Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




4 posts

Wannabe Geek


# 108208 26-Aug-2012 18:45
Send private message

Hi there, I've been struggling with this problem for several weeks now and it's time for me to bite the bullet and get some help.

I've got a Western Digital My Book World Edition II (White Light) NAS server; it has 2x1Tb drives with volumes configured in Raid-1. It runs some distribution of Busybox I believe.

I was planning to upgrade this box to 2x3Tb drives, which I was successful at doing. Everything came unstuck when I put one of the 1Tb drives into my PC running Ubuntu and tried to access the data partition on the original drives.

It should be as simple as mounting the 4th partition, /dev/sda4 and accessing the data but unfortunately on both drives that volume has no filesystem information. I've tried all sorts of ways to try to recover the filesystem but either it is beyond me, or there is a proprietory Raid1 format that WD uses.
(Note that the boot volume and the swapdisk volumes can be assembled into Raid 1 arrays and accessed with no issues).


Long story short - when I put the original 1Tb drives (either both or just one) into the NAS, it no longer boots successfully.
The data partitions on the original drives are of unknown filesystem type and I have been unable to mount them.
The only success I've had is with a piece of recovery software called R-Studio which has found all of the files but there are no names, and no directory structure.

This success gives me hope that I may still be able to find a 'good' solution. I want to either: mount the data partition in Linux and recover the data; OR fix the Linux distribution so that the NAS server can boot up and then access the data.



I'd appreciate any tips, advice or expertise, and I'm more than willing at this stage to hire someone to sort this problem out safely without losing the data.


Create new topic
164 posts

Master Geek


  # 677694 27-Aug-2012 16:16
Send private message

You are not the first person I know to have this issue with WD gear. Hopefully someone here can help you.



4 posts

Wannabe Geek


  # 677705 27-Aug-2012 16:41
Send private message

Thanks, did they find a good solution for this - perhaps you could show them this post?

 
 
 
 


164 posts

Master Geek


  # 677710 27-Aug-2012 16:53
Send private message

Sorry the solution was 

1.Rubbish bin
2.Not to by WD Nas drives again.



4 posts

Wannabe Geek


  # 677718 27-Aug-2012 17:06
Send private message

Ha, thanks but I'm optimistic that there's a solution that's beyond my noob linux skills.

275 posts

Ultimate Geek


  # 677720 27-Aug-2012 17:12
Send private message

I have found EasyRecovery Professional ( http://www.softpedia.com/get/System/Back-Up-and-Recovery/EasyRecovery-Professional-Standard-Edition.shtml )
really good at recovering from RAW partitions, if that doesn't work I usually try test disk in a linux environment on deep scan.




"The Atlantis base, brings greetings from the pegasus galaxy, you may cut power to the gate!."- Dr Weir (Rising) New Zealand · Luke.Geek.NZ




4 posts

Wannabe Geek


  # 677734 27-Aug-2012 18:17
Send private message

Thanks! I haven't tried that one out yet - I'll give it a go tonight.

Create new topic



Twitter and LinkedIn »



Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

Chorus to launch Hyperfibre service
Posted 18-Nov-2019 15:00


Microsoft launches first Experience Center worldwide for Asia Pacific in Singapore
Posted 13-Nov-2019 13:08


Disney+ comes to LG Smart TVs
Posted 13-Nov-2019 12:55


Spark launches new wireless broadband "Unplan Metro"
Posted 11-Nov-2019 08:19


Malwarebytes overhauls flagship product with new UI, faster engine and lighter footprint
Posted 6-Nov-2019 11:48


CarbonClick launches into Digital Marketplaces
Posted 6-Nov-2019 11:42


Kordia offers Microsoft Azure Peering Service
Posted 6-Nov-2019 11:41


Spark 5G live on Auckland Harbour for Emirates Team New Zealand
Posted 4-Nov-2019 17:30


BNZ and Vodafone partner to boost NZ Tech for SME
Posted 31-Oct-2019 17:14


Nokia 7.2 available in New Zealand
Posted 31-Oct-2019 16:24


2talk launches Microsoft Teams Direct Routing product
Posted 29-Oct-2019 10:35


New Breast Cancer Foundation app puts power in Kiwi women's hands
Posted 25-Oct-2019 16:13


OPPO Reno2 Series lands, alongside hybrid noise-cancelling Wireless Headphones
Posted 24-Oct-2019 15:32


Waikato Data Scientists awarded $13 million from the Government
Posted 24-Oct-2019 15:27


D-Link launches Wave 2 Unified Access Points
Posted 24-Oct-2019 15:07



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.


Support Geekzone »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.