Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




1703 posts

Uber Geek

Subscriber

# 109335 18-Sep-2012 13:58
Send private message

Hi guys,

I am not a newbie by any stretch but I am no expert either. I have had a Mini-ITX box running Ubuntu Server as a headless server for the last few years. It runs my Squeezebox software, acts as a NAS and serves up my movies via Plex. All was working just fine.

The PC had a 160GB HDD for the OS and a 500GB for /home - where all my media was stored.

Then I upgraded my hardware with a new MOBO and case etc. This included a new 2TB HDD for /home but I took the old 160GB out of the old PC and used it for the OS drive in the new box (repartitioning etc).

The new box is purring along nicely.

I decided I would try out XMBC on the old box, since it still had the 500GB HDD in there. I downloaded the XMBC image and built a bootable USB stick using Universal-USB-Installer-1.9.0.5. I tested this on my Windows 7 laptop and could boot into it and run XMBC in 'live' mode.

When I try to boot into the USB stick on the old Mini-ITX PC I get as far as the 'Boot from CD: ' prompt and nothing happens. I have gone into the BIOS and made sure it is configured to boot from USB first but no luck.

I also tried booting from a Windows XP install DVD I had lying around, but again nothing happens post the 'Boot from CD ' prompt. Again, I ensure the BIOS was configured to boot from the CDROM drive before any HDD.

Even if I don't have any bootable media attached if I try to boot it doesn't even prompt me to say the HDD is not bootable or no OS is found. Remember the HDD is the /home partition from the old headless server, so has no OS etc.

I am a bit stumped as to how I can get this PC to boot - into anything! I want to re-partition the HDD and install XMBC as a trial, and potentially reinstall Ubuntu Server and build a simple NAS for my brother.

Any ideas on what I am doing wrong? I hope I have given enough details so you can offer some suggestions?!

Cheers,
Ben



Create new topic
30 posts

Geek


  # 688022 19-Sep-2012 09:39
Send private message

Usb boot can be tricky. There are options - grub, syslinux, isolinux. I've had PCs where one would work but not others. Depends on the PC's bios. Booting from an optical drive is most reliable but you tried that. Another way is to take the hdd out, partition it on another computer placing on it the boot files of the CD, fixing it to boot, put the hdd back. Depends on the booting method of the original CD.



1703 posts

Uber Geek

Subscriber

  # 688039 19-Sep-2012 10:06
Send private message

Yeah I have previously been able to boot this MOBO from the CDROM drive (which hasn't changed) so the fact this isn't working is what is worrying me.

Surely the fact the HDD is not bootable has no bearing on things - the BIOS should boot from an attached CDROM in this case just fine?

Is it possible my MOBO is stuffed? I have tried a factory reset of the BIOS by setting a jump, powering on (nothing happened - no lights etc), powering off, resetting the jumper and powering on again.

But this didn't help either.

 
 
 
 


gzt

11052 posts

Uber Geek


  # 688110 19-Sep-2012 11:54
Send private message

Try a gparted live cdr.

30 posts

Geek


  # 688120 19-Sep-2012 12:06
Send private message

If your system doesn't boot in any way it is going to suck because it's good as dead. Just go through the ports one at a time, sata and ide, different usb ports perhaps, seeing if one might work. Unplug all the cables to the other storage devices.



1703 posts

Uber Geek

Subscriber

  # 688136 19-Sep-2012 12:38
Send private message

Tried gparted, no good. Tried a Ubuntu Live CD/USB boot image, no good.

The MOBO just refuses to boot. When trying with a USB boot image, the BIOS lists the USB drive so I am pretty sure it is connecting ok, it just refuses to boot off anything. And as already mentioned, I have tried my CDROM - again nothing.

I have tried both USB ports with my USB stick, and tried the HDD in both SATA ports.

Is my MOBO dead?!

gzt

11052 posts

Uber Geek


  # 688137 19-Sep-2012 12:49
Send private message

it may be a bios problem - but you have already tried a reset.

check the manual for the exact reset method to be sure.

removing the bios battery for 10 minutes or even longer if you want to be sure should also cause it to lose current bios setting state.

you could also try a reset or load setup default from inside the bios if you have not done so already.

btw, if you can get into bios there may be an option to load a new bios image (bios flash) without needing to boot from anything. flash with the same bios version if it will let you but you might have to go up one.



1703 posts

Uber Geek

Subscriber

  # 688145 19-Sep-2012 12:51
Send private message

Yep - tried resetting all BIOS settings to 'fail-safe' and 'default-optimized' - but neither any good.

I will have a look and see if I can reload a BIOS image.

Thanks for the tips.

Create new topic



Twitter and LinkedIn »



Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

Vodafone New Zealand starts two year partnership with LetsPlay.Live
Posted 28-Jan-2020 11:24


Ring launches indoor-only security camera
Posted 23-Jan-2020 17:26


New report findings will help schools implement the digital technologies curriculum content
Posted 23-Jan-2020 17:25


N4L to upgrade & support wireless internet inside schools
Posted 23-Jan-2020 17:22


Netflix releases 21 Studio Ghibli works
Posted 22-Jan-2020 11:42


Vodafone integrates eSIM into device and wearable roadmap
Posted 17-Jan-2020 09:45


Do you need this camera app? Group investigates privacy implications
Posted 16-Jan-2020 03:30


JBL launches headphones range designed for gaming
Posted 13-Jan-2020 09:59


Withings introduces ScanWatch wearable combining ECG and sleep apnea detection
Posted 9-Jan-2020 18:34


NZ Police releases public app
Posted 8-Jan-2020 11:43


Suunto 7 combine sports and smart features on new smartwatch generation
Posted 7-Jan-2020 16:06


Intel brings innovation with technology spanning the cloud, network, edge and PC
Posted 7-Jan-2020 15:54


AMD announces high performance desktop and ultrathin laptop processors
Posted 7-Jan-2020 15:42


AMD unveils four new desktop and mobile GPUs including AMD Radeon RX 5600
Posted 7-Jan-2020 15:32


Consolidation in video streaming market with Spark selling Lightbox to Sky
Posted 19-Dec-2019 09:09



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.


Support Geekzone »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.