Geekzone: technology news, blogs, forums
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.

2 posts

Wannabe Geek

# 138707 14-Jan-2014 12:31
Send private message


I've got a bit of an odd issue with a client who is running NZA Gold with a USB connected HP 7500A printer and Windows 7 x86 - a less than ideal configuration, but it's the software the client wants to use and no amount of promoting the benefits of MYOB seems to change their mind.

For more than 12 months this combination worked really well - NZA Gold would quite happily print invoices and statements to the HP 7500A. But just before Christmas, NZA Gold print jobs just started disappearing for no good reason.

On testing I discovered that should the default Windows printer (that 7500A) get changed to another printer and then switched back, the first print job from NZA Gold prints fine. However each subsequent job disappears until the default is switched again. I then tested to see if NZA Gold would print to another printer, which it does happily and consistently - so it's an issue with the HP7500A software.

I then removed all printer queues and drivers from the Registry and System32 directory and did a clean install of the HP printer - however on re-installation exactly the same problem resurfaced. I then remembered to check the Windows Error Logs, where it appears to indicate a privilege problem writing to the Windows Spool directory each time the 7500A is used with NZA Gold. So I created a new spool directory with global access and directed the spooler to use that, but still the same error.

As a last gasp effort, I configured the 7500A on the client's LAN and set up generic HP PCL5e and PCL6 queues to print to the printers Jet Direct card, but for whatever reason the HP 7500A doesn't understand normal PCL and all that resulted was junk.

As a side note, every other program on the machine seems to run fine with the 7500A.

Would anyone happen to have any thoughts on what could be causing these jobs to fail?

Many Thanks, Steve.

If it helps, here is a sample error log:

Log Name: Microsoft-Windows-PrintService/Admin
Source: Microsoft-Windows-PrintService
Date: 16/12/2013 10:33:37 p.m.
Event ID: 372
Task Category: Printing a document
Level: Error
Keywords: Classic Spooler Event,Document Print Job
User: IANHP\I** *****
Computer: IanHP
The document Crystal Reports, owned by *** *****, failed to print on printer HP Officejet
7500a. Try to print the document again, or restart the print spooler.
Data type: NT EMF 1.008. Size of the spool file in bytes: 8712. Number of bytes printed: 0.
Total number of pages in the document: 2. Number of pages printed: 0. Client computer:
\\IANHP. Win32 error code returned by the print processor: 5. Access is denied.
Event Xml:
<Event xmlns="">
<Provider Name="Microsoft-Windows-PrintService" Guid="{747EF6FD-E535-4D16-B510-
42C90F6873A1}" />
<TimeCreated SystemTime="2013-12-16T09:33:37.708457800Z" />
<Correlation />
<Execution ProcessID="1548" ThreadID="3784" />
<Security UserID="S-1-5-21-3754063858-2367217974-3444804509-1001" />
<PrintOnProcFailedEd xmlns:autons3=""
<Param1>Crystal Reports</Param1>
<Param2>I** *****</Param2>
<Param3>HP Officejet 7500a</Param3>
<Param4>NT EMF 1.008</Param4>
<Param11>Access is denied.

[Mod Edit |BH| Removed customers name]

Create new topic
3754 posts

Uber Geek
+1 received by user: 2222

Lifetime subscriber

  # 966766 14-Jan-2014 13:07
Send private message

Two lines under where you ***'d your customers username, you missed your customers username.

Information wants to be free. The Net interprets censorship as damage and routes around it.

3754 posts

Uber Geek
+1 received by user: 2222

Lifetime subscriber

  # 966772 14-Jan-2014 13:19
Send private message

I notice it's printing via Crystal Reports, does anything else on the PC use Crystal Reports? Try reinstalling the CR redistributable perhaps.

Information wants to be free. The Net interprets censorship as damage and routes around it.


2 posts

Wannabe Geek

  # 966807 14-Jan-2014 13:57
Send private message

Thanks Lias,

Oops. I must still be in holiday mode missing out that detail. I can't seem to find any way to edit the original post though!

With Crystal Reports, I did consider doing an installation. But NZA Gold seems have the Crystal Report binaries scattered in amongst the rest of the NZA program directories - so I backed out of that one as there was a good chance I was going to break everything.

Also, as NZA seems to work other printers I'm not sure the Crystal Reports is at play in this problem. However I'd be gladly proven wrong!



8 posts

Wannabe Geek

  # 1164150 29-Oct-2014 10:14
Send private message

Hi Falbs,

Did you have any success with this? I've been banging my head against the wall trying to get my mother's NZAGold to print to either of her printers. It was working on her old XP system, but she's upgraded to a new Win7 system and it's not working with either of her USB printers (Brother Laser and Canon Inkjet).

Weirdly, printing reports from NZAGold works just fine, but the custom forms aren't. The workaround we're using is to print to CutePDF, which works as saving it to a PDF file, and then printing the PDF file from adobe. This works, but obviously makes printing reports a hassle.

I could roll her new system back to XP if needs be, or maybe try an XP Virtual Machine inside Win7, but it seems like NZAGold can talk to the printer just fine for reports, just something in the way it handles the printing of custom reports that's not working.

My symptoms are exactly the same as you had.... the print command executes, but nothing gets added to the printer queue. I too get an "Access Denied" error in the event viewer.

I've tried everything I can find on google, making sure everything has the right permissions etc, and nothing's fixed it, so it seems very much like it's something in the way that NZAGold is handling the print command.



Create new topic

Twitter and LinkedIn »

Follow us to receive Twitter updates when new discussions are posted in our forums:

Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:

Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:

News »

Dunedin selects Telensa to deliver smart street lighting for 15,000 LEDs
Posted 18-Jul-2019 10:21

Sprint announces a connected wallet card with built-in IoT support
Posted 18-Jul-2019 08:36

Educational tool developed at Otago makes international launch
Posted 17-Jul-2019 21:57

Symantec introduces cloud access security solution
Posted 17-Jul-2019 21:48

New Zealand government unveils new digital service to make business easier
Posted 16-Jul-2019 17:35

Scientists unveil image of quantum entanglement
Posted 13-Jul-2019 06:00

Hackers to be challenged at University of Waikato
Posted 12-Jul-2019 21:34

OPPO Reno Z now available in New Zealand
Posted 12-Jul-2019 21:28

Sony introduces WF-1000XM3 wireless headphones with noise cancellation
Posted 8-Jul-2019 16:56

Xero announces new smarter tools, push into the North American market
Posted 19-Jun-2019 17:20

New report by Unisys shows New Zealanders want action by social platform companies and police to monitor social media sites
Posted 19-Jun-2019 17:09

ASB adds Google Pay option to contactless payments
Posted 19-Jun-2019 17:05

New Zealand PC Market declines on the back of high channel inventory, IDC reports
Posted 18-Jun-2019 17:35

Air New Zealand uses drones to inspect aircraft
Posted 17-Jun-2019 15:39

TCL Electronics launches its first-ever 8K TV
Posted 17-Jun-2019 15:18

Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.

Support Geekzone »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron

Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.