Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.


291 posts

Ultimate Geek
+1 received by user: 29


Topic # 230474 25-Feb-2018 19:09
Send private message

Got a bug here that is driving me crazy. I had Windows 10 Pro V1709 32bit running on RAID1 (mirrored). This PC was running very slow after KB4074588 (but that is another story), so I decided to replace the two mirrored 500GB HDDs with a 500GB SSD.


Step one was to disable raid at boot up. No problems there. Next, change the SATA RAID option in BIOS to AHCI, and do a Safe Boot into the OS, then a normal restart. No problems there. Successfully changed Windows from RAID to AHCI using this guide:


https://triplescomputers.com/blog/uncategorized/solution-switch-windows-10-from-raidide-to-ahci-operation/


I then installed the Samsung EVO 860 500GB SSD, using the Samsung migration software to clone the two partitions on the HDD (OS and DATA partitions).


We use the ancient Lotus Approach database software (Lotus Smartsuite V. 9.8). The program is installed on C: drive (where Windows resides) and the folder with the database resides on a partition called DATA (E:) on the same HDD. After cloning the HDD to the SSD, the .dbf files on DATA partition (now on the SSD) are all read-only. If I open the database on the source HDD, it opens without the read-only warning. I thought this might be a Windows permissions problem, so I deleted the database folder on DATA SSD partition and used XCOPY /O /X /E /H /K to copy all permissions. Still got the read-only warning.


Tried to change the read-only permissions in Lotus Approach. File menu, choose User Setup --> Approach Preferences --> Database panel, but the "Make all fields in database read only" checkbox has a greyed out tick which I cannot remove. So I thought this might be something to do with the database being on the SSD. I next booted up using one of the originally mirrored HDDs, but this time I got the same problem with the HDD: Approach produced the read-only error on the DATA HDD partition (which had formerly produced no error when I booted from the SSD), but strangely, if I opened the database files on the DATA SSD partition, they now open without the read-only warning. It seems that since I split the RAID mirror, Lotus approach gives me a Read-Only message if the database files are stored on the same disk as the OS. This happens both on the SSD and the HDD. If I boot from a particular disk (SSD or HDD), I can only avoid the read-only warning by opening the database files on a partition on another disk.


What I want to do is remove the HDDs and just use the SSD, but since access to the Approach database is critical, I can't do this without solving this issue.


Hope somebody out there might release what is causing this.


Many thanks,


Tim


Create new topic


291 posts

Ultimate Geek
+1 received by user: 29


  Reply # 1964373 26-Feb-2018 12:18
Send private message

Fixed it. Cloning error with Samsung Data Migration software. Did it with Acronis True Image and everything worked.


Create new topic

Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

Targus set sights on enterprise and consumer growth in New Zealand
Posted 13-Aug-2018 13:47


Huawei to distribute nova 3i in New Zealand
Posted 9-Aug-2018 16:23


Home robot Vector to be available in New Zealand stores
Posted 9-Aug-2018 14:47


Panasonic announces new 2018 OLED TV line up
Posted 7-Aug-2018 16:38


Kordia completes first live 4K TV broadcast
Posted 1-Aug-2018 13:00


Schools get safer and smarter internet with Managed Network Upgrade
Posted 30-Jul-2018 20:01


DNC wants a safer .nz in the coming year
Posted 26-Jul-2018 16:08


Auldhouse becomes an AWS Authorised Training Delivery Partner in New Zealand
Posted 26-Jul-2018 15:55


Rakuten Kobo launches Kobo Clara HD entry level reader
Posted 26-Jul-2018 15:44


Kiwi team reaches semi-finals at the Microsoft Imagine Cup
Posted 26-Jul-2018 15:38


KidsCan App to Help Kiwi Children in Need
Posted 26-Jul-2018 15:32


FUJIFILM announces new high-performance lenses
Posted 24-Jul-2018 14:57


New FUJIFILM XF10 introduces square mode for Instagram sharing
Posted 24-Jul-2018 14:44


OPPO brings advanced technology to the smartphone market with new device
Posted 24-Jul-2018 09:20


Hawaiki Transpacific cable ready-for-service
Posted 20-Jul-2018 11:29



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.