Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




656 posts

Ultimate Geek
+1 received by user: 107


Topic # 57994 3-Mar-2010 21:33
Send private message

Hey everyone,

I was wondering if anyone could shed some light on my issue.

I have a viewsonic VX922 LCD (19"). It wont work properly.

The yellow power light is flashing on and off, slowly. At the same time the monitor screen or backlight (nothing visable except a slight bit of light, no colour) seems to flash on/off very briefly(split second - can only see this up close).

It only does the above when it is plugged into a source, its like its set to the wrong resolution.

If i unplug/deactivate the source it displays "no signal" so the screen works fine. Also the backlight lights up the "no signal" fine.


Its like when you change resolution on your display it turns off then on, except on this it isnt coming back on.


I have tried this on a different computer and during boot. I ask this because it is out of warrenty and the screen seems to be functioning fine apart from this issue.

Previously it rarely had this issue, it just became more and more regular and now it will not turn on properly.


Any help would be greatly apreactiated =)

Create new topic
195 posts

Master Geek
+1 received by user: 9


  Reply # 305288 8-Mar-2010 00:53
Send private message

Sounds like you might have some faulty capacitors on the board... http://www.aplusperfect.com/articles/lcd_capacitor_repair might help if you're not afraid of a soldering iron? I've had a few LCDs at the office do the same sort of thing.



656 posts

Ultimate Geek
+1 received by user: 107


  Reply # 305289 8-Mar-2010 01:17
Send private message

fastmikey: Sounds like you might have some faulty capacitors on the board... http://www.aplusperfect.com/articles/lcd_capacitor_repair might help if you're not afraid of a soldering iron? I've had a few LCDs at the office do the same sort of thing.


Cheers for that reply!

I might give this a go, nothing to lose afterall.


Create new topic



Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

New Zealand hits peak broadband data
Posted 18-Jan-2018 12:21


Amazon Echo devices coming to New Zealand early February 2018
Posted 18-Jan-2018 10:53


$3.74 million for new electric vehicles in New Zealand
Posted 17-Jan-2018 11:27


Nova 2i: Value, not excitement from Huawei
Posted 17-Jan-2018 09:02


Less news in Facebook News Feed revamp
Posted 15-Jan-2018 13:15


Australian Government contract awarded to Datacom Connect
Posted 11-Jan-2018 08:37


Why New Zealand needs a chief technology officer
Posted 6-Jan-2018 13:59


Amazon release Silk Browser and Firefox for Fire TV
Posted 21-Dec-2017 13:42


New Chief Technology Officer role created
Posted 19-Dec-2017 22:18


All I want for Christmas is a new EV
Posted 19-Dec-2017 19:54


How clever is this: AI will create 2.3 million jobs by 2020
Posted 19-Dec-2017 19:52


NOW to deploy SD-WAN to regional councils
Posted 19-Dec-2017 19:46


Mobile market competition issues ComCom should watch
Posted 18-Dec-2017 10:52


New Zealand government to create digital advisory group
Posted 16-Dec-2017 08:47


Australia datum changes means whole country moving 1.8 metres north-east
Posted 16-Dec-2017 08:39



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.