Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.


grantvand

13 posts

Geek


#8451 30-Jun-2006 21:05
Send private message

Unable to synchronise calendar appointments between Windows SBS2003 and Windows Mobile device using ActiveSync.
Have seen a couple of related posts on the site, but no definite answers. Has anyone got any more info on this?

Here's the detail:
Running Windows SBS 2003. Latest patches for SBS2003 and Exchange 2003 SP2 installed.
Have tried both an iMate JAM and an iMate JASJAR. JASJAR has latest updates.
ActiveSync runs find on both iMates and no errors are reported, but appointments are never added to the iMate's Calendar.
Note the email sync via ActiveSync is working fine.
iMate is set to sync the last 2 weeks and all future appointments.

Here's the scenario:
Two email accounts A and B.
Account A is an external email account.
Account B is on the the SBS2003 server/Exchange Server 2003SP2. Account B ist is accessed either from Outlook 2003 on a PC, or from Exchange ActiveSync on the iMate.
Account A sends a meeting request to Account B. If Account B accepts the meeting request via Outlook 2003 on their PC, the meeting is added to the PC's calendar, but on subsequent Exchange Activesyncs, the iMate never receives the appointment

Instead, if I accept the meeting request on the iMate instead of Outlook 2003 on the PC, this works fine and the appointments is added to the iMate's calendar.

Have tested this on several email accounts on the same server, and with the same results.

Has anyone got any guidance on this one?

Create new topic
freitasm
BDFL - Memuneh
68854 posts

Uber Geek

Administrator
Trusted
Geekzone
Lifetime subscriber

#40241 30-Jun-2006 22:24
Send private message

Are these calendars using the default folder? ActiveSync will only synchronise the default folders. Check that these are not in a subfolder or another new folder.





 

 

These links are referral codes

 

Geekzone broadband switch | Eletcricity comparison and switch | Hatch investment (NZ$ 10 bonus if NZ$100 deposited within 30 days) | Sharesies | Mighty Ape | Backblaze | Coinbase | TheMarket | My technology disclosure


wirelessluva
14 posts

Geek


  #40275 1-Jul-2006 15:09
Send private message

A couple of things to try :

1 - Set Calendar sync settings to All instead of 2 weeks on the device?
2 - If you are running antivirus on the server - this could be affecting it.


 
 
 
 


freitasm
BDFL - Memuneh
68854 posts

Uber Geek

Administrator
Trusted
Geekzone
Lifetime subscriber

#40276 1-Jul-2006 15:34
Send private message

Yes, there are some cases where AV software on the server are not fast enough and the scan is not finished before the synchronisation times out. You would find this in the Event Viewer on the server. Also, you can set the ActiveSync log to Verbose on the device and look at the log files. They will show you where it stops.






 

 

These links are referral codes

 

Geekzone broadband switch | Eletcricity comparison and switch | Hatch investment (NZ$ 10 bonus if NZ$100 deposited within 30 days) | Sharesies | Mighty Ape | Backblaze | Coinbase | TheMarket | My technology disclosure


grantvand

13 posts

Geek


  #40360 3-Jul-2006 11:34
Send private message

Have tried all the above suggestions without luck, specifically:
1) Changed Calendar sync to All (instead of past 2 weeks only) - no change
2) Disabled email antivirus program - no change (FYI am running Symantec Mail Security for Exchange version 5.0.2.221)
3) Disabled server AV realtime monitoring - no change (FYI am running Symantec AV Corp Edition version 10.0.2.221)
4) Calendar is definitely in default folder

Server Event Viewer does not show any errors or warnings, just the normal Information stuff.

Have set the JasJar to verbose logging. Here is the output from the log file for 2 separate attempts. I don't think there is anything unusual here.

*************************
Attempt1
*************************
=-= Build 14847 =-=
=-= No XIP Information Available =-=
<<server name omitted>>

=-=- [3/7/2006 11:22:41.0] -=-=
=-=-=-= Client Request =-=-=-=
POST Microsoft-Server-ActiveSync?User=<<removed>>&DeviceId=<<removed>>&DeviceType=PocketPC&Cmd=GetItemEstimate
Accept-Language: en-gb
MS-ASProtocolVersion: 2.5
Content-Type: application/vnd.ms-sync.wbxml
X-MS-PolicyKey: 0

-=-=-=- Start of Body -=-=-=-
<?xml version="1.0" encoding="utf-8"?><GetItemEstimate xmlns="GetItemEstimate:" xmlns:A="AirSync:"><Collections><Collection><Class>Contacts</Class><CollectionId>24bf9e108815a64380ff825f1c70cdc1-1fa0</CollectionId><A:FilterType>0</A:FilterType><A:SyncKey>{1BAAFF6D-DDEA-4780-8F47-872A80B6C577}3</A:SyncKey></Collection><Collection><Class>Calendar</Class><CollectionId>24bf9e108815a64380ff825f1c70cdc1-1f9f</CollectionId><A:FilterType>0</A:FilterType><A:SyncKey>{FFF0849D-D2BF-47CD-A3FF-3582DC40980A}5</A:SyncKey></Collection><Collection><Class>Email</Class><CollectionId>24bf9e108815a64380ff825f1c70cdc1-399d</CollectionId><A:FilterType>2</A:FilterType><A:SyncKey>{0B79BE2A-5257-447A-A4E6-27C6EC5521EB}5</A:SyncKey></Collection><Collection><Class>Tasks</Class><CollectionId>24bf9e108815a64380ff825f1c70cdc1-1fa4</CollectionId><A:FilterType>0</A:FilterType><A:SyncKey>{BFACAFA6-B9F8-4F80-A473-817F1AC9B5A6}2</A:SyncKey></Collection></Collections></GetItemEstimate>

=-=- [3/7/2006 11:22:43.0] -=-=
=-=-=-= Server Response =-=-=-
HTTP/1.1 200 OK
Date: Sun, 02 Jul 2006 23:24:25 GMT
Server: Microsoft-IIS/6.0
MicrosoftOfficeWebServer: 5.0_Pub
X-Powered-By: ASP.NET
Pragma: no-cache
Content-Type: application/vnd.ms-sync.wbxml
Content-Length: 270
MS-Server-ActiveSync: 6.5.7638.1


-=-=-=- Start of Body -=-=-=-
<?xml version="1.0" encoding="utf-8"?><GetItemEstimate xmlns="GetItemEstimate:"><Response><Status>1</Status><Collection><Class>Contacts</Class><CollectionId>24bf9e108815a64380ff825f1c70cdc1-1fa0</CollectionId><Estimate>0</Estimate></Collection></Response><Response><Status>1</Status><Collection><Class>Calendar</Class><CollectionId>24bf9e108815a64380ff825f1c70cdc1-1f9f</CollectionId><Estimate>0</Estimate></Collection></Response><Response><Status>1</Status><Collection><Class>Email</Class><CollectionId>24bf9e108815a64380ff825f1c70cdc1-399d</CollectionId><Estimate>0</Estimate></Collection></Response><Response><Status>1</Status><Collection><Class>Tasks</Class><CollectionId>24bf9e108815a64380ff825f1c70cdc1-1fa4</CollectionId><Estimate>0</Estimate></Collection></Response></GetItemEstimate>

*************************
Attempt2
*************************
=-= Build 14847 =-=
=-= No XIP Information Available =-=
<<removed>>

=-=- [3/7/2006 11:6:27.0] -=-=
=-=-=-= Client Request =-=-=-=
POST Microsoft-Server-ActiveSync?User=<<removed>>&DeviceId=<<removed>>&DeviceType=PocketPC&Cmd=FolderSync
Accept-Language: en-gb
MS-ASProtocolVersion: 2.5
Content-Type: application/vnd.ms-sync.wbxml
X-MS-PolicyKey: 0

-=-=-=- Start of Body -=-=-=-
<?xml version="1.0" encoding="utf-8"?><FolderSync xmlns="FolderHierarchy:"><SyncKey>{AF0619D7-E914-424C-81E1-DE25FBE367BF}1</SyncKey></FolderSync>

=-=- [3/7/2006 11:6:32.0] -=-=
=-=-=-= Server Response =-=-=-
HTTP/1.1 200 OK
Date: Sun, 02 Jul 2006 23:08:14 GMT
Server: Microsoft-IIS/6.0
MicrosoftOfficeWebServer: 5.0_Pub
X-Powered-By: ASP.NET
Pragma: no-cache
Content-Type: application/vnd.ms-sync.wbxml
Content-Length: 63
MS-Server-ActiveSync: 6.5.7638.1


-=-=-=- Start of Body -=-=-=-
<?xml version="1.0" encoding="utf-8"?><FolderSync xmlns="FolderHierarchy:"><Status>1</Status><SyncKey>{AF0619D7-E914-424C-81E1-DE25FBE367BF}1</SyncKey><Changes><Count>0</Count></Changes></FolderSync>

=-=- [3/7/2006 11:6:33.0] -=-=
=-=-=-= Client Request =-=-=-=
POST Microsoft-Server-ActiveSync?User=<<removed>>&DeviceId=<<removed>>&DeviceType=PocketPC&Cmd=GetItemEstimate
Accept-Language: en-gb
MS-ASProtocolVersion: 2.5
Content-Type: application/vnd.ms-sync.wbxml
X-MS-PolicyKey: 0

-=-=-=- Start of Body -=-=-=-
<?xml version="1.0" encoding="utf-8"?><GetItemEstimate xmlns="GetItemEstimate:" xmlns:A="AirSync:"><Collections><Collection><Class>Contacts</Class><CollectionId>24bf9e108815a64380ff825f1c70cdc1-1fa0</CollectionId><A:FilterType>0</A:FilterType><A:SyncKey>{1BAAFF6D-DDEA-4780-8F47-872A80B6C577}3</A:SyncKey></Collection><Collection><Class>Calendar</Class><CollectionId>24bf9e108815a64380ff825f1c70cdc1-1f9f</CollectionId><A:FilterType>0</A:FilterType><A:SyncKey>{FFF0849D-D2BF-47CD-A3FF-3582DC40980A}5</A:SyncKey></Collection><Collection><Class>Email</Class><CollectionId>24bf9e108815a64380ff825f1c70cdc1-399d</CollectionId><A:FilterType>2</A:FilterType><A:SyncKey>{0B79BE2A-5257-447A-A4E6-27C6EC5521EB}5</A:SyncKey></Collection><Collection><Class>Tasks</Class><CollectionId>24bf9e108815a64380ff825f1c70cdc1-1fa4</CollectionId><A:FilterType>0</A:FilterType><A:SyncKey>{BFACAFA6-B9F8-4F80-A473-817F1AC9B5A6}2</A:SyncKey></Collection></Collections></GetItemEstimate>

=-=- [3/7/2006 11:6:34.0] -=-=
=-=-=-= Server Response =-=-=-
HTTP/1.1 200 OK
Date: Sun, 02 Jul 2006 23:08:15 GMT
Server: Microsoft-IIS/6.0
MicrosoftOfficeWebServer: 5.0_Pub
X-Powered-By: ASP.NET
Pragma: no-cache
Content-Type: application/vnd.ms-sync.wbxml
Content-Length: 270
MS-Server-ActiveSync: 6.5.7638.1


-=-=-=- Start of Body -=-=-=-
<?xml version="1.0" encoding="utf-8"?><GetItemEstimate xmlns="GetItemEstimate:"><Response><Status>1</Status><Collection><Class>Contacts</Class><CollectionId>24bf9e108815a64380ff825f1c70cdc1-1fa0</CollectionId><Estimate>0</Estimate></Collection></Response><Response><Status>1</Status><Collection><Class>Calendar</Class><CollectionId>24bf9e108815a64380ff825f1c70cdc1-1f9f</CollectionId><Estimate>0</Estimate></Collection></Response><Response><Status>1</Status><Collection><Class>Email</Class><CollectionId>24bf9e108815a64380ff825f1c70cdc1-399d</CollectionId><Estimate>0</Estimate></Collection></Response><Response><Status>1</Status><Collection><Class>Tasks</Class><CollectionId>24bf9e108815a64380ff825f1c70cdc1-1fa4</CollectionId><Estimate>0</Estimate></Collection></Response></GetItemEstimate>


freitasm
BDFL - Memuneh
68854 posts

Uber Geek

Administrator
Trusted
Geekzone
Lifetime subscriber

#40363 3-Jul-2006 11:49
Send private message

There was a similar discussion a few months ago (http://www.geekzone.co.nz/forums.asp?forumid=6&topicid=6788) and after getting involvement from Microsoft it sounds as it was a problem on the server side. something with access rights, or other configuration. Is this Exchange a single instance, or is there a front end instance?

The discussion also has some links to a couple of KB on Microsoft and Sophos (AV software) about this issue.

Have a read through it and see if it helps.





 

 

These links are referral codes

 

Geekzone broadband switch | Eletcricity comparison and switch | Hatch investment (NZ$ 10 bonus if NZ$100 deposited within 30 days) | Sharesies | Mighty Ape | Backblaze | Coinbase | TheMarket | My technology disclosure


grantvand

13 posts

Geek


  #40430 4-Jul-2006 10:01
Send private message

Thanks for the info. The server is a single instance.
Still haven't managed to get this working, but thought I would share further information to date:

1) Microsoft have issued hotfix for a similar problem - see http://support.microsoft.com/kb/894065/en-us
I have contacted Microsoft, installed the HotFix and restarted the server with no change to my problem

2) My next step is to try the steps outlined in Microsoft KB 883380 - see http://support.microsoft.com/kb/883380/en-us
I'm clutching at straws here, but at this stage am prepared to give anything a go.

Will give a further update after I have applied (2) above. Watch this space!!

Create new topic





News »

Huawei introduces new features to Petal Search, Maps and Docs
Posted 26-Oct-2020 18:05


Nanoleaf enhances lighting line with launch of Triangles and Mini Triangles
Posted 17-Oct-2020 20:18


Synology unveils DS16211+
Posted 17-Oct-2020 20:12


Ingram Micro introduces FootfallCam to New Zealand channel
Posted 17-Oct-2020 20:06


Dropbox adopts Virtual First working policy
Posted 17-Oct-2020 19:47


OPPO announces Reno4 Series 5G line-up in NZ
Posted 16-Oct-2020 08:52


Microsoft Highway to a Hundred expands to Asia Pacific
Posted 14-Oct-2020 09:34


Spark turns on 5G in Auckland
Posted 14-Oct-2020 09:29


AMD Launches AMD Ryzen 5000 Series Desktop Processors
Posted 9-Oct-2020 10:13


Teletrac Navman launches integrated multi-camera solution for transport and logistics industry
Posted 8-Oct-2020 10:57


Farmside hits 10,000 RBI customers
Posted 7-Oct-2020 15:32


NordVPN starts deploying colocated servers
Posted 7-Oct-2020 09:00


Google introduces Nest Wifi routers in New Zealand
Posted 7-Oct-2020 05:00


Orcon to bundle Google Nest Wifi router with new accounts
Posted 7-Oct-2020 05:00


Epay and Centrapay partner to create digital gift cards
Posted 2-Oct-2020 17:34









Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.


Support Geekzone »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.