Geekzone: technology news, blogs, forums
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.

66 posts

Master Geek

Topic # 114324 15-Feb-2013 19:05 Send private message

Well, me again . I think you will be sick and tired of me by now... :)

I have been having this strange problem for a while, but because I wasn't too fussed about it I never bothered asking. I have an Elastix Box (Ver 2.3.0) on which I now have 3 VfX lines. (Getting more and more! )

The problem is that, although all can receive calls, only one can make calls. I use the same settings in all of them, but only my oldest number 9950xxx2 is able to make calls.
I have port 5060 forwarded to my machine (yes I am running IPTABLES with Fail2Ban). I juggle the outgoing routes to force calls out of the other channels and I always get "all circuits are busy" . As soon as I try changing the port from 5060 to 5061 in the trunk settings, it tries to connect for a while but then fails again. 
So upon running 3 vfx lines on the same machine, do I need each line to be forwarded to a separate port? (and maybe I am not forwarding correctly)? Or what other reason could make 1 line able to make calls and the other two not, when they have EXACTLY the same settings?

Here are the settings that work

User context : 9950xxxx


Create new topic
24889 posts

Uber Geek
+1 received by user: 4788

Biddle Corp

  Reply # 763340 16-Feb-2013 09:10 Send private message

What G729 codec do you have installed? If it's the Digium one how many channels are you licenced for?

66 posts

Master Geek

  Reply # 763342 16-Feb-2013 09:16 Send private message

Good question... I have not licenced any g729 codecs. Could that be the issue?



2948 posts

Uber Geek
+1 received by user: 782


  Reply # 763353 16-Feb-2013 10:11 Send private message

G729 is licensed so if you havent paid for and applied a license your asterisk box cant use it. In saying that though I thought it would just negotiate for 711 instead.

66 posts

Master Geek

  Reply # 763573 16-Feb-2013 20:31 Send private message

Yep, tried using only ulaw and alaw, .... Same result :(

24889 posts

Uber Geek
+1 received by user: 4788

Biddle Corp

  Reply # 763609 16-Feb-2013 22:28 Send private message

Could be any number of things, the only way to tell is to see Asterisk and SIP debugging of the issue to see why it's happening.

If you don't have a G.729 codec installed on your box you shouldn't be specifying it in your invite messages.

66 posts

Master Geek

  Reply # 765651 19-Feb-2013 11:27 Send private message

After a LOT of trial and error and some very useful tips from Josh I managed to find what was wrong...

It appears that Elastix does not like numbers as trunk names. I had 2 trunks, one called 0800 (my 0800 Nr) and another named after my business. Both had same settings, but only the second one worked. So the only thing different was the name. Changed it to "Freephone" and VOILA, everything is working as expected.

Managed to learn a couple of things in the process too, which is always a god thing :)

Thnx WxC!

Create new topic

Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:

Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:

Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:

News »

National AI group launching next month
Posted 25-May-2017 09:54

New Zealand Digital Future, according to tech companies
Posted 25-May-2017 09:51

New Microsoft Surface Pro delivers outstanding battery life, performance
Posted 25-May-2017 09:34

Garmin VIRB 360 brings immersive 360-degree 5.7K camera experience
Posted 25-May-2017 09:30

Telecommunications monitoring report: Are you being served?
Posted 24-May-2017 11:54

NetValue partners with CRM Provider SugarCRM
Posted 23-May-2017 20:04

Terabyte looms as Vocus users download 430GB a month
Posted 19-May-2017 14:51

2degrees tips into profit after seven lean years
Posted 19-May-2017 09:47

2degrees growth story continues
Posted 17-May-2017 15:25

Symantec Blocks 22 Million Attempted WannaCry Ransomware Attacks Globally
Posted 17-May-2017 12:41

HPE Unveils Computer Built for the Era of Big Data
Posted 17-May-2017 12:39

Samsung Galaxy S8 Plus review: Beautiful, feature-packed
Posted 16-May-2017 20:14

After ten years of mail pain Spark is done with Yahoo
Posted 15-May-2017 13:12

Warnings from security firms: do not click that link or risk your computer being infected
Posted 15-May-2017 10:11

Pushpay named NZ Hi-Tech Company of the Year 2017
Posted 15-May-2017 09:59

Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.

Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.