Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.


41 posts

Geek
+1 received by user: 5


Topic # 111940 20-Nov-2012 14:09
Send private message

Hi,
we are setting up in a new premises, and our main wireless/DSL Modem can't reach one of the offices. There's a connected Ethernet cable to the room next to it, so I've set up our spare wireless router there.

Primary: Cisco WAG 310G - provided by xnet. Set as 192.168.1.1, Subnet mask 255.255.255.0
 - two desktops on LAN, 
 - phone (via VFX)
 - WPA-Personal / TKIP Encryption Wireless on channel 11

Secondary: Asus WL520GC
- WPA2-Personal on Channel 9

we have a fixed IP address from Worldxchange

What I've done (following 2 sets of instructions I found, both for different brand routers!)
- connected secondary via an ethernet port, not WAN port
- set secondary's LAN IP to 192.168.1.2
- set gateway on secondary to 192.168.1.1
- DHCP is enabled on both. Primary limited to 192.168.1.64..127, secondary 128..255

A laptop can connect to the admin panel of the secondary ok. Internet requests give an unable to reach DNS server error.
I tried putting in the xnet DNS server IP's, same result.
I cannot access 192.168.1.1 admin page from a device connected to the secondary, and cannot reach 192.168.1.2 from this computer on the primary.

The cable is known to work - I've run a laptop on it.

Any clues or pointers to more specific help?
All I really want is internet access via thesecondary.

I've no networking training, so please answer in words of one syllable :-)

Create new topic
168 posts

Master Geek
+1 received by user: 30


  Reply # 720095 20-Nov-2012 14:20
Send private message

Have a look at this guide:

http://support.asus.com/Download.aspx?SLanguage=en&p=11&s=2&m=WL-520GC&os=17&ft=12&f_name=WDS_Configuration_Guide_v[1]0.rar#WDS_Configuration_Guide_v[1]0.rar

Is the router running in bridge mode?

6178 posts

Uber Geek
+1 received by user: 242

Trusted
Subscriber

  Reply # 720096 20-Nov-2012 14:23
One person supports this post
Send private message

Hi, turn the DHCP server on the 2nd AP off, I would suggest that is the main problem. Also use Ch 1 or 6 as 9 overlaps with 11, ie there are 3 non overlapping channels 1, 6, and 11 so use those only.

Cyril

Edit, I should replace the suggest that is the main problem with IS the main problem.



3448 posts

Uber Geek
+1 received by user: 1204

Subscriber

  Reply # 720108 20-Nov-2012 14:31
Send private message

Yea make sure all the routing functions are disabled on the Asus and that it is only acting as an access point.

So look for NAT, QoS, DHCP, Firewall etc and disable all these things. Then just set up the SSID and password the same as what you have on the Cisco and you should be able to roam between both nice and easy.



41 posts

Geek
+1 received by user: 5


  Reply # 720115 20-Nov-2012 14:39
Send private message

Thanks

After disabling DHCP and switching to channel 6, I can't connect to the secondary's admin page any more. If I still can't after a reboot, I'll have to hook up a cable again.

6178 posts

Uber Geek
+1 received by user: 242

Trusted
Subscriber

  Reply # 720121 20-Nov-2012 14:44
One person supports this post
Send private message

The correct setup should be.

First/Main NAT router, lan ip 192.168.1.1 etc, DHCP server should be on and DHCP pool should not start till 192.168.1.3 or ideally 192.168.1.20 to leave a static working space.

2nd AP, set to 192.168.1.2, DHCP server should be OFF, and gateway set to 192.168.1.1. Connect 2nd AP to 1st ap via a LAN port nothing on the WAN port of the 2nd AP.

You may need to ensure your PC gets a new lease address, just remove the lan cable and re attach to a port of either router/AP and it should get a new address from the DHCP server of the main router.

Cyril



41 posts

Geek
+1 received by user: 5


  Reply # 720184 20-Nov-2012 16:02
Send private message

Thank goodness for the restore defaults button on the back - talking to AP 2 again via cable.

cyril7: The correct setup should be.

First/Main NAT router, lan ip 192.168.1.1 etc, DHCP server should be on and DHCP pool should not start till 192.168.1.3 or ideally 192.168.1.20 to leave a static working space.

2nd AP, set to 192.168.1.2, DHCP server should be OFF, and gateway set to 192.168.1.1. Connect 2nd AP to 1st ap via a LAN port nothing on the WAN port of the 2nd AP.



So does that mean I can totally ignore the WAN settings sections?
I've set LAN IP as 192.168.1.2 and put an xnet nameserver as DNS1 (DNS2 is disabled and showing the AP's IP)


6178 posts

Uber Geek
+1 received by user: 242

Trusted
Subscriber

  Reply # 720189 20-Nov-2012 16:08
One person supports this post
Send private message

Hi, you dont need to configure anything in the WAN interface of the 2nd router (which you are running simply as an AP). If you turn the DHCP server in the 2nd AP off then the 1st router/AP is what dishs up addresses and provides DNS info from its WAN port.

Cyril



41 posts

Geek
+1 received by user: 5


  Reply # 798280 12-Apr-2013 10:26
Send private message

Just bringing this up to date, after leaving it unresolved for a few months, we finally have things working: There were two key points to the solution in addtion to the advice above:

1) When working with the (isolated) Asus directly from a laptop, attempts to set the AP's address as 192.168.1.2 failed, because it had already assigned that lease to the laptop before we disabled DHCP. Setting it as 192.168.1.3 worked.
2) Browsing ASUS FAQ's I came across an obscure documentation page which showed a config screen where the Role of the device was determined, with AP only as the third option. Our device had no such screen, but a small note at the bottom said that for models without that option, the same effect was obtained by connecting the cable from the primary to LAN1 port rather than WAN.
Having done both those, it works perfectly.

Create new topic

Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

N4L helping TAKA Trust bridge the digital divide for Lower Hutt students
Posted 18-Jun-2018 13:08


Winners Announced for 2018 CIO Awards
Posted 18-Jun-2018 13:03


Logitech Rally sets new standard for USB-connected video conference cameras
Posted 18-Jun-2018 09:27


Russell Stanners steps down as Vodafone NZ CEO
Posted 12-Jun-2018 09:13


Intergen recognised as 2018 Microsoft Country Partner of the Year for New Zealand
Posted 12-Jun-2018 08:00


Finalists Announced For Microsoft NZ Partner Awards
Posted 6-Jun-2018 15:12


Vocus Group and Vodafone announce joint venture to accelerate fibre innovation
Posted 5-Jun-2018 10:52


Kogan.com to launch Kogan Mobile in New Zealand
Posted 4-Jun-2018 14:34


Enable doubles fibre broadband speeds for its most popular wholesale service in Christchurch
Posted 2-Jun-2018 20:07


All or Nothing: New Zealand All Blacks arrives on Amazon Prime Video
Posted 2-Jun-2018 16:21


Innovation Grant, High Tech Awards and new USA office for Kiwi tech company SwipedOn
Posted 1-Jun-2018 20:54


Commerce Commission warns Apple for misleading consumers about their rights
Posted 30-May-2018 13:15


IBM leads Call for Code to use cloud, data, AI, blockchain for natural disaster relief
Posted 25-May-2018 14:12


New FUJIFILM X-T100 aims to do better job than smartphones
Posted 24-May-2018 20:17


Stuff takes 100% ownership of Stuff Fibre
Posted 24-May-2018 19:41



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.