Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




2649 posts

Uber Geek
+1 received by user: 759


# 136576 2-Dec-2013 13:41
Send private message

I am attempting to configure a Fortinet FortiWiFi 60C to us a USB 3G modem as a redundant connection, but so far haven't been too successful. I am starting by just configuring it as a standalone interface and will configure the redundancy once that is working.

I am using a Netgear Air Card 320U (formerly Sierra). The modem is recognized by the Fortigate (although as a Sierra AC320U).  I have confirmed that the modem itself works by attaching it to my PC and connecting successfully to the XT network. But when i try on the Fortigate it just sits there saying "Connecting..." but never establishes the connection.

Here is the config I have:

config system modem
    set status enable
    set auto-dial enable
    set phone1 "*99#"
    set extra-init1 "at+cgdcont=1,\"ip\",\"wap.telecom.co.nz\""
end

Anyone out there who has managed to get a 3G modem working on a Fortigate who can help me out?

Thanks

Create new topic


2649 posts

Uber Geek
+1 received by user: 759


  # 944175 2-Dec-2013 15:15
Send private message

Correction to above, the Fortigate recognizes the modem as a Sierra AC313U

15 posts

Geek
+1 received by user: 35


  # 945025 3-Dec-2013 23:07
Send private message

Whilst I have no experience with fortinet I have used the Sierra card and 3G backup on another device (router).

I found that I needed to use the APN 'internet.telecom.co.nz' and it worked where 'wap.telecom.co.nz' did not. It may, or may not work but no harm in trying :)


 
 
 
 


19282 posts

Uber Geek
+1 received by user: 2600
Inactive user


  # 945027 3-Dec-2013 23:08
Send private message

I would not use the APN wap.telecom.co.nz



2649 posts

Uber Geek
+1 received by user: 759


  # 945921 5-Dec-2013 09:56
Send private message

Thanks for the suggestions.

Turns out it was because since the router was recognizing it as a slightly different model than what it was it was attempting to access it using the wrong port number. Creating a custom modem definition specifying the correct port has resolved the issue.

Syntax for the APN was correct, and I have found it work with wap.telecom.co.nz and internet.telecom.co.nz. Am currently using internet.telecom.co.nz since that seems to be the consensus of the best one to use.

The issue I am now having is that the IP address that the router is reporting it has been assigned is different to what is being reported to websites (whatismyip.com, speedtest.net etc.) and I can't seem to get it to accept any unsolicited inbound traffic.

What I would like to do is use open port 25 and use DDNS on the modem interface to make it a secondary MX so if the primary connection fails.

I'm quite sure the router config is correct, are inbound pinholes possible on Telecom 3G?

Thanks

Paul

538 posts

Ultimate Geek
+1 received by user: 38


  # 945934 5-Dec-2013 10:18
Send private message

If you want inbound connections you might need to use the "direct.telecom.co.nz" APN http://www.geekzone.co.nz/forums.asp?forumid=39&topicid=32983



2649 posts

Uber Geek
+1 received by user: 759


  # 946050 5-Dec-2013 13:09
Send private message

wongtop: If you want inbound connections you might need to use the "direct.telecom.co.nz" APN http://www.geekzone.co.nz/forums.asp?forumid=39&topicid=32983


Thanks. I've tried that and hasn't made any difference. The device is getting an external and internal address, rather than bridging the external address to the router interface, and I think this is the issue. I've created a new topic under the Telecom XT forum to see if anyone else has got inbound port forwarding to work on XT.

New topic is here.

Thanks again

Create new topic



Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

Video game market in New Zealand passes half billion dollar mark
Posted 24-May-2019 16:15


WLG-X festival to celebrate creativity and innovation
Posted 22-May-2019 17:53


HPE to acquire supercomputing leader Cray
Posted 20-May-2019 11:07


Techweek starting around NZ today
Posted 20-May-2019 09:52


Porirua City Council first to adopt new council software solution Datascape
Posted 15-May-2019 12:00


New survey provides insight into schools' technology challenges and plans
Posted 15-May-2019 09:30


Apple Music now available on Alexa devices in Australia and New Zealand
Posted 15-May-2019 09:11


Make a stand against cyberbullying this Pink Shirt Day
Posted 14-May-2019 20:23


Samsung first TV manufacturer to launch the Apple TV App and Airplay 2
Posted 14-May-2019 20:11


Vodafone New Zealand sold
Posted 14-May-2019 07:25


Kordia boosts cloud performance with locally-hosted Microsoft Azure ExpressRoute
Posted 8-May-2019 10:25


Microsoft Azure ExpressRoute in New Zealand opens up faster, more secure internet for Kiwi businesses
Posted 8-May-2019 09:39


Vocus Communications to deliver Microsoft Azure Cloud Solutions through Azure ExpressRoute
Posted 8-May-2019 09:25


Independent NZ feature film #statusPending to premiere during WLG-X
Posted 6-May-2019 22:13


The ultimate dog photoshoot with Nokia 9 PureView #ForgottenDogsofInstagram
Posted 6-May-2019 09:41



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.


Support Geekzone »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.