Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




55 posts

Master Geek


# 139292 3-Feb-2014 20:20
One person supports this post
Send private message

Telecom's support line are keeping me hanging for at least 38 minutes, I reckon this forum can probably beat that :-/

Technician came and switched me over today. I checked that a phone could get on the wireless net, that my laptop could surf the internet, that my email uploaded and downloaded, and that I could get onto the VPN I need for work. All seemed OK so I signed the paperwork and he went away.

Now... here's what's going wrong:

a significant percentage of browser requests are being redirected to http://help.telecom.co.nz/app/broadband. This includes pages on 192.168.1.254 (the modem itself!). It's a Huawei HG630b, btw.

I managed to log in to geekzone on the third attempt, checking out the forums was a lottery :-/

I have a netgear WN802Tv2 access point at the opposite end of the house (on a wired connection) and it and my previous router had identical wlan setups such that anyone could connect to one and seamlessly move throughout the whole property without reconnecting. I've done the same here (identical wlan configuration) but a phone connection drops repeatedly as I move from room to room - I don't have to put the passkey in again, but each time I select the network I see a url like apple.captive.com, or apple.airport.us, etc. and the single word "success". Click "done" and we're back on the network - until walking into another room...

Anyone been through the same issues and can assist me?

Create new topic
8033 posts

Uber Geek

Trusted

  # 980040 4-Feb-2014 12:24
One person supports this post
Send private message

Sounds like an issue with the modem/router, I thought Telecom were supplying Pace or Technicolor devices mostly.

Have you tried factory resetting it?
http://help.telecom.co.nz/app/answers/detail/a_id/34300/session/L2F2LzEvdGltZS8xMzkxNDY5Njk4L3NpZC9pYUN4QjFNbA%3D%3D


If the Netgear supports VLAN tagging you could use that as your primary router.

Alternatively the Huawei can probably be bridged so your Netgear does dhcp/nat/routing etc.

456 posts

Ultimate Geek


  # 980111 4-Feb-2014 13:59
Send private message

If you turn off your netgear, restart a test device and then surf do the issues still occur?

Matt.

 
 
 
 




55 posts

Master Geek


  # 980133 4-Feb-2014 14:36
Send private message

The telecom/app/broadband redirect looks like a DNS issue; the frequency slowly reduced on my desktop and after about half an hour of intense frustration it stopped happening. Ditto on my main laptop. When my son switched on his PC he started getting the same problem, again it slowly fixed itself over about half an hour. And to seal the deal on Windows my wife's laptop did exactly the same later in the evening. Whatever that issue is, it's tied to Windows (all Win 7 Pro); Chrome on my phone never went to the telecom page nor did Firefox on a Linux box I have here.
We haven't seen this issue again, so I'm hopeful it's fixed.

I powered the Netgear and Huawei devices off and on again, and the wireless access improved, but didn't go completely away. A friend with an Android phone running a decent network sniffer app (curse you, Apple) came over and verified that the two wireless signals were consistent - and he didn't have any problems staying connected throughout the property, while my phone dropped out a couple of times On his advice I did a "reset all network connections" on the phone, and it's been much more stable since (though it has lost the network once, so I'm not writing this problem off just yet).

Thanks for suggestions

cheers

1990 posts

Uber Geek

Trusted

  # 982249 8-Feb-2014 13:04
Send private message

You could also turn off wifi on the Huawei and put your old router back in, but setup as an accesspoint only. Change the old router's IP address to be compatible with the LAN you are connecting it to, eg 192.168.1.254 so it doesn't conflict with new router or the AP, log into it again at the new IP address and turn off DHCP or set it to relay LAN addresses from the main router, and usually set "gateway" and DNS as the main router.

The end result should be that nothing is connected to the old router's WAN or DSL port, everything gets allocated the same 192.168.x.x subnet by the main router.




Qualified in business, certified in fibre, stuck in copper, have to keep going  ^_^



55 posts

Master Geek


  # 986523 13-Feb-2014 00:24
Send private message

An update. There's still two residual problems - which may have the same underlying cause, not sure. Networking's really not my forte.

The problem with repeated dropped wifi connections went away. iPhone resets and rebooting the Huawei fibre modem and Netgear AP fixed that one.

The redirect to Telecom's setup help page went away. A friend suggested that the Huawei may have a proxy server (?) which is supposed to serve up the setup page to the first connection from the first device. Maybe it's configured for a basic one PC only domestic customer, but here it served up that same page to every device for the first 30 minutes or so, then behaved itself after that.

Problems which remain:

1. While upload & download speeds are great once connection to a site has been established, getting to that point can be ridiculously slow. For example the Google home page (I refuse to believe that Google isn't cached absolutely everywhere in the Telecom network) sometimes takes more than 30 seconds to load.
Google search results regularly report "showing you the basic view as you appear to be on a slow connection" OWTTE. There's nothing wrong with the speed, it just takes forever to get through the door!

2. I connect to an overseas VPN for work and, although I can connect OK, some operations seem to be blocked. For example a reverse DNS lookup just times out - which blocks certain licensed functions I need to be able to access. The previous (ADSL) router clearly didn't have this problem, but I can't interrogate it anymore to compare configs.

[ As an aside, the Huawei lets you save a copy of its config to disk, but the data is binary which makes it useless for comparing setups. Does this annoy everyone else? ]

[ The Telecom helpdesk just says "we can't see anything wrong". Great :-/ ]

If anyone has had similar troubles and knows the fixes, please share!!!

cheers

3885 posts

Uber Geek

Subscriber

  # 987010 13-Feb-2014 21:30

Go into TCP/IP settings on your computers network adaptor. Manually enter your ISPs DNS servers instead of having it set to "obtain automaticly". If the internet now works fine on that computer you now know that it is a local DNS issue.



55 posts

Master Geek


  # 987072 13-Feb-2014 23:18
Send private message

I don't have "obtain automatically" on any of my computers and never have.
Most of them have two from the following list of four:
8.8.8.8 google-public-dns-a.google.com
8.8.4.4 google-public-dns-b.google.com
202.27.184.3 alien.xtra.co.nz
203.96.152.4 rachel.paradise.net.nz

The Huawei appears to have different DNS servers in its config:
122.56.237.1 ns1.xtra.co.nz
210.55.111.1 unknown

Builtin help on the config is pathetic, but maybe using the same name servers (and having two that exist!) would be a step forward. Or maybe it's irrelevant.

 
 
 
 


Mad Scientist
20659 posts

Uber Geek

Trusted
Lifetime subscriber

  # 987073 13-Feb-2014 23:25
Send private message

Have you factory reset your router?

Then enter the correct dns on the computer (not sure if ufb has different dns than us copper folks but your dns is not the same as mine)




Involuntary autocorrect in operation on mobile device. Apologies in advance.




55 posts

Master Geek


  # 987087 14-Feb-2014 02:30
Send private message

I haven't knowingly reset the router. The only alteration I have made since Chorus installed it was to change the network SSID and key to our previous one so that it matched the other AP in our network, and I have rebooted it a couple of times since.

What do you mean by "correct" DNS? 8.8.8.8 has worked for me for years. But 122.56.237.1 looks reasonable. No idea about the other one on the router, it doesn't seem to be real.

5525 posts

Uber Geek


  # 987099 14-Feb-2014 06:57
2 people support this post
Send private message

aquatarkus:What do you mean by "correct" DNS? 8.8.8.8 has worked for me for years. But 122.56.237.1 looks reasonable. No idea about the other one on the router, it doesn't seem to be real.


Unless you know exactly what you are doing, and the reason for it, it is far better (especially in NZ) to use the DNS servers maintained by your ISP - it will generally give you a far better experience with distributed content / CDNs.

28117 posts

Uber Geek

Moderator
Trusted
Biddle Corp
Lifetime subscriber

  # 987122 14-Feb-2014 08:29
2 people support this post
Send private message

You should also never manually enter Telecom DNS servers, because 99% of people don't know what the correct ones are.

Telecom have a major CDN network with nodes in Auckland, Wellington and Christchurch. Using the wrong DNS (or Google DNS) can simply mean degraded performance to a lot of CDN content.






2 posts

Wannabe Geek


  # 1142951 28-Sep-2014 13:04
Send private message

I'm getting the same problem (except the redirects are to www.spark.co.nz/help/broadbandsetup).

 

 

Sometimes it happens alot, Sometimes infrequently. But is is definitely at the "Annoying" level.

 

 

Talking to the second line support they say it is an occasional know issue, and they are in the process (?) of raising it with the modem manufacturer to get a patch.

 

 

Like you I'm using non-Spark DNS servers.

 

 

I wonder if there is any other modem I can use instead.

6835 posts

Uber Geek

Trusted
Subscriber

  # 1142953 28-Sep-2014 13:28
Send private message

Hi, I am about to upgrade to VDSL tomorrow and have had the Huawei HG630b as my modem (albeit as ADSL2+) since Wednesday when it arrived, I too have noted lots of requests being redirected to Sparks Broadband site.

Seeing this post made me think, damn the new router has a DNS cache/forwarder issue, so I have just overwritten the DHCP server DNS records with xtras ns1 and ns2, will keep an eye on things.

Cyril

2 posts

Wannabe Geek


  # 1142954 28-Sep-2014 13:31
Send private message

I subsequently found this post:

 

http://www.geekzone.co.nz/forums.asp?forumid=39&topicid=144105

 

 

I have just tried it, and so far, so good.

 

 

It suggested that turning off VDSL fixed the problem (whilst ADSL was being used). I wonder if, as you are using VDSL, you need to turn off (disable) ADSL.

6835 posts

Uber Geek

Trusted
Subscriber

  # 1142957 28-Sep-2014 13:34
Send private message

Hi, currrently on ADSL will be changed to vDSL tomorrow, but in reality I dont care for the modem to perform DNS forwarding, quite happy to just have it load ns1/2 directly out to the clients by DHCP.

Cyril

Create new topic



Twitter and LinkedIn »



Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

New AI legaltech product launched in New Zealand
Posted 21-Aug-2019 17:01


Yubico launches first Lightning-compatible security key, the YubiKey 5Ci
Posted 21-Aug-2019 16:46


Disney+ streaming service confirmed launch in New Zealand
Posted 20-Aug-2019 09:29


Industry plan could create a billion dollar interactive games sector
Posted 19-Aug-2019 20:41


Personal cyber insurance a New Zealand first
Posted 19-Aug-2019 20:26


University of Waikato launches space for esports
Posted 19-Aug-2019 20:20


D-Link ANZ expands mydlink ecosystem with new mydlink Mini Wi-Fi Smart Plug
Posted 19-Aug-2019 20:14


Kiwi workers still falling victim to old cyber tricks
Posted 12-Aug-2019 20:47


Lightning Lab GovTech launches 2019 programme
Posted 12-Aug-2019 20:41


Epson launches portable laser projector
Posted 12-Aug-2019 20:27


Huawei launches new distributed HarmonyOS
Posted 12-Aug-2019 20:20


Lenovo introduces single-socket servers for edge and data-intensive workloads
Posted 9-Aug-2019 21:26


The Document Foundation announces LibreOffice 6.3
Posted 9-Aug-2019 16:57


Symantec sell enterprise security assets for US$ 10.7 billion to Broadcom
Posted 9-Aug-2019 16:43


Artificial tongue can distinguish whisky and identify counterfeits
Posted 8-Aug-2019 20:20



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.


Support Geekzone »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.