Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




6 posts

Wannabe Geek


# 139374 6-Feb-2014 17:33
Send private message

I am regretting updating the firmware in my 7390 to 6.01 because it no longer supports SMB. I have followed AVM's instructions to downgrade without success.
I get this message from the router:

The update failed.
The selected file contains a firmware version which is older than the one already in use.

I see on the overview page that the unit "contains basic settings adjusted for your Internet service provider" (Snap!). Could this be what is preventing me from downgrading?

Any help would be much appreciated as it is frustrating not having SMB functionality.

Thankyou

Create new topic
1457 posts

Uber Geek

Trusted

  # 981388 6-Feb-2014 17:42
Send private message

Try the firmware file near the bottom of this post; it is a special 'downgrade' firmware which should get around your issue.

49 posts

Geek


  # 981433 6-Feb-2014 18:38
Send private message

Unfortunately, 6.01 won't let you run any downgrade firmware - likely something to do with the major version of the firmware being different.  The best option is to download the 05.51 recovery image from ftp://ftp.avm.de/fritz.box/fritzbox.fon_wlan_7390/x_misc/english/.

As this is an exe, you'll need to be running windows for it to work.  If you want 5.22, you should be able to run the downgrade firmware after recovering the fritz.

 
 
 
 


'That VDSL Cat'
10606 posts

Uber Geek

Trusted
Spark
Subscriber

  # 981437 6-Feb-2014 18:41
Send private message

looks like AVM may simply not allow downgrading from 6.0 to 5.0 .. major revision in their OS, i suppose it makes sense.

the lucky thing about the 6.0 versions is that you can run older DSL versions.

to get SMB back you can try recovery images, otherwise you might have to turn to the likes of frettz.




#include <std_disclaimer>

 

Any comments made are personal opinion and do not reflect directly on the position my current or past employers may have.


2873 posts

Uber Geek


  # 981495 6-Feb-2014 20:25
Send private message

i have tried the 6.01 version and have gone back to the 5.0 firmware with no trouble .




Common sense is not as common as you think.


'That VDSL Cat'
10606 posts

Uber Geek

Trusted
Spark
Subscriber

  # 981496 6-Feb-2014 20:27
Send private message

vexxxboy: i have tried the 6.01 version and have gone back to the 5.0 firmware with no trouble .


on a 7390?

cant say i want to try it myself.. bit of a risk...




#include <std_disclaimer>

 

Any comments made are personal opinion and do not reflect directly on the position my current or past employers may have.




6 posts

Wannabe Geek


  # 981576 7-Feb-2014 00:54
Send private message

This is the response from AVM:

 

 

 

Thank you very much for the enquiry you submitted to AVM Support.

 

 

We are unaware of problems concerning the downgrade.

 

 

Did you get your FRITZ!Box from your internet service provider or did you

 

buy it in a store? Maybe your ISP uses specific provider settings in the

 

FRITZ!Box that prevent it from downgrading? You could enquire this at your

 

ISP.



6 posts

Wannabe Geek


  # 981577 7-Feb-2014 00:59
Send private message

Pinkfish: Unfortunately, 6.01 won't let you run any downgrade firmware - likely something to do with the major version of the firmware being different.  The best option is to download the 05.51 recovery image from ftp://ftp.avm.de/fritz.box/fritzbox.fon_wlan_7390/x_misc/english/.

As this is an exe, you'll need to be running windows for it to work.  If you want 5.22, you should be able to run the downgrade firmware after recovering the fritz.


Is there a risk this could interfere with, or even remove, the Snap! settings and give me other problems?

 
 
 
 


'That VDSL Cat'
10606 posts

Uber Geek

Trusted
Spark
Subscriber

  # 981578 7-Feb-2014 01:03
Send private message

Tronette:
Pinkfish: Unfortunately, 6.01 won't let you run any downgrade firmware - likely something to do with the major version of the firmware being different.  The best option is to download the 05.51 recovery image from ftp://ftp.avm.de/fritz.box/fritzbox.fon_wlan_7390/x_misc/english/.

As this is an exe, you'll need to be running windows for it to work.  If you want 5.22, you should be able to run the downgrade firmware after recovering the fritz.


Is there a risk this could interfere with, or even remove, the Snap! settings and give me other problems?


all snaps settings can be reconfigured.

if all else fails, you can ring snap, they will step you through atlest getting the modem online, from there they can resetup your VoIP etc.




#include <std_disclaimer>

 

Any comments made are personal opinion and do not reflect directly on the position my current or past employers may have.


Create new topic



Twitter and LinkedIn »



Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

Kiwi workers still falling victim to old cyber tricks
Posted 12-Aug-2019 20:47


Lightning Lab GovTech launches 2019 programme
Posted 12-Aug-2019 20:41


Epson launches portable laser projector
Posted 12-Aug-2019 20:27


Huawei launches new distributed HarmonyOS
Posted 12-Aug-2019 20:20


Lenovo introduces single-socket servers for edge and data-intensive workloads
Posted 9-Aug-2019 21:26


The Document Foundation announces LibreOffice 6.3
Posted 9-Aug-2019 16:57


Symantec sell enterprise security assets for US$ 10.7 billion to Broadcom
Posted 9-Aug-2019 16:43


Artificial tongue can distinguish whisky and identify counterfeits
Posted 8-Aug-2019 20:20


Toyota and Preferred Networks to develop service robots
Posted 8-Aug-2019 20:11


Vodafone introduces new Vodafone TV device
Posted 7-Aug-2019 17:16


Intel announces next-generation Intel Xeon Scalable processors with up to 56 cores
Posted 7-Aug-2019 15:41


Nokia 2.2 released in New Zealand
Posted 5-Aug-2019 19:38


2degrees celebrating ten years
Posted 5-Aug-2019 05:00


Sure Petcare launches SureFeed microchip pet feeder
Posted 2-Aug-2019 17:00


Symantec Threat Intelligence: revival and rise of email extortion scams
Posted 2-Aug-2019 16:55



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.


Support Geekzone »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.