Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.


58 posts

Master Geek
+1 received by user: 5


Topic # 192263 3-Mar-2016 19:08
Send private message

Hi

 

I've recently purchased a Linksys WRT1200AC on a sale, originally for little else other than to set it up as a wireless AP. I've flashed DD-WRT on it.

 

 

 

It has occurred to me that it may be possible to plug it directly into the ONT, removing the need for the Vodafone supplied HG659.

 

 

 

I understand that I need to use a VLAN tag of 10, and the WAN connection to DHCP. I've tried to set this up with no luck. Has anyone here have particular experience with this router, or perhaps has some further advice.

 

 

 

 

Reading around, some of the Linksys gear has some troubles with VLAN tagging? 

 

 

 

Is this router even capable of such a task?

 

 

 

Thanks!!


Create new topic
92 posts

Master Geek
+1 received by user: 1


  Reply # 1505711 3-Mar-2016 21:54
Send private message

I have a different router that also supports DD-WRT and openWRT.

 

I spent several hours trying to get DD-WRT to work with spark fibre, and never was successful. I ended up flashing openWRT, which has a much easier to understand ui for vlans, and had it working in 5 minutes.


650 posts

Ultimate Geek
+1 received by user: 178


  Reply # 1505714 3-Mar-2016 22:03
Send private message

I'm pretty sure you need to set up the WAN port to be bridged to the LAN ports - have you done this? Also make sure that your LAN ports are all assigned VLAN0/No VLAN.



58 posts

Master Geek
+1 received by user: 5


  Reply # 1505959 4-Mar-2016 13:34
Send private message

Appreciate your replies!

 

toejam316: I'm pretty sure you need to set up the WAN port to be bridged to the LAN ports - have you done this? Also make sure that your LAN ports are all assigned VLAN0/No VLAN.

 

It seems I don't understand this as well as I thought I did. Here is a screen of the networking UI

 

 

Are you able to set me off in the correct direction? 

 

Maybe I will look towards OpenWRT, my current VPN provider plays nice with DD WRT although

 

 

 

Thanks again


650 posts

Ultimate Geek
+1 received by user: 178


  Reply # 1505968 4-Mar-2016 13:57
Send private message

Honestly I'm not familiar enough to provide solid guidance, just to blunder through myself. JD suggest checking the ddwrt forums before giving up - someone there will almost definitely be able to tell you what you need to do in detail.
All I know is conceptually having the WAN on VLAN 10 means the WAN and ONT can communicate, but because the LAN (eth0 through eth3 on a 4 port device) and WiFi (I suspect ath0 is 2.4ghz and ath1 is 5ghz), it has nothing passing through.
Try briding eth0 to the WAN, and see if that lets you get service on port 1.

133 posts

Master Geek
+1 received by user: 22


  Reply # 1505989 4-Mar-2016 14:24
Send private message

If the issue still persists in DD-WRT as how I remember it, you will not be able to set the proper VLAN Tag through the GUI.

 

Try to commit these commands to nvram via telnet or SSH (https://www.dd-wrt.com/wiki/index.php/Telnet/SSH_and_the_Command_Line):

 

nvram set pppoe_wan_ifname=vlan10
nvram commit

 

There's also reports that the router won't remember this VLAN Tag setting when it's rebooted, so you will have to commit the changes every time there's a power cycle.

 

More info can be found here: https://www.dd-wrt.com/phpBB2/viewtopic.php?t=261226&postdays=0&postorder=asc&start=0


650 posts

Ultimate Geek
+1 received by user: 178


  Reply # 1505994 4-Mar-2016 14:31
Send private message

venomio:

If the issue still persists in DD-WRT as how I remember it, you will not be able to set the proper VLAN Tag through the GUI.


Try to commit these commands to nvram via telnet or SSH (https://www.dd-wrt.com/wiki/index.php/Telnet/SSH_and_the_Command_Line):


nvram set pppoe_wan_ifname=vlan10
nvram commit


There's also reports that the router won't remember this VLAN Tag setting when it's rebooted, so you will have to commit the changes every time there's a power cycle.


More info can be found here: https://www.dd-wrt.com/phpBB2/viewtopic.php?t=261226&postdays=0&postorder=asc&start=0


Pretty sure ddwrt has an autoexec or some such, doesn't it? Maybe add it to a start up script if thats the case. Unsure off the top of my head where that is, I play around more with AsusWRT-Merlin

650 posts

Ultimate Geek
+1 received by user: 178


  Reply # 1505995 4-Mar-2016 14:31
Send private message

venomio:

If the issue still persists in DD-WRT as how I remember it, you will not be able to set the proper VLAN Tag through the GUI.


Try to commit these commands to nvram via telnet or SSH (https://www.dd-wrt.com/wiki/index.php/Telnet/SSH_and_the_Command_Line):


nvram set pppoe_wan_ifname=vlan10
nvram commit


There's also reports that the router won't remember this VLAN Tag setting when it's rebooted, so you will have to commit the changes every time there's a power cycle.


More info can be found here: https://www.dd-wrt.com/phpBB2/viewtopic.php?t=261226&postdays=0&postorder=asc&start=0


Pretty sure ddwrt has an autoexec or some such, doesn't it? Maybe add it to a start up script if thats the case. Unsure off the top of my head where that is, I play around more with AsusWRT-Merlin

133 posts

Master Geek
+1 received by user: 22


  Reply # 1506019 4-Mar-2016 15:01
Send private message

Correct! You can make a startup script to run to make those changes on startup.

 

But natively, it doesn't save the changes.

 

Administration -> Commands -> <PASTE SCRIPT> -> Save Startup

 


133 posts

Master Geek
+1 received by user: 22


  Reply # 1506020 4-Mar-2016 15:03
Send private message

Haven't tested it myself, but this script could work:

 

nvram unset vlan2ports
nvram unset vlan2hwname
nvram set wan_ifname2=vlan10
nvram set pppoe_wan_ifname=vlan10
nvram set pppoe_ifname=vlan10
nvram set wan_default=vlan10
nvram set wan_ifnames=vlan10
nvram set wan_ifname=vlan10
sleep 1
nvram commit




58 posts

Master Geek
+1 received by user: 5


  Reply # 1506152 4-Mar-2016 18:44
Send private message

Thanks again all

 

 

 

I'm still not having any luck. I've put a thread together at the DD WRT forums too, hopefully I get some success and I will report back.


2007 posts

Uber Geek
+1 received by user: 327

Lifetime subscriber

  Reply # 1506158 4-Mar-2016 19:02
Send private message

 Better off sticking with the GUI config.

 

 Port Setup/WAN Port Assignment and choose eth0.10 from the drop down box (simply because its the most obvious thing to do).

 

 Above commands relate to a PPPoE connection which isn't relevant to Voda anyway.





Ross

 

Spark FibreMAX using Mikrotik CCR1009-8G-1S-1S+

 


Speed Test




58 posts

Master Geek
+1 received by user: 5


  Reply # 1506382 5-Mar-2016 09:57
One person supports this post
Send private message

Wow this was frustrating, although I now have this working.

 

 

 

I went back to the stock firmware to make sure this wasn't just me being a nub, had this working in 2mins. Back to DD WRT. Here is the config I've used to get this working for the record.

 

 

Apparently the VLAN tag needs at least 1 priority? I'd tried these settings before hand with no success, maybe resetting the firmware did the trick. First time in a good while I've found a stock firmware to be more useful that a TP one.

 

I'm too afraid to reboot the bloody thing though.

 

Again, I appreciate the assistance offered.




58 posts

Master Geek
+1 received by user: 5


  Reply # 1506753 6-Mar-2016 09:01
Send private message

For the next individual searching this problem, to get the Vodafone TV working you need to uncheck the Filter Multicast check box under Security.

 

This however will immediately break your wifi as it gets flooding with the Multicast (VodaTV) traffic. You need to add these commands under Administration > Commands, run them and then hit Save Firewall. They will then run on each boot.

 

 

 

insmod ebtables
insmod ebtable_filter
insmod ebt_pkttype
ebtables -A FORWARD -o ath0 --pkttype-type multicast -j DROP
ebtables -A OUTPUT -o ath0 --pkttype-type multicast -j DROP
ebtables -A FORWARD -o ath1 --pkttype-type multicast -j DROP
ebtables -A OUTPUT -o ath1 --pkttype-type multicast -j DROP

 

 

 

This causes ath0 and ath1, the 2.4 and 5 GHz wifi radios, to drop these packets. This will apply to other routers, you may just need to check under Status > Wireless to confirm the name of the applicable interfaces.

 

You  should then be all good to go with Vodafone TV.


6 posts

Wannabe Geek
+1 received by user: 1

Lifetime subscriber

  Reply # 1923448 21-Dec-2017 22:19
Send private message

Hey loathe did this end up surviving a reboot?

Create new topic

Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

Intel introduces new NUC kits and NUC mini PCs
Posted 16-Aug-2018 11:03


The Warehouse leaps into the AI future with Google
Posted 15-Aug-2018 17:56


Targus set sights on enterprise and consumer growth in New Zealand
Posted 13-Aug-2018 13:47


Huawei to distribute nova 3i in New Zealand
Posted 9-Aug-2018 16:23


Home robot Vector to be available in New Zealand stores
Posted 9-Aug-2018 14:47


Panasonic announces new 2018 OLED TV line up
Posted 7-Aug-2018 16:38


Kordia completes first live 4K TV broadcast
Posted 1-Aug-2018 13:00


Schools get safer and smarter internet with Managed Network Upgrade
Posted 30-Jul-2018 20:01


DNC wants a safer .nz in the coming year
Posted 26-Jul-2018 16:08


Auldhouse becomes an AWS Authorised Training Delivery Partner in New Zealand
Posted 26-Jul-2018 15:55


Rakuten Kobo launches Kobo Clara HD entry level reader
Posted 26-Jul-2018 15:44


Kiwi team reaches semi-finals at the Microsoft Imagine Cup
Posted 26-Jul-2018 15:38


KidsCan App to Help Kiwi Children in Need
Posted 26-Jul-2018 15:32


FUJIFILM announces new high-performance lenses
Posted 24-Jul-2018 14:57


New FUJIFILM XF10 introduces square mode for Instagram sharing
Posted 24-Jul-2018 14:44



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.