Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.


View this topic in a long page with up to 500 replies per page Create new topic
1 | ... | 36 | 37 | 38 | 39 | 40 | 41 | 42 | 43 | 44 | 45 | 46 
1805 posts

Uber Geek

Trusted

  #2413422 6-Feb-2020 08:16
Send private message quote this post

More than a reboot was needed. ISP may need to reprovision a new IP if it fails to bring up the PPPoE session with the first one.

 





CPU: Intel 3770k| RAM: F3-2400C10D-16GTX G.Skill Trident X |MB:  Gigabyte Z77X-UD5H-WB | GFX: GV-N660OC-2GD gv-n660oc-2gd GeForce GTX 660 | Monitor: Qnix 27" 2560x1440

 

 


7 posts

Wannabe Geek


  #2414022 7-Feb-2020 09:34
Send private message quote this post

ipv6 not working on ER-4 on 2degrees.

 

A request for assistance. Apologies for my ignorance. I've read through multiple posts and found some similar sounding issues from nicmair and metalinc but haven't been able to fix.

 

Trying to set this up, when I followed the ipv6 portion of the excellent guide at the start it always failed at commit, skewering my connection which required re-set up. After changing the MTU to 1500 on pppoe0 and 1508 on eth0 and eth0.10, it will commit and now an ipv6 address of some type is visible on pppoe0 as per the attached screenshot. Still no external ipv6 access though.

 

I realise I'm probably missing a lot of required information. If anyone has advice or time to assist I'd appreciate the help.

 

 

 

 

 

Click to see full size


 
 
 
 


1805 posts

Uber Geek

Trusted

  #2414096 7-Feb-2020 10:15
Send private message quote this post

Reboot the PC you're using and retest.

 

 





CPU: Intel 3770k| RAM: F3-2400C10D-16GTX G.Skill Trident X |MB:  Gigabyte Z77X-UD5H-WB | GFX: GV-N660OC-2GD gv-n660oc-2gd GeForce GTX 660 | Monitor: Qnix 27" 2560x1440

 

 


387 posts

Ultimate Geek


  #2414109 7-Feb-2020 11:01
Send private message quote this post

axlback:

 

ipv6 not working on ER-4 on 2degrees.

 

A request for assistance. Apologies for my ignorance. I've read through multiple posts and found some similar sounding issues from nicmair and metalinc but haven't been able to fix.

 

Trying to set this up, when I followed the ipv6 portion of the excellent guide at the start it always failed at commit, skewering my connection which required re-set up. After changing the MTU to 1500 on pppoe0 and 1508 on eth0 and eth0.10, it will commit and now an ipv6 address of some type is visible on pppoe0 as per the attached screenshot. Still no external ipv6 access though.

 

I realise I'm probably missing a lot of required information. If anyone has advice or time to assist I'd appreciate the help.

 

 

 

 

 

Click to see full size

 

 

This has been discussed a couple of times before, and I've never managed to get it working - and it seems a couple of others haven't either.

 

So yeah - if you do, please post how and @me :)


defiant
1097 posts

Uber Geek

Lifetime subscriber

  #2414199 7-Feb-2020 13:10
Send private message quote this post

I think there's an error in the first page:

 

set interfaces ethernet eth0 pppoe 0 dhcpv6-pd prefix-only

 

Should be:

 

set interfaces ethernet eth0 vif 10 pppoe 0 dhcpv6-pd prefix-only

 

However, I don't think that alone would prevent ipv6 from working as from memory that just stops the cpu usage bug with the EdgeRouter and 2degrees.


7 posts

Wannabe Geek


  #2414237 7-Feb-2020 14:18
Send private message quote this post

mentalinc:

 

Reboot the PC you're using and retest.

 

 

 

 

 

 

Thanks, no luck though. Network on my mac configured to obtain ipv6 automatically and hasn't. Same with a windows 10 PC. Both of these machines are wired to a ubiquiti switch plugged into eth1 of the router.

 

 

 

Just to clarify ipv6 works when using Fritzbox or a Synology router.

 

 

 

I have tried both the michaelmurfy and dfny methods, but settled on enabling ipv6 pppoe rather than vlan as per dfnt below:

 

set system offload ipv6 forwarding enable
set system offload ipv6 vlan enable

 

to:

 

set system offload ipv6 forwarding enable
set system offload ipv6 pppoe enable

 

 

 

As per nicmair 7/8/2019, using this seems to work in that it commits and I receive an ipv6 address (? not global as fe80:... ) on pppoe as per the original screenshot, however when I commit I receive the following message:

 

EdgeRouter-4# commit

 

[ interfaces ethernet eth0 vif 10 pppoe 0 dhcpv6-pd ]

 

Stopping daemon...

 

Starting new daemon...

 

Sending ICMPv6 packet: Network is unreachable

 

 

 

Again as per nicmair I have not run the command below, despite this I'm not getting any CPU issues: 

 

set interfaces ethernet eth0 pppoe 0 dhcpv6-pd prefix-only

 

However, if I do run it, I get the following error and my pppoe interface is trashed.

 

EdgeRouter-4# commit

 

[ interfaces ethernet eth0 pppoe 0 dhcpv6-pd ]

 

sysctl: cannot stat /proc/sys/net/ipv6/conf/pppoe0/accept_ra: No such file or directory

 

Starting new daemon...

 

pppoe0: No such device

 

If I repeat the entire process and then get back to that stage and modify it to include vif 10 as below ,then I get a different error:

 

EdgeRouter-4# set interfaces ethernet eth0 vif 10 pppoe 0 dhcpv6-pd prefix-only

 

Unit number must be unique.

 

Since I have the fe80 address I then set a default route as per michaelmurfy instructions, commit, save, and reboot everything, without luck.

 

I realise this router is outside my skillset but would love to get it running and hopefully not have to modify it for a while...


1805 posts

Uber Geek

Trusted

  #2414263 7-Feb-2020 14:58
Send private message quote this post

How long have you been pumping commands at the router?

 

You may want to backup what you have and start again....

 

 

 

please note the below commands are to improve performance (hardware acceleration), not enable IPv6

 

set system offload ipv6 forwarding enable
set system offload ipv6 vlan enable

 

to:

 

set system offload ipv6 forwarding enable
set system offload ipv6 pppoe enable

 

 





CPU: Intel 3770k| RAM: F3-2400C10D-16GTX G.Skill Trident X |MB:  Gigabyte Z77X-UD5H-WB | GFX: GV-N660OC-2GD gv-n660oc-2gd GeForce GTX 660 | Monitor: Qnix 27" 2560x1440

 

 


 
 
 
 


7 posts

Wannabe Geek


  #2414268 7-Feb-2020 15:07
Send private message quote this post

mentalinc:

 

How long have you been pumping commands at the router?

 

You may want to backup what you have and start again....

 

 

 

please note the below commands are to improve performance (hardware acceleration), not enable IPv6

 

set system offload ipv6 forwarding enable
set system offload ipv6 vlan enable

 

to:

 

set system offload ipv6 forwarding enable
set system offload ipv6 pppoe enable

 

 

 

 

 

 

Way too long ;) I've hard reset several times and started from scratch, still no dice.

 

Thanks for the clarification regarding the offload.


7 posts

Wannabe Geek


  #2414365 7-Feb-2020 19:23
Send private message quote this post

dfnt:

 

I think there's an error in the first page:

 

set interfaces ethernet eth0 pppoe 0 dhcpv6-pd prefix-only

 

Should be:

 

set interfaces ethernet eth0 vif 10 pppoe 0 dhcpv6-pd prefix-only

 

However, I don't think that alone would prevent ipv6 from working as from memory that just stops the cpu usage bug with the EdgeRouter and 2degrees.

 

 

 

 

Thanks, I did correct that and managed to commit and save, and no longer receive any errors when commiting, but still no functioning ipv6.

 

 

 

Is the set a default route instruction correct for my situation (set protocols static interface-route6 ::/0 next-hop-interface pppoe0)?


defiant
1097 posts

Uber Geek

Lifetime subscriber

  #2414384 7-Feb-2020 20:28
Send private message quote this post

Yeah, the default route is required

Have you applied the ipv6 firewall rules? From memory you need to allow dhcpv6 otherwise you won’t get assigned anything https://murfy.nz/files/er_v6.txt

I’m not with 2degrees nor do I use an edgerouter anymore so I’m a little rusty



Can you run:
show interfaces ethernet eth0 vif 10 pppoe 0

And paste the output here, remove your pppoe username and password

1805 posts

Uber Geek

Trusted

  #2414393 7-Feb-2020 21:51
Send private message quote this post

here's what mine looks like (working config)

 

 

default-route auto

 

dhcpv6-pd {

 

pd 0 {

 

interface eth2 {

 

host-address ::1

 

no-dns

 

prefix-id :1

 

service slaac

 

}

 

prefix-length /56

 

}

 

prefix-only

 

rapid-commit enable

 

}

 

firewall {

 

in {

 

ipv6-name WAN6_IN

 

name WAN_IN

 

}

 

local {

 

ipv6-name WAN6_LOCAL

 

name WAN_LOCAL

 

}

 

}

 

ipv6 {

 

dup-addr-detect-transmits 1

 

enable {

 

}

 

}

 

mtu 1500

 

name-server auto

 

password XXXXX

 

user-id XXXX@




CPU: Intel 3770k| RAM: F3-2400C10D-16GTX G.Skill Trident X |MB:  Gigabyte Z77X-UD5H-WB | GFX: GV-N660OC-2GD gv-n660oc-2gd GeForce GTX 660 | Monitor: Qnix 27" 2560x1440

 

 


7 posts

Wannabe Geek


#2414506 8-Feb-2020 08:05
One person supports this post
Send private message quote this post

✅It's working - shamefully I had not rebooted the router prior to responding. Thanks to everyone on this thread but in particular to dfnt, mentalinc, and michaelmurfy.

 

 

 

For CokemonZ, I reset the router and started from scratch about 10 times, but the final attempt was done as below.

 

Setup WAN+2LAN2 as per page 1 of thread. Note I did not tick set up ipv6 default firewall, I added this manually later through the CLI as per michaelmurfy. I have no idea if this mattered or not.

 

Hardware offload as per page 1

 

Changed MTU on eth0 and eth0.10 to 1508; pppoe to 1500

 

Ran the following commands (the only change to page 1 as per dfnt prefix-only)

 

 

 

set interfaces ethernet eth0 vif 10 pppoe 0 ipv6 enable

 

edit interfaces ethernet eth0 vif 10 pppoe 0 dhcpv6-pd pd 0

 

set prefix-length /56

 

set interface eth1 host-address ::1

 

set interface eth1 prefix-id :0

 

set interface eth1 service slaac

 

top

 

set interfaces ethernet eth0 vif 10 pppoe 0 dhcpv6-pd prefix-only

 

commit

 

save

 

 

 

set protocols static interface-route6 ::/0 next-hop-interface pppoe0

 

commit

 

save

 

 

 

set up ipv6 firewall through CLI as above

 

reboot

 

 

 

Not sure of the significance of the slight differences between mentalinc and my configurations or if the default ipv6 firewall that is applied on set up was an issue.

 

 

 

dfnt: Yeah, the default route is required

Have you applied the ipv6 firewall rules? From memory you need to allow dhcpv6 otherwise you won’t get assigned anything https://murfy.nz/files/er_v6.txt

I’m not with 2degrees nor do I use an edgerouter anymore so I’m a little rusty



Can you run:
show interfaces ethernet eth0 vif 10 pppoe 0

And paste the output here, remove your pppoe username and password

 

Thanks, slightly different to mentalinc. After going through this am now receiving a local ipv6 address on eth1 as well but still not passing external checks e.g. test-ipv6.

 

 

 

@EdgeRouter-4# show interfaces ethernet eth0 vif 10 pppoe 0

 

default-route auto

 

dhcpv6-pd {

 

     pd 0 {

 

         interface eth1 {

 

             host-address ::1

 

             prefix-id :0

 

             service slaac

 

         }

 

         prefix-length /56

 

     }

 

     prefix-only

 

}

 

firewall {

 

     in {

 

         ipv6-name WAN6_IN

 

         name WAN_IN

 

     }

 

     local {

 

         ipv6-name WAN6_LOCAL

 

         name WAN_LOCAL

 

     }

 

}

 

ipv6 {

 

     enable {

 

     }

 

}

 

mtu 1500

 

name-server auto

 

password ****

 

user-id ****@snap.net.nz


defiant
1097 posts

Uber Geek

Lifetime subscriber

  #2414593 8-Feb-2020 11:03
Send private message quote this post

Nice one @axlback

Always a sense of relief when it just works 👍

7 posts

Wannabe Geek


  #2424707 20-Feb-2020 22:05
Send private message quote this post

I'm at it again, now trying to add ipv6 to my VLANs, eth1.30 and eth1.40

 

I've tried the instructions as per #1806397 (changing vif to my tags), but get this error:

 

@EdgeRouter-4# edit interfaces ethernet eth0 vif 10 pppoe 0 dhcpv6-pd pd 0

 

[edit interfaces ethernet eth0 vif 10 pppoe 0 dhcpv6-pd pd 0]

 

@EdgeRouter-4# set interface eth1 vif 30 host-address ::1

 

The specified configuration node is not valid

 

Set failed

 

[edit interfaces ethernet eth0 vif 10 pppoe 0 dhcpv6-pd pd 0]

 

 

 

Any help appreciated. Current config below.

 

 

 

default-route auto

 

dhcpv6-pd {

 

     pd 0 {

 

         interface eth1 {

 

             host-address ::1

 

             prefix-id :0

 

             service slaac

 

         }

 

         interface eth2 {

 

             host-address ::1

 

             prefix-id :1

 

             service slaac

 

         }

 

         prefix-length /56

 

     }

 

     prefix-only

 

     rapid-commit enable

 

}

 

firewall {

 

     in {

 

         ipv6-name WAN6_IN

 

         name WAN_IN

 

     }

 

     local {

 

         ipv6-name WAN6_LOCAL

 

         name WAN_LOCAL

 

     }

 

}

 

ipv6 {

 

     dup-addr-detect-transmits 1

 

     enable {

 

     }

 

}

 

mtu 1500

 

name-server auto

 

password ****

 

user-id ****@snap.net.nz


1 | ... | 36 | 37 | 38 | 39 | 40 | 41 | 42 | 43 | 44 | 45 | 46 
View this topic in a long page with up to 500 replies per page Create new topic



Twitter and LinkedIn »



Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

New Vodafone mobile data plans with unlimited data
Posted 26-Feb-2020 06:55


Vodafone launches innovation initiatives to help businesses use 5G
Posted 26-Feb-2020 05:00


Ultimate Ears HYPERBOOM brings massive sound and extreme bass
Posted 25-Feb-2020 09:00


Withings launches three new devices to help monitor heart health from home
Posted 13-Feb-2020 20:05


Auckland start-up Yourcar matches new car buyers with dealerships
Posted 13-Feb-2020 18:05


School gardens go high tech to teach kids the importance of technology
Posted 13-Feb-2020 11:10


Malwarebytes finds Mac threats outpace Windows for the first time
Posted 13-Feb-2020 08:01


Amazon launches Echo Show 8 in Australia and New Zealand
Posted 8-Feb-2020 20:36


Vodafone New Zealand starts two year partnership with LetsPlay.Live
Posted 28-Jan-2020 11:24


Ring launches indoor-only security camera
Posted 23-Jan-2020 17:26


New report findings will help schools implement the digital technologies curriculum content
Posted 23-Jan-2020 17:25


N4L to upgrade & support wireless internet inside schools
Posted 23-Jan-2020 17:22


Netflix releases 21 Studio Ghibli works
Posted 22-Jan-2020 11:42


Vodafone integrates eSIM into device and wearable roadmap
Posted 17-Jan-2020 09:45


Do you need this camera app? Group investigates privacy implications
Posted 16-Jan-2020 03:30



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.


Support Geekzone »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.