Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.


View this topic in a long page with up to 500 replies per page Create new topic
1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | 10 | 11 | 12 | 13 | 14 | 15 | ... | 28
4169 posts

Uber Geek
+1 received by user: 574

Trusted

  Reply # 1725159 23-Feb-2017 13:58
Send private message quote this post

CokemonZ:

 

why portfowarding? shouldn't upnp cover it?

 

Plex website says it should.

 

 

 

 

i tend to port forward since i don't trust upnp , but also I use a non standard port (so a remap from my external port to 32400 internally).





Previously known as psycik

NextPVR: 
Gigabyte AMD A8 Brix --> Samsung LA46A650D via HDMI, NextPVR,
OpenHAB: ODroid C2 eMMC DriveOpenHAB with Aeotech ZWave Controller, Raspberry PI, Wemos D1 Mini, Zwave and Bluetooth LE Sensors
Media:Chromecast v2, ATV4, Roku3, HDHomeRun Dual
Windows 2012 
Host (Plex Server/Crashplan): 2x2TB, 2x3TB, 1x4TB using DriveBender, Samsung 850 evo 512 GB SSD, Hyper-V Server with 1xW10, 1xW2k8, 2xUbuntu 16.04 LTS, Crashplan, NextPVR channel for Plex,NextPVR Metadata Agent and Scanner for Plex




Mr Snotty
8178 posts

Uber Geek
+1 received by user: 4160

Moderator
Trusted
Lifetime subscriber

  Reply # 1725168 23-Feb-2017 14:11
Send private message quote this post
 
 
 
 


146 posts

Master Geek
+1 received by user: 18


  Reply # 1725170 23-Feb-2017 14:14
Send private message quote this post

michaelmurfy:

 

It is a wizard on the Edgerouter and yes it works.

 

 

 

 

 

When I ran this wizrd it only enabled upnp, not upnp 2.

 

I understand upnp2 is also nat-pmp which is what xbox live requires.

 

Or should I disable upnp2 and just use the wizard?




Mr Snotty
8178 posts

Uber Geek
+1 received by user: 4160

Moderator
Trusted
Lifetime subscriber

  Reply # 1725213 23-Feb-2017 14:47
Send private message quote this post

CokemonZ:

 

When I ran this wizrd it only enabled upnp, not upnp 2.

 

I understand upnp2 is also nat-pmp which is what xbox live requires.

 

Or should I disable upnp2 and just use the wizard?

 

 

I've just checked my configuration and I only have UPNP enabled on one of the interfaces which my PS4 and PC sits on for gaming, have not even bothered with UPNP2. The PS4 shows a medium NAT (which is what you want on a network) and required ports are forwarding. The Xbox supports UPNP fine.

 

If you wanted to enable UPNP2 do it via the terminal (configure command):

 

You may want to clear off old configuration you may have first:

 

delete service upnp
delete service upnp2
commit

 

Then running this will enable upnp2 + nat-pmp:

 

set service upnp2 nat-pmp enable
set service upnp2 secure-mode enable
set service upnp2 wan eth0 <-- where eth0 is your outbound interface.
set service upnp2 listen-on eth1 <-- where eth1 is your inside interface.
commit
save

 

Edit: Confirmed this works.





146 posts

Master Geek
+1 received by user: 18


  Reply # 1725218 23-Feb-2017 14:52
Send private message quote this post

invalid command....???

 

 

 




Mr Snotty
8178 posts

Uber Geek
+1 received by user: 4160

Moderator
Trusted
Lifetime subscriber

  Reply # 1725220 23-Feb-2017 14:55
Send private message quote this post

CokemonZ:

 

invalid command....???

 

I updated the above post. You need to type configure first before any configuration. commit commits the configuration and save saves it to the startup configuration exit to exit once you've saved or exit discard to exit and ignore any configuration changes (if you screw something up and don't want to save).





146 posts

Master Geek
+1 received by user: 18


  Reply # 1725221 23-Feb-2017 15:00
Send private message quote this post

ok - up to the inside lan portion.

 

I can't set it as switch0

 

says node is invalid.

 

should i add all 3 eth ports?




Mr Snotty
8178 posts

Uber Geek
+1 received by user: 4160

Moderator
Trusted
Lifetime subscriber

  Reply # 1725223 23-Feb-2017 15:02
Send private message quote this post

CokemonZ:

 

ok - up to the inside lan portion.

 

I can't set it as switch0

 

says node is invalid.

 

should i add all 3 eth ports?

 

 

No - look at the post again sorry. I did a spelling error. It should be "set service upnp2 listen-on switch0" or whatever your switch interface sits on.





146 posts

Master Geek
+1 received by user: 18


  Reply # 1725226 23-Feb-2017 15:03
Send private message quote this post

spelling mistake

 

got it

 

 


146 posts

Master Geek
+1 received by user: 18


  Reply # 1725231 23-Feb-2017 15:06
Send private message quote this post

hmmm.....still not working

 

 

 


146 posts

Master Geek
+1 received by user: 18


  Reply # 1725233 23-Feb-2017 15:07
Send private message quote this post

and it looks right

 




Mr Snotty
8178 posts

Uber Geek
+1 received by user: 4160

Moderator
Trusted
Lifetime subscriber

  Reply # 1725235 23-Feb-2017 15:08
Send private message quote this post

CokemonZ:

 

hmmm.....still not working

 

Lies :) restart Plex and ensure you've configured your correct outbound interface (eg: pppoe0, eth0.10 or whatever port has the public IP).

 





146 posts

Master Geek
+1 received by user: 18


  Reply # 1725242 23-Feb-2017 15:19
Send private message quote this post

now i feel dumb.

 

Thanks for your help @michaelmurfy

 

The whole issue (the whole time) was eth0 instead of pppoe0

 

Damn!


IcI

854 posts

Ultimate Geek
+1 received by user: 184

Trusted

  Reply # 1725314 23-Feb-2017 17:09
Send private message quote this post

@benokobi: I blame this tutorial for the Ubiquiti shopping spree I went on yesterday. ...

 

If you want alternatives, several people have mentioned the Ruckus. I'd be willing to give Eero a try, but they are not available in NZ.

 

 

 

Edit: at mention





Please keep this GZ community vibrant by contributing in a constructive & respectful manner.


288 posts

Ultimate Geek
+1 received by user: 22


  Reply # 1725671 24-Feb-2017 13:37
Send private message quote this post

Why is it with the ERL, when I sh into the router, there are some files (a lot) that I can't modify or delete, which I could on my old Gargoyle router?  e.g. even the dnsmasq file downloaded from dns4me.  I've tried chmod -x but it won't let me do that.  Are there some permission settings or something that I'm missing?

 

 


1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | 10 | 11 | 12 | 13 | 14 | 15 | ... | 28
View this topic in a long page with up to 500 replies per page Create new topic



Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.


Geekzone Live »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.