1) disable wifi on the Spark router
2) connect C2 internet port to a lan port on HG659b
3) setup wifi on the C2
4) adjust archer C2 settings as needed (its not that hard to do this)

 

problem solved  :-)
that should give better wifi than another ISP's router .