Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




3 posts

Wannabe Geek


# 223810 18-Oct-2017 12:12
Send private message

Hi all,

 

I'm with 2Degrees for my VDSL (formerly SNAP as far as I can tell but they'd changed before I signed up).  I want to move my FritzBox out of the job it's doing as a firewall and router and relegate it to be nothing but a wifi gateway and handle phones.

 

I have my old Spark VDSL modem - an HG630b - which I can get to connect via VDSL to 2Degrees just fine.  It works nicely in either bridged mode or handling the PPPoE and routing itself - I get internets.

 

I want to run in bridged mode and use my shiny Mikrotik router - a CCR1009-7G-1C-1S+ - to handle the PPPoE and routing.

 

 

 

I have switched the HG630b into bridged mode, bound to eth4 (keeping eth1 for management etc).

 

I have created a VLAN on eth1 on the Mikrotik with VLAN-ID 10, then created a pppoe client connection and bound it to the newly created VLAN.

 

If I run a PPPoE scan on the VLAN, I can see "SNAP-69" and a MAC address, suggesting that it's working correctly, but I can't get the PPPoE client state to do anything other just sit at "Connecting...".

 

 

 

When I unplug the phone line from the HG630b it switches status to: "disconnected".

 

My setup:

 

Regular boring ethernet cable from ether1 on the Mikrotik to LAN4 on the HG630b

 


/interface ethernet
set [ find default-name=ether1 ] advertise=10M-full,100M-full,1000M-full arp=enabled arp-timeout=auto auto-negotiation=yes bandwidth=unlimited/unlimited disabled=no full-duplex=yes l2mtu=1580 loop-protect=\
default loop-protect-disable-time=5m loop-protect-send-interval=5s mac-address=64:D1:54:E6:EB:F1 master-port=none mtu=1500 name=ether1 orig-mac-address=64:D1:54:E6:EB:F1 rx-flow-control=off speed=100Mbps \
tx-flow-control=off
/interface vlan
add arp=enabled arp-timeout=auto disabled=no interface=ether1 loop-protect=default loop-protect-disable-time=5m loop-protect-send-interval=5s mtu=1500 name=vlan10 use-service
/interface pppoe-client
add ac-name=SNAP-69 add-default-route=yes allow=pap,chap,mschap1,mschap2 default-route-distance=0 dial-on-demand=no disabled=no interface=vlan10 keepalive-timeout=60 max-mru=
2Degrees-PPPoE password=password profile=default service-name="" use-peer-dns=yes user=username@snap.net.nz


I can't figure out what I'm missing, it seems like this should just work.  Does anyone know where I'm going wrong?

 

Many thanks and kind regards,

 

char


Create new topic
2418 posts

Uber Geek

Lifetime subscriber

  # 1885701 18-Oct-2017 13:35
One person supports this post
Send private message

My guess is that traffic from HG630 is untagged.





Spark FibreMAX using Mikrotik CCR1009-8G-1S-1S+. Apple TV 4, Apple TV 4K, iPad Air 1, iPhone 6s, VodaTV Gen 2. If it doesn't move then its data cabled.




3 posts

Wannabe Geek


  # 1885740 18-Oct-2017 14:52
Send private message

I'd configured the VDSL interface on the HG to tag VLAN10 via the "Basic -> Link Interface -> VDSL" screen.  Although I'd have assumed that the entire thing wouldn't work if that were the issue surely? ie the HG works pretty well on it's own in router mode instead of bridged.  It's when I bridge and try to use the Mikrotik that everything stops working.


 
 
 
 




3 posts

Wannabe Geek


  # 1885750 18-Oct-2017 15:00
Send private message

SUCCESS!

 

On a whim, I tried turning off the VLAN tagging on the HG.  Suddenly everything started working, thank you so much for pointing me that way!


Create new topic



Twitter and LinkedIn »



Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

Vodafone New Zealand starts two year partnership with LetsPlay.Live
Posted 28-Jan-2020 11:24


Ring launches indoor-only security camera
Posted 23-Jan-2020 17:26


New report findings will help schools implement the digital technologies curriculum content
Posted 23-Jan-2020 17:25


N4L to upgrade & support wireless internet inside schools
Posted 23-Jan-2020 17:22


Netflix releases 21 Studio Ghibli works
Posted 22-Jan-2020 11:42


Vodafone integrates eSIM into device and wearable roadmap
Posted 17-Jan-2020 09:45


Do you need this camera app? Group investigates privacy implications
Posted 16-Jan-2020 03:30


JBL launches headphones range designed for gaming
Posted 13-Jan-2020 09:59


Withings introduces ScanWatch wearable combining ECG and sleep apnea detection
Posted 9-Jan-2020 18:34


NZ Police releases public app
Posted 8-Jan-2020 11:43


Suunto 7 combine sports and smart features on new smartwatch generation
Posted 7-Jan-2020 16:06


Intel brings innovation with technology spanning the cloud, network, edge and PC
Posted 7-Jan-2020 15:54


AMD announces high performance desktop and ultrathin laptop processors
Posted 7-Jan-2020 15:42


AMD unveils four new desktop and mobile GPUs including AMD Radeon RX 5600
Posted 7-Jan-2020 15:32


Consolidation in video streaming market with Spark selling Lightbox to Sky
Posted 19-Dec-2019 09:09



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.


Support Geekzone »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.