Geekzone: technology news, blogs, forums
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.

10 posts

Wannabe Geek

# 223985 27-Oct-2017 11:47
Send private message

I just bought a new router, the NETGEAR R7800, and installed LEDE firmware.


I intend to have this as the main router and wireless AP, with it connected to the ONT. No other routers involved.


My ISP is 2Degrees and I am on 100/20 UFB.


How do I go about setting it up to work in this configuration?




Currently, LEDE is default with the exception that I have enabled WiFi. By default, it is set to DHCP and so I have the Netgear currently plugged into the ISP supplied router's LAN port (FRITZ!Box 7490) for internet access and to configure the Netgear router.


I read that I need to change it from DHCP to PPOE, put in my ISP account information, and set VLAN to 10, not sure if that is absolutely everything, how do I go about doing that?




Here are some screenshots of the configuration pages:





Filter this topic showing only the reply marked as answer Create new topic

10 posts

Wannabe Geek

  # 1891837 28-Oct-2017 13:05
Send private message

Any help would be much appreciated. I am most unsure about the interfaces in the 'Switches' tab and the 'Physical Settings' tabs.





497 posts

Ultimate Geek

  # 1892038 29-Oct-2017 00:06
One person supports this post
Send private message

I have a Linksys WRT1900ac running LEDE working as an access point only, not as a router, but I tried a few things with the GUI without actually making any changes and I think I can point you at how to do it.


In LUCI, go to Network > Switch.  Under VLANs, click the "Add" button.  On the new VLAN, change the VLAN ID to 10 and set "CPU (eth0)" to untagged and "WAN" to tagged.  This creates a VLAN on the CPU's eth0 interface that is tagged as VLAN 10 on the WAN port on the outside of the router.  The VLAN 10 tag is removed from the packets from the WAN port as they enter the eth0 port ready for routing inside the router.


Then go to Network > Interfaces.  Click "Add new interface".  Give the new interface a name (eg "ISP") and change the "Protocol of the new interface" to PPPoE.  In the list under "Cover the following interface" you should see the new VLAN  10 interface you have just created.  Select that interface and click "Submit".  There should then be a way of giving the user ID and password for the PPPoE connection somewhere - I am not sure about how that works.


So now you should have a PPPoE client running on VLAN 10 on the WAN port.  At this point, having not actually tried this, I am not sure if it will just work, or if there is more config needed.  You may need to go Network > Static routes and create a static default route ( on the PPPoE interface.  You will need to set up firewall settings so that NAT masquerading is done on the PPPoE interface.


Note that the UFB connection is overprovisioned to allow for ISP connections using PPPoE.  The PPPoE protocol adds an extra 8 bytes of PPPoE headers to each packet, so you set the Ethernet interface to the ONT to use an MTU of 1508, and the PPPoE interface can then be set to an MTU of 1500 (overriding its normal default), allowing full size TCP/IP packets to be sent.  Without that, your internal network will be using an MTU of 1500 but the PPPoE interface will only be able to handle packets of size 1500-8=1492, so IPv4 packets of size 1493-1500 will be fragmented, slowing down the connection.  And 2Degrees supports IPv6, and if you enable that with the PPPoE interface only handling packets up to 1492 bytes, there will be nasty problems where the IPv6 packets in the 1492-1500 byte range may be silently dropped, as IPv6 does not do fragmentation and the commonly available PPPoE software has a bug that fails to send the required IPv6 ICMPv6 packet to notify the TCP/IP stack when it drops over long packets.


For anyone reading this who is using a FritzBox on 2Degrees, they normally set up the overprovisioning automatically as part of the normal 2Degrees config that they load into the FritzBox.  But if you are using IPv6 and have problems with IPv6 capable web sites that use long frames, call 2Degrees to get them to check your config.  The normal site that always causes problems that people notice when IPv6 is set up for the first time but the overprovisioning is not set up properly is Facebook.  It pretty much stops working as its opening pages send lots of full length IPv6 frames.


Note: I have my WRT1900ac running LEDE 17.01.4+updates - this has the KRACK fixes and KRACK mitigation option installed.  The ability to use the GUI to set the "option wpa_disable_eapol_key_retries '1'" KRACK mitigation option only comes if you run "opkg update" and upgrade all the updated LUCI packages to the newest version.  Anyone using OpenWRT/LEDE on a WiFi device should update to this version immediately and do all the updates, then set that option.


For more help, the LEDE forums are here:


10 posts

Wannabe Geek

  # 1900602 14-Nov-2017 12:24
Send private message

Hi, sorry for the late reply. I did the vlan 10 on the switch and the connection worked straight away. I came back and reread your additional information. Not sure if I have to do anything else to get an optimal connection if it is already working.


All I did was the following:





  • The static route page is empty, not sure if I should set up that static route regardless.
  • The Override MTU entries for LAN, WAN, and WAN6, have a greyed out 1500. You reckon I should change the LAN to 1508 and the WAN & WAN6 to 1500?
  • I will look at updating the packages. I just installed a custom firmware that was already built for this router.


10 posts

Wannabe Geek

  # 1900612 14-Nov-2017 12:32
Send private message

I set LAN to 1508 MTU, and WAN & WAN6 to 1500 MTU.


  • At I get a 10/10 score for IPv6.
  • Speed test results look normal.

It doesn't seem to have broken anything by doing this, but if I did it wrong, let me know.

10 posts

Wannabe Geek

  # 1900625 14-Nov-2017 12:57
Send private message

SQM QoS also has an option regarding the MTU. There is page called Link Layer Adaptation, where I can specify a link layer to account for.


  • None (default)
  • Ethernet with overhead
  • ATM

There is also a checkbox for advanced options for MTU >1500.


Here is what it looks like when I click Ethernet with overhead and tick the checkbox, these are the default values when doing so:



For now, I left the checkbox unticked and just set the overhead to Ethernet and 8 bytes.


Everything is working fine, but I can't see any difference between this and leaving all the MTU and overhead settings as default.

10 posts

Wannabe Geek

  # 1900659 14-Nov-2017 13:38
Send private message

I reset the MTU and overhead to default. Everything works fine. IPv6 tests are 10/10.





Test IPv6 large packet





ok (0.822s) using ipv6






Maybe 2Degrees fixed it?

497 posts

Ultimate Geek

  # 1900982 14-Nov-2017 21:29
Send private message



I reset the MTU and overhead to default. Everything works fine. IPv6 tests are 10/10.


Test IPv6 large packet   ok (0.822s) using ipv6


Maybe 2Degrees fixed it?



Even if they did, without you using the overprovisioning you will still be slowing down your IPv6 traffic by using smaller packet sizes - it will just be happening automatically using the MTU discovery mechanism.  So if you can set up PPPoE to use an MTU of 1508, you should.


10 posts

Wannabe Geek

  # 1900995 14-Nov-2017 22:25
Send private message

Alright thanks for the help. I'll set it to LAN 1508, WAN 1500 again.

Filter this topic showing only the reply marked as answer Create new topic

Twitter and LinkedIn »

Follow us to receive Twitter updates when new discussions are posted in our forums:

Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:

Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:

News »

Ring launches indoor-only security camera
Posted 23-Jan-2020 17:26

New report findings will help schools implement the digital technologies curriculum content
Posted 23-Jan-2020 17:25

N4L to upgrade & support wireless internet inside schools
Posted 23-Jan-2020 17:22

Netflix releases 21 Studio Ghibli works
Posted 22-Jan-2020 11:42

Vodafone integrates eSIM into device and wearable roadmap
Posted 17-Jan-2020 09:45

Do you need this camera app? Group investigates privacy implications
Posted 16-Jan-2020 03:30

JBL launches headphones range designed for gaming
Posted 13-Jan-2020 09:59

Withings introduces ScanWatch wearable combining ECG and sleep apnea detection
Posted 9-Jan-2020 18:34

NZ Police releases public app
Posted 8-Jan-2020 11:43

Suunto 7 combine sports and smart features on new smartwatch generation
Posted 7-Jan-2020 16:06

Intel brings innovation with technology spanning the cloud, network, edge and PC
Posted 7-Jan-2020 15:54

AMD announces high performance desktop and ultrathin laptop processors
Posted 7-Jan-2020 15:42

AMD unveils four new desktop and mobile GPUs including AMD Radeon RX 5600
Posted 7-Jan-2020 15:32

Consolidation in video streaming market with Spark selling Lightbox to Sky
Posted 19-Dec-2019 09:09

Intel introduces cryogenic control chip to enable quantum computers
Posted 10-Dec-2019 21:32

Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.

Support Geekzone »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron

Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.