For Users with Vista and DBT122 and are looking for working PAN access TO your PC I have prepared the following.

first uninstall.

remove any existing bluetooth drivers, d-link, widcom, microsoft bluetooth enumerator,
microsoft intelitype and intelipoint. do this first through programs and features in the control panel and then second in the device manager.

unplug your bluetooth device and reboot.

download and run the “registry” tool of Ccleaner.
download and run a fix/clean with wise registry tool, or whatever reg cleaner you have.

the prep work

MOST important steps read carefully.
open c:\windows\inf and rename bth.inf and bth.pnf to bth.inf.old and bth.pnf.old
then
download the C1 revision drivers from here.
ftp://ftp.dlink.ru/pub/Wireless/DBT-...1%20Driver.rar
this is your golden ticket. These drivers ALLOW the network bridge that you need to share your LAN with your Bluetooth Network PAN Access Connection.

Unrar the download. go into the win32 folder and run setup. plug in your dbt122 if/when prompted and finish the setup. MAKE SURE TO CHOOSE ALLOW UNSINGED DRIVER INSTALL WHEN PROMPTED.
Dont worry about doing the inital setup wizard, trust me on this JUST WAIT. Once setup is complete REBOOT and let windows find the WORKING driver for your dbt122 (this is why we waited to pair). Vista should say “ready to use” when this is done.

Pairing

Pair your devices ie phone pda etc. Choose all the services you wish to offer (i recommend NOT choosing dun unless you know what you are selecting) The next time you connect to your pc FROM your device watch the icon in your tray it SHOULD turn green and you gotta click on it b4 it goes white again to setup the always allow access prompt.

Not there yet.

Make sure you go into vistas manage network connections section and bridge the LAN connection with the Blue Tooth network Access Conection. (if you cant bridge you didnt use the right dbt drivers. start over) Dont worry about ajsuting ANY settings here just make sure your got auto dhcp enabled on your lan b4 your bridge.
AND
Right click bt tray icon and chose bluetooth configuration. goto local services->dbl click network access. Change the drop down to “allow other devices to use the internet/network through this compueter. click apply and okay.

(i had to pair again here and redo the always allow access prompt for some reason)

Once this is complete your gtg. Hope this helps it took 3 weeks of trial and error to figure out. (and lots of dirty looks from the misses)

Now for the love of god remember the following. DO NOT UPDATE YOUR BLUETOOTH STACK TO A NEWER VERSION. DO NOT INSTALL ANY BROADCOM / WIDCOMM UPDATES. AND DO NOT UPDATE THE DRIVER FOR YOUR DBT122…. DONT DO IT YOULL MESS IT ALL UP.

Anyways hope this helps. There is now a definitve guide to getting pan network access FROM your computer to your device with the dbt122 and windows vista (SP1 at that)

-cope