Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




8 posts

Wannabe Geek


Topic # 229021 3-Feb-2018 22:33
Send private message quote this post

Hi there,

 

Vodafone have 'upgraded' my internet to FibreX 200/20 and with it replaced the various pieces of equipment I had with a technicolor cable modem and seperate router. I have a Mikrotik router configured and managing all my home devices well and do not want to transfer them all to the new router (which does not seem to like the number I devices I tried to connect).

 

I have been trying to set up the Mikrotik to directly connect to the technicolor cable modem (following this guide - https://www.geekzone.co.nz/forums.asp?forumid=66&topicid=206084, but also setting up dhcp client for IPv6) but cannot get a working connection.

 

I have:

 

1) connected the Mikrotik directly to the technicolor cable modem

 

2) run through the guide above to enable vlan tagging / dhcp / changed firewall rules etc (and enabled ipv6 too)

 

3) confirmed I am receiving an IPv4 and IPv6 address in the dhcp-client section of the mikrotik

 

4) restarted everything just in case

 

5) failed to get a connection to the internet

 

6) tried factory resetting the mikrotik incase any old rules were breaking something

 

7) still failed to get a connection to the internet

 

This has all got a bit beyond me - I have enough knowledge to follow various guides, but not enough to troubleshoot / diagnose what is actually happening here (i.e. enough knowledge to break something... but not fix it). From the guides I have read, once I have confirmed I am getting dhcp to provide IP address from the technicolor / vodafone, and provided I have the firewall configured correctly, I should be getting internet, but I am not.

 

Any help would be appreciated.


Create new topic
Meow
7095 posts

Uber Geek
+1 received by user: 3333

Moderator
Trusted
Lifetime subscriber



8 posts

Wannabe Geek


  Reply # 1951306 4-Feb-2018 10:15
Send private message quote this post

michaelmurfy:

 

Did you read through the IPoE instructions here? https://www.geekzone.co.nz/forums.asp?forumid=66&topicid=206084 

 

 

Thanks michaelmurfy

 

I did - and followed through exactly first time - second / third time (after reset mikrotik), the first highlighted rule (Drop all from WAN) was no longer there. I had the following (and have tried the drop invalid both with the Vlan interface as in interface and with nothing):

 

Click to see full size

 

I do note I have not changed any of the IPv6 Firewall rules, which look like this:

 

Click to see full size

 

Click to see full size

 

I did update the NAT masquarade rule (as follows):

 

Click to see full size

 

I still do not have internet (but still showing has received IP address in DHCP Client for both IPv4 and IPv6).

 

Thanks very much for the assistance - happy to provide more screenshots / try out ideas.


 
 
 
 




8 posts

Wannabe Geek


  Reply # 1954578 9-Feb-2018 22:05
Send private message quote this post

Figured out what was going wrong - 2 of the default rules once resetted the Mikrotik were different from what needed to be. What I did to fix was:

 

1) Create a new firewall rule with: Chain=input, In.Interface=VLAN (my default firewall rules did not have this rule and I was editing another rule I should not have); and

 

2) change my Masquerade rule, which was pre configured with an out.interface.list - once removed the out.interface.list, internet came back up.

 

Hope helps someone else - the original Mikrotik guide here (https://www.geekzone.co.nz/forums.asp?forumid=66&topicid=206084) worked a treat, my default config was just starting from a different point.

 

Glad I have my lovely stable and secure router back!


Create new topic



Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

CPTPP text and National Interest Analysis released for public scrutiny
Posted 21-Feb-2018 19:43


Foodstuffs to trial digitised shopping trolleys
Posted 21-Feb-2018 18:27


2018: The year of zero-login, smart cars & the biometrics of things
Posted 21-Feb-2018 18:25


Intel reimagines data centre storage with new 3D NAND SSDs
Posted 16-Feb-2018 15:21


Ground-breaking business programme begins in Hamilton
Posted 16-Feb-2018 10:18


Government to continue search for first Chief Technology Officer
Posted 12-Feb-2018 20:30


Time to take Appleā€™s iPad Pro seriously
Posted 12-Feb-2018 16:54


New Fujifilm X-A5 brings selfie features to mirrorless camera
Posted 9-Feb-2018 09:12


D-Link ANZ expands connected smart home with new HD Wi-Fi cameras
Posted 9-Feb-2018 09:01


Dragon Professional for Mac V6: Near perfect dictation
Posted 9-Feb-2018 08:26


OPPO announces R11s with claims to be the picture perfect smartphone
Posted 2-Feb-2018 13:28


Vocus Communications wins a place on the TaaS panel
Posted 26-Jan-2018 15:16


SwipedOn raises $1 million capital
Posted 26-Jan-2018 15:15


Slingshot offers unlimited gigabit fibre for under a ton
Posted 25-Jan-2018 13:51


Spark doubles down on wireless broadband
Posted 24-Jan-2018 15:44



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.