Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




10 posts

Wannabe Geek


Topic # 23442 29-Jun-2008 17:05
Send private message

Hi,

This is in response to a couple of questions about my ealier (now locked) post:

http://www.geekzone.co.nz/forums.asp?ForumId=49&TopicId=22334

No I never got my AM300 to work reliably work in half-bridge.  The AM300 was always happy connecting to the net (ie the Internet light always came on), but my DLink wireless router would only connect to it under two circumstances:

1. The modem is in full router mode, or
2. The modem is in full router mode, everything is working together including the wireless router, then I navigate to the modem setup page and change it to half-bridge and reboot the modem. 

Scenario 2 seems to only work because the wireless router already had a working WAN connection with the initial DHCP lease to the modem when it was in full router mode.  However, if I reboot the wireless router, or power down then I have to reset the AM300 back to full router mode and repeat all the steps before the wireless will work with it again.  And that is a huge pain, so I've just gone with option 1 above (ie I have 2 layers of NATing, firewalls, port mappings etc). 

I figure my problem is one of interoperability between the way Linksys implement the half-bridge via their DHCP server implementation vs DLink's DHCP client implementation - ie the problem might not exist with other wireless routers (and indeed I've seen many posts on here regarding AM300's working fine in half-bridge mode with Linksys wireless routers).

You will also find (as posted elswhere on geekzone) that getting the AM300 half-bridge working is often a matter of sequence and timing - ie you may have to reboot/power on in a particular order.

Also, the AM300 half-bridge mode works fine when the AM300 is connected directly to my PC - but that not a workable solution for most people as the whole point of having a wireless router is that you've typically got more than one PC and at least one wireless client (laptop etc).

Hope that helps.

Cheers,
dunc

View this topic in a long page with up to 500 replies per page Create new topic
 1 | 2
234 posts

Master Geek
+1 received by user: 5


  Reply # 141271 29-Jun-2008 17:25
Send private message

dunc:
I figure my problem is one of interoperability between the way Linksys implement the half-bridge via their DHCP server implementation vs DLink's DHCP client implementation - ie the problem might not exist with other wireless routers (and indeed I've seen many posts on here regarding AM300's working fine in half-bridge mode with Linksys wireless routers).


I have the same problem, but with a Linksys Router (BEFSX41). I worked around this by entering the address details (luckily I have a static IP). When I was trying to get the DHCP to work, I noticed that there were IP address spoofing errors (for my external IP address) reported in the firewall logs. Maybe this is the firewall rejecting the DHCP response from the AM300?

I did manage to get the router acquire to an IP address from the AM300 using DHCP once or twice, which looked like being the result of powering up and connecting in the "right" order.  But once it lost the connection (e.g. a config change), it never managed to recover on its own, and requesting the address manually didn't work ever.



10 posts

Wannabe Geek


  Reply # 141375 30-Jun-2008 09:07
Send private message

tr3v:
dunc:
I figure my problem is one of interoperability between the way Linksys implement the half-bridge via their DHCP server implementation vs DLink's DHCP client implementation - ie the problem might not exist with other wireless routers (and indeed I've seen many posts on here regarding AM300's working fine in half-bridge mode with Linksys wireless routers).


I have the same problem, but with a Linksys Router (BEFSX41). I worked around this by entering the address details (luckily I have a static IP). When I was trying to get the DHCP to work, I noticed that there were IP address spoofing errors (for my external IP address) reported in the firewall logs. Maybe this is the firewall rejecting the DHCP response from the AM300?

I did manage to get the router acquire to an IP address from the AM300 using DHCP once or twice, which looked like being the result of powering up and connecting in the "right" order.  But once it lost the connection (e.g. a config change), it never managed to recover on its own, and requesting the address manually didn't work ever.


I'm assuming you mean the firewall on the wireless router?  I'll check mine tonight.

 
 
 
 


234 posts

Master Geek
+1 received by user: 5


  Reply # 141383 30-Jun-2008 09:49
Send private message

I doubt that this is relevant, but I also noticed that I had NAT enabled on both the AM300 and the router. I disabled NAT on the AM300 when I realised this.



10 posts

Wannabe Geek


  Reply # 141548 30-Jun-2008 16:02
Send private message

tr3v: I doubt that this is relevant, but I also noticed that I had NAT enabled on both the AM300 and the router. I disabled NAT on the AM300 when I realised this.


Yeah I wondered about that as well, but in half-bridge mode toggling the NAT setting seems to make no difference in my setup (ie it still didn't work).

1340 posts

Uber Geek
+1 received by user: 159

Trusted

  Reply # 141668 30-Jun-2008 20:40
Send private message

Not to state the obvious, but you are running firmware v1.19.04 on the AM300 right?

What happens if you set the AM300 to half-bridging, leave the DHCP server on, but leave DHCP off on the DLink router and manually set the router to use the WAN ip settings that it should be picking up? (ie; assigned internet ip, subnet, gateway etc...)

When you connect the AM300 directly to your PC, does your PC pick up the correct IP details via DHCP from the AM300?

32 posts

Geek


  Reply # 141716 30-Jun-2008 22:16
Send private message

I didn't have much luck with my AM300 and Half bridge mode either.

My setup was AM300 -> WRT54G -> LAN. Latest firmware on AM300 and DD-WRT on the WRT54G.

I set up DHCP to renew every minute to catch when my ip would change (or when I might reboot the modem, etc). But what I found was each minute the WRT54G would zero out the ip address and wait a couple of seconds before getting a new one. This would cause all internet traffic to stop and sometimes time out. I don't know if this was the AM300 or the WRT at fault.

The weird thing was this setup worked perfectly when I had an older DSE modem...

Anyway, to solve it I just set the WRT54G as the DMZ ip on the AM300, and then the WRT54G did all the firewall stuff. Oh and yes this does mean double NATing, but this has been running for a few months without any noticable problems.

1340 posts

Uber Geek
+1 received by user: 159

Trusted

  Reply # 141728 30-Jun-2008 22:59
Send private message

I have a WRT54G, but it's running DD-WRT (custom firmware).  It's SUCH a superior firmware to the standard Linksys rubbish!!

I initially had the same problem with the droppout every minute to get a new DHCP IP with DD-WRT, but then wrote a DD-WRT script to get around the issue and it runs really well now!! Smile



10 posts

Wannabe Geek


  Reply # 141771 1-Jul-2008 08:39
Send private message

SamF: Not to state the obvious, but you are running firmware v1.19.04 on the AM300 right?


Yes I am running the v1.19.04 firmware on the AM300.  It originally came with 1.19.02, which had the half-bridge mode as well (but as I understand it couldn't handle gateways on different subnets?).

SamF: What happens if you set the AM300 to half-bridging, leave the DHCP server on, but leave DHCP off on the DLink router and manually set the router to use the WAN ip settings that it should be picking up? (ie; assigned internet ip, subnet, gateway etc...)


Not sure, haven't tried that.  At the moment if the AM300 and the Dlink are hooked up together in half-bridge mode I can't see the AM300.  However I should be able to do what you've described if I set it in normal mode first, then half-bridge it while the Dlink is still happy (ie scenario 2 in my original post), then try what you've described.

If I get the chance, I'll try that tonight.

SamF: When you connect the AM300 directly to your PC, does your PC pick up the correct IP details via DHCP from the AM300?


When I connect the AM300 in half-bridge mode directly to the PC it does pickup the correct IP details via DHCP from the AM300, albeit a lengthy process.  In other words the PC's DHCP client takes about 3-4 times longer to get the address from the AM300 because it gets the initial 192.168.1.x address (the default LAN subnet on the AM300), then reacquires a few seconds later and eventually picks up the new WAN IP address.  In this case the gateway on the PC is always on the same subnet as the WAN IP (on .254) despite the real gateway reported on the AM300 being on a different IP (and often on an entirely different subnet).  So the AM300 is doing something tricky there (when I had a Dynalink modem in IP-extension mode, the gateway was the real gateway, even if it was on a different subnet). 

A direct connection to the PC worked with the 1.19.02 in half-bridge mode as well, but I can't remember what it did for the gateway.

But the gateway isn't the problem in my case - the Dlink wireless router simply doesn't acquire a DHCP lease.  As someone else pointed out, this could be the firewall being too suspicious on the Dlink - when I get the chance I'll try it with the firewall off on the Dlink.

234 posts

Master Geek
+1 received by user: 5


  Reply # 141782 1-Jul-2008 09:11
Send private message

dunc:
SamF: What happens if you set the AM300 to half-bridging, leave the DHCP server on, but leave DHCP off on the DLink router and manually set the router to use the WAN ip settings that it should be picking up? (ie; assigned internet ip, subnet, gateway etc...)


Not sure, haven't tried that.  At the moment if the AM300 and the Dlink are hooked up together in half-bridge mode I can't see the AM300.  However I should be able to do what you've described if I set it in normal mode first, then half-bridge it while the Dlink is still happy (ie scenario 2 in my original post), then try what you've described.

This is how I got my setup to work, and it is all good now. In my case, I have an external static IP address which is no different except I am allocated the same IP address everytime I connect.

So, summarising... I have the AM300 set up in halfbridge mode, NAT off, and DHCP server on. I also turned keepalives on. My WAN config on my router (Linksys) is configured as static IP as SamF suggests with the gateway and DNS settings as provided. My PC managed to get the settings with a direct connection to the AM300 but it was slow, and unreliable. E.g. ipconfig /renew never worked. The router once or twice got the DHCP settings too, but it was random, and not repeatable.

1340 posts

Uber Geek
+1 received by user: 159

Trusted

  Reply # 141839 1-Jul-2008 12:17
Send private message

Hmm, it does sound like the AM300 does something non-standard with respect to DHCP address allocation.  Perhaps other Linksys products tend to work because they also use the same non-standard method?

It could even be something as simple as the timeout on the DLink being too short for the time it takes the AM300 to provide an address...

In any case I'm at the end of my experience on this, sorry I couldn't be of more help.

It will be interesting to see what happens when you statically assign the internet IP details to the DLink tho...



10 posts

Wannabe Geek


  Reply # 141851 1-Jul-2008 13:01
Send private message

SamF: Hmm, it does sound like the AM300 does something non-standard with respect to DHCP address allocation.  Perhaps other Linksys products tend to work because they also use the same non-standard method?

It could even be something as simple as the timeout on the DLink being too short for the time it takes the AM300 to provide an address...


Good point.  The Dlink and the AM300 work perfectly together in terms of DHCP if half-bridge is turned off, but not with it turned on, so you might be right.  When connected to my PC the AM300 does take significantly longer to issue the WAN IP address (after initially issueing a local subnet address first) than it does when half-bridge is off.  Like a minute or so.

SamF: In any case I'm at the end of my experience on this, sorry I couldn't be of more help.


No worries, you've already provided some food for thought, which is much appreciated Smile

SamF: It will be interesting to see what happens when you statically assign the internet IP details to the DLink tho...


 I'm sure that manually assigning the real IP address would work, however, as I don't have a static WAN IP arrangement with my ISP, this would be unworkable on an ongoing basis (I think they have short DHCP leases).  Having said that, if I get a chance to try it just the once, I'll do that.



10 posts

Wannabe Geek


  Reply # 141852 1-Jul-2008 13:05
Send private message

tr3v:
dunc:
SamF: What happens if you set the AM300 to half-bridging, leave the DHCP server on, but leave DHCP off on the DLink router and manually set the router to use the WAN ip settings that it should be picking up? (ie; assigned internet ip, subnet, gateway etc...)


Not sure, haven't tried that.  At the moment if the AM300 and the Dlink are hooked up together in half-bridge mode I can't see the AM300.  However I should be able to do what you've described if I set it in normal mode first, then half-bridge it while the Dlink is still happy (ie scenario 2 in my original post), then try what you've described.

This is how I got my setup to work, and it is all good now. In my case, I have an external static IP address which is no different except I am allocated the same IP address everytime I connect.

So, summarising... I have the AM300 set up in halfbridge mode, NAT off, and DHCP server on. I also turned keepalives on. My WAN config on my router (Linksys) is configured as static IP as SamF suggests with the gateway and DNS settings as provided. My PC managed to get the settings with a direct connection to the AM300 but it was slow, and unreliable. E.g. ipconfig /renew never worked. The router once or twice got the DHCP settings too, but it was random, and not repeatable.


If I had a static IP arrangement I think this would also work in my situation, but unfortunately thats not the case.

In my experience connecting to the PC directly, the DHCP assignment is always almost instaneous when the AM300 is not in half-bridge mode, however, when it is in half-bridge mode, the PC always get a local subnet assignment almost instanteously, then renegotiates a few seconds later, which always takes about a minute or so, and then it gets a WAN IP address.  If you issue any ipconfig /release or /renew while that process is already in progress it simply extends the time taken, but should work.

1340 posts

Uber Geek
+1 received by user: 159

Trusted

  Reply # 142060 1-Jul-2008 22:12
Send private message

My point in suggesting you try manually assigning the Internet IP address was more for troubleshooting to see which component was at fault...  At least it would allow you to focus your efforts / rage Laughing



10 posts

Wannabe Geek


Reply # 142114 2-Jul-2008 08:44
Send private message

SamF: My point in suggesting you try manually assigning the Internet IP address was more for troubleshooting to see which component was at fault...  At least it would allow you to focus your efforts / rage Laughing


Yup, I realised that and thanks for the tip, it is appreciated Smile

Now all I have to do is find 30mins to test this stuff out when I'm not busy and the other half isn't working from her laptop in the evening...  Wink

3594 posts

Uber Geek
+1 received by user: 79

Trusted
WorldxChange

  Reply # 142122 2-Jul-2008 09:07
Send private message

Just for your info, we have Linksys looking at some issues with this router when running in half bridge mode and hopefully expect to see some improvements in the near future, have no ETA for this but they are looking at it.




Yes I am a employee of WxC (My Profile) ... but I do have my own opinions as well Wink

             

https://www.facebook.com/wxccommunications

 1 | 2
View this topic in a long page with up to 500 replies per page Create new topic



Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

Symantec protects data everywhere with Information Centric Security
Posted 21-Sep-2017 15:33


FUJIFILM introduces X-E3 mirrorless camera with wireless connectivity
Posted 18-Sep-2017 13:53


Vodafone announces new plans with bigger data bundles
Posted 15-Sep-2017 10:51


Skinny launches phone with support for te reo Maori
Posted 14-Sep-2017 08:39


If Vodafone dropping mail worries you, you’re doing online wrong
Posted 11-Sep-2017 13:54


Vodafone New Zealand deploy live 400 gigabit system
Posted 11-Sep-2017 11:07


OPPO camera phones now available at PB Tech
Posted 11-Sep-2017 09:56


Norton Wi-Fi Privacy — Easy, flawed VPN
Posted 11-Sep-2017 09:48


Lenovo reveals new ThinkPad A Series
Posted 8-Sep-2017 14:37


Huawei passes Apple for the first time to capture the second spot globally
Posted 8-Sep-2017 10:45


Vodafone initiative enhances te reo Maori pronunciation on Google Maps
Posted 8-Sep-2017 10:40


Voyager Internet expand local internet phone services company with Conversant acquisition
Posted 6-Sep-2017 18:27


NOW Expands in to Tauranga
Posted 5-Sep-2017 18:16


Windows 10 Fall Creators Update coming Oct. 17
Posted 4-Sep-2017 14:10


Garmin introduce Garmin vivoactive 3
Posted 1-Sep-2017 18:38



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.