Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




32 posts

Geek


Topic # 245589 12-Feb-2019 08:40
Send private message

Hi all
Not sure where I'd put arduino related threads on this forum, but because its networking related, this seems the best place.

Im having a odd problem with my NodeMCU's

I recently updated my firewall and my script stopped working, I found that I had accidentally turned off ping between vlans. I allowed ICMP which is usually what ping runs over, but it still appears to be blocked.
So posting on another forum we got to the point where we know its the arduino having issues and not the firewall its self.

Turned on logging on firewall and noticed the following actions:

Ping router from Arduino - See the requests in firewall & arduino gets response. (Red line)
Send external web request from arduino - See requests in firewall & arduino gets response. (Orange Line)
Send web request to internal server - Arduino queries internal DNS and gets IP of web server, but no request send (Nothing in firewall logs) (Yellow and Blue)
Send ping to internal server - Arduino queries same dns server, gets ip, but no request sent (Firewall logs again) (Yellow and Green)

however, sending the ping and web request from desktop, shows both the firewall log blocking the ping request, and the rule allowing the web request.(Brown Purple Pink)

Have attached diagram again to help visualize whats going on
And can attach router logs or rules if required

https://imgur.com/a/g4TipmZ

Also have set a windows PC with the same IP address, and can ping the web server, so I know it's something wrong with the arduino's requests to the web server in particular, and not the firewall?

So for some reason, when doing any network traffic to that particular vlan / subnet from the arduino it wont send the requests.
Other devices with the same IP work fine, and other subnets / vlans work fine, just that particular range?

Things I am going to try tonight after work are
- Try a different IP on that subnet to see if its the IP or the range thats having issues.
- Try a wireshark capture to see if I can see the traffic on the LAN, then see if I can see any issues with the packets.


Create new topic
2588 posts

Uber Geek
+1 received by user: 1076

Trusted
Lifetime subscriber

  Reply # 2177295 12-Feb-2019 19:11
Send private message quote this post

What code are you running? I would try posting into the nodemcu or whoever provides the code and libraries that you are running and ask them.
I've never had a problem with Homie on my ESP-01 and on my other micro controllers.





Create new topic


Donate via Givealittle


Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

A call from the companies providing internet access for the great majority of New Zealanders, to the companies with the greatest influence over social media content
Posted 19-Mar-2019 15:21


Two e-scooter companies selected for Wellington trial
Posted 15-Mar-2019 17:33


GeForce GTX 1660 available now
Posted 15-Mar-2019 08:47


Artificial Intelligence to double the rate of innovation in New Zealand by 2021
Posted 13-Mar-2019 14:47


LG demonstrates smart home concepts at LG InnoFest
Posted 13-Mar-2019 14:45


New Zealanders buying more expensive smartphones
Posted 11-Mar-2019 09:52


2degrees Offers Amazon Prime Video to Broadband Customers
Posted 8-Mar-2019 14:10


D-Link ANZ launches D-Fend AC2600 Wi-Fi Router Protected by McAfee
Posted 7-Mar-2019 11:09


Slingshot commissions celebrities to design new modems
Posted 5-Mar-2019 08:58


Symantec Annual Threat Report reveals more ambitious, destructive and stealthy attacks
Posted 28-Feb-2019 10:14


FUJIFILM launches high performing X-T30
Posted 28-Feb-2019 09:40


Netflix is killing content piracy says research
Posted 28-Feb-2019 09:33


Trend Micro finds shifting threats require kiwis to rethink security priorities
Posted 28-Feb-2019 09:27


Mainfreight uses Spark IoT Asset Tracking service
Posted 28-Feb-2019 09:25


Spark IoT network now covers 98% of New Zealand population
Posted 19-Feb-2019 09:28



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.


Support Geekzone »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.