Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.


4 posts

Wannabe Geek


Topic # 26875 6-Oct-2008 14:16
Send private message

Hi,

I found this article relating to using a Dlink DSL502T in half bridge mode:

http://www.geekzone.co.nz/forums.asp?ForumId=49&TopicId=18700

I've had many late nights trying to get my VPN tunnel working between AKL and Welli where I have the following setup

Wellington:

1x Dlink DSL502T
1x LinksysWRV200 behind the DSL502T
Static IP assigned from Telstra


Auckland:

1x Dlink DSL502T
1x LinksysWRV200 behind the DSL502T
Static IP assigned from Xtra

I can get the tunnels to see each other, but I get the old expecting IP address , but got message:
014 [Wed 12:40:42] "TunnelA" #5: transition from state STATE_MAIN_I2 to state STATE_MAIN_I3
015 [Wed 12:40:42] "TunnelA" #5: STATE_MAIN_I3: sent MI3, expecting MR3
016 [Wed 12:40:42] "TunnelA" #5: Main mode peer ID is ID_IPV4_ADDR: '192.168.1.5'
017 [Wed 12:40:42] "TunnelA" #5: we require peer to have ID '219.89.195.17', but peer declares '192.168.1.5'
018 [Wed 12:40:42] "TunnelA" #5: sending encrypted notification INVALID_ID_INFORMATION to 219.89.195.17:4500

So to get the WRV200 to have the public IP address, I was going to use half bridge mode on the DSL502T, but for some reason it doesn't seem to pass it through to the WRV200.
The firmware I have on the DSL502T is V3.02B01T01.NZ.20071119.
I can see the status on the DSL502T says connected, and the Public IP is there, but even when I try bypassing the WRV200 with a Laptop and try to connect out, I cannot browse the internet.
I've rung D-Link and Linksys, but Linksys want me to at least be able to get the D-Link going, and D-link seem to think I come from the moon when I ask them questions

Can anyone help before I throw everything in the bin!

Cheers,

Hamish

Create new topic
8025 posts

Uber Geek
+1 received by user: 387

Trusted
Subscriber

  Reply # 169313 6-Oct-2008 15:26
Send private message

Yes when the ppoa half bridge setup is working properly the 502T should assign the public ip given to it by your ISP to be the wan ip of the WRV200 (via DHCP).

Does the Dlink have the latest firmware?

Is the Linksys set to get it's wan ip via dhcp?

What ISP/provider are you using at either end?  I ask because some ISP's (xnet, telstra etc) have their default gateway on a different subnet to the public ip address they assign and this confuses some halfbridge implementations.

Worst case scenario, bin the dlinks and get 2x Dynalink RTA1320's (they are sub $20 as new on trademe) I have several working perfectly in half bridge for me.  Note:  The half bridge option in the dynalinks is called ip extension and is in a weird part of the ui/menu heh.



4 posts

Wannabe Geek


  Reply # 169322 6-Oct-2008 15:45
Send private message

Hi,

The Telecom gateway is definitley on a different address range than the IP that it's asiggned. From memory it's on a 125 subnet, whereas the IP is 203 something.

I have a firmware to try from D-Link, it's DLinkNZ_DSL-502T_singleimage_kernel_fs_V3.02B01T01.NZ.20080827, so just got to make sure it's right for one of the D-Links, will try it on Wednesday night and see how it goes. I have tried DHCP, but nothing seemed to happen.

I may not have given it enough time though, it was 3am, and I was getting a bit tired.
So I should have DHCP enabled on the D-Link?

Cheers for responding.



4 posts

Wannabe Geek


Reply # 170015 8-Oct-2008 22:43
Send private message

Well I've just messed around with again for another few hours and tried the following:

1. reset the D-Link router to factory, upgraded to the latest firmware
2. Put back in all username and password, plus the static IP assigned from Xtra
3. Tested connecting to the internet in PPOA/PPOE mode, with the D-Link plugged into my laptop, the D-link had DHCP enabled, this worked fine.
4. Put D-Link into half bridge mode, left the DHCP enabled. Saved and rebooted. It still handed out the internal LAN interface DHCP range, and I couldn't connect to the internet at all.
5. Set bridge filters to any any from any mac address with any protocol, no success.
6. Tried configuring a static IP on the laptop of the public IP, disabled DHCP on the D-Link, saved and rebooted D-Link, no success.
7. Disabled firewall, have tried it with nat disabled and enabled as well.

So now I'm going to try the Dyanlink path, I have one at home, will have to check the model, but I think it does have Half Bridge, or Bridge mode.
If this fails, will get go for Cisco kit, as I'm runnning out of patience!

Cheers.

Create new topic

Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

Intel introduces new NUC kits and NUC mini PCs
Posted 16-Aug-2018 11:03


The Warehouse leaps into the AI future with Google
Posted 15-Aug-2018 17:56


Targus set sights on enterprise and consumer growth in New Zealand
Posted 13-Aug-2018 13:47


Huawei to distribute nova 3i in New Zealand
Posted 9-Aug-2018 16:23


Home robot Vector to be available in New Zealand stores
Posted 9-Aug-2018 14:47


Panasonic announces new 2018 OLED TV line up
Posted 7-Aug-2018 16:38


Kordia completes first live 4K TV broadcast
Posted 1-Aug-2018 13:00


Schools get safer and smarter internet with Managed Network Upgrade
Posted 30-Jul-2018 20:01


DNC wants a safer .nz in the coming year
Posted 26-Jul-2018 16:08


Auldhouse becomes an AWS Authorised Training Delivery Partner in New Zealand
Posted 26-Jul-2018 15:55


Rakuten Kobo launches Kobo Clara HD entry level reader
Posted 26-Jul-2018 15:44


Kiwi team reaches semi-finals at the Microsoft Imagine Cup
Posted 26-Jul-2018 15:38


KidsCan App to Help Kiwi Children in Need
Posted 26-Jul-2018 15:32


FUJIFILM announces new high-performance lenses
Posted 24-Jul-2018 14:57


New FUJIFILM XF10 introduces square mode for Instagram sharing
Posted 24-Jul-2018 14:44



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.