Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.


View this topic in a long page with up to 500 replies per page Create new topic
1 | 2 
124 posts

Master Geek
+1 received by user: 1


  # 256122 16-Sep-2009 13:46

corina

Not that much help, we haven't got it fixed yet !

Now I'm somewhat confused by mention of Atheros; this is a different chipset manufacturer altogether. My T42 for example could have been suppled with either Intel *or* Atheros wireless cards, so in its original config I guess the driver sets for both might have been available with all the "recovery" software. IBM calls the packages (driver plus Proset) wlanint or wlanath.  BUT my particular machine has the Intel2200 chipset card so I need to use the Intel driver *and* can use Intel Proset management software.

But you said the machine has the Intel 3945 - you know this because a) you've physically seen the card, b) you've looked at the product specs for the machine (and the card hasn't been swapped out) or c) because you've had a look in Device Manager and seen it listed as such *and* it was working ?

I am right in saying that wi-fi was working, it's just the Intel Proset management tool wasn't installed/available ? Proset supports just 3 Intel chipsets, 2200, 2915 and 3945 - if you don't have any of those then that may be why you were getting the "adapter not found" error

Have you gone through the process I suggested (noting point 2),


From Device manager, remove the wireless adapter then re-boot the machine.
On re-start XP "Found New Hardware" wizard should start but cancel it.
Then go to the unzipped contents of the Toshiba package download and run the Setup routine from the "top" of that folder. That should install the Toshiba-provided driver and the Proset s/w

If you have just uninstalled the wireless driver and let XP do its thing, it would only have installed the Atheros driver if the wirelss card identified itself as Atheros (hardware has code built in so the computer's BIOS and then operating systems can figure out what the harware is and apply the appropriate drivers - this is how the Windows "Hardware wizard" works - it probes the device, reads the id code, identifies the correct driver, or calls it an unknown device because the piece of hardware is maybe newer than Windows) - you can manually "force" another driver to be used by hardware but almost always that piece of hardware just won't work with the "wrong" driver.

If you do in fact have an Atheros chipset-based card then you *will* need the Atheros driver and Proset won't work.

So I guess we need to step back and ask, exactly what wireless card do you actually have in your laptop?

IG




7 posts

Wannabe Geek


  # 256133 16-Sep-2009 14:41
Send private message

Hi Again

Ok so I know I HAD a 3945 before it crashed because I was running my wireless through the Intel Proset and the ID sticker is on the bottom of my laptop.

I know when it caught a virus the person who fixed it said *quote* he'd never seen anything like it before and he couldn't read it at all - (whatever that means) so I lost everything so I think he had to basically start again (sorry unsure of tech terms lol).

So is it possible the 3945 was replaced with the Antheros?

Is there any way of telling?

Also I did what you said about uninstalling the wireless driver and rebooting, canceling wizard ect, and I ran the Toshiba package the Setup for some reason blinks orange at the bottom tab, it then installs the software but comes up saying Adapter problem - Driver not found.

Thanks for all your time!!

Corina

 
 
 
 


124 posts

Master Geek
+1 received by user: 1


  # 256151 16-Sep-2009 15:20

It's perfectly possible that the wireless card has been swapped out - although why for a virus I don't know !

The A-100 PSA9A only has the Intel drivers listed on the Toshiba website so that would have been the original fitting.

The fact that Proset is failing with "adapter not found" suggests there isn't a 3945/2915/2000 card in there.

So if you just let XP find the new hardware and install its idea of the correct driver do you end up with Atheros? If you can get a driver installed, look in Device Manager & see what its telling you is there.

Not sure where the wi-fi card sits in that machine - I know on the Thinkpads you need to seriously dis-assemble the case to get at them (but then again Thinkpads are built to be taken apart like that !!) - on some laptops there is a simple little access "hatch" underneath - I'll go see if I can find out...

IG

124 posts

Master Geek
+1 received by user: 1


  # 256159 16-Sep-2009 15:31

just to update, there *are* Atheros drivers listed for both Vista32 & 64-bit for that model - I guess the XP kernel just happily installed a generic driver if an Atheros card is fitted, whereas the Intel chipsets needed a non-kernel 3rd party driver - so looks like there was that optional configuration when new.

Still doesn't change the fact that if Proset was working before, it implies an Intel card...

1 | 2 
View this topic in a long page with up to 500 replies per page Create new topic



Twitter and LinkedIn »



Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

New Zealand government unveils new digital service to make business easier
Posted 16-Jul-2019 17:35


Scientists unveil image of quantum entanglement
Posted 13-Jul-2019 06:00


Hackers to be challenged at University of Waikato
Posted 12-Jul-2019 21:34


OPPO Reno Z now available in New Zealand
Posted 12-Jul-2019 21:28


Sony introduces WF-1000XM3 wireless headphones with noise cancellation
Posted 8-Jul-2019 16:56


Xero announces new smarter tools, push into the North American market
Posted 19-Jun-2019 17:20


New report by Unisys shows New Zealanders want action by social platform companies and police to monitor social media sites
Posted 19-Jun-2019 17:09


ASB adds Google Pay option to contactless payments
Posted 19-Jun-2019 17:05


New Zealand PC Market declines on the back of high channel inventory, IDC reports
Posted 18-Jun-2019 17:35


Air New Zealand uses drones to inspect aircraft
Posted 17-Jun-2019 15:39


TCL Electronics launches its first-ever 8K TV
Posted 17-Jun-2019 15:18


E-scooter share scheme launches in Wellington
Posted 17-Jun-2019 12:34


Anyone can broadcast with Kordia Pop Up TV
Posted 13-Jun-2019 10:51


Volvo and Uber present production vehicle ready for self-driving
Posted 13-Jun-2019 10:47


100,000 customers connected to fibre broadband network through Enable
Posted 13-Jun-2019 10:35



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.


Support Geekzone »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.