Hello,

and thank you in advance for any answers.

I have a funny problem with my Billionton Bluetooth USB dongle. Here's my situation:

When SP2 came, I installed it (after a few weeks' meditation) and was overjoyed by the fact that it has built-in bluetooth drivers to simplify issues. Well, I got just fine with Windows' drivers and went along with them for a while. However, for some reason every time I booted windows, I had to take out the dongle and replug it in. Each time Windows started up it claimed that it had found a new USB device and wanted to install it. This happens every time. The only thing I can do is take out the dongle and replug it and everything works as usual.

Well, I got really frustrated with this routine since the dongle is behind the computer and quite a reach from where my lazy butt is sitting. I decided thus to install Widcomm's drivers and Billionton's own software to go along. I followed the various instructions on how to bypass Windows' attempts to thwart the software with its own drivers and managed to get the Billionton bluetooth symbol all shiny and white.

The problem arose when I tried to hook up the serial connection (which is the one property I need the most). For some reason as soon as I replaced the "Generic USB radio" or whatnot with Billionton's driver all COM ports disappeared and all indications whatsoever to serial ports. So now I can't connect the serial port because no com ports exist for the connection. I am unable to create new ports via the software's own settings, nor am I able to modify any com port settings, since either all the com port fields (in my bluetooth places' settings) are blank or just show Com 0, which is just as good as blank.

Any ideas what might be wrong? As soon as I uninstall Billionton's software and revert back to Windows' drivers everything works OK, but I have to do that annoying chore of plug-out/plug-in again, which I'd rather avoid.

Also, if anyone has any insight as to WHY Windows won't accept the fact that the USB device has been already installed on Windows start-up I'd be happy to hear it. If I could get that aspect corrected I wouldn't have to mind Billionton's software.

Thank you,

Simo Ahava