Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




3301 posts

Uber Geek
+1 received by user: 627


Topic # 74852 8-Jan-2011 23:52
Send private message

I've had a network setup at my home now that has worked (for the most part) for the last two years. Basically, I have a desktop machine, which is where all my files are stored, and I can access it remotely from any computer connected over the network, either wired or wirelessly. The desktop is connected to my RTA1025W by ethernet cable, all other machines connect to it via wireless.

I've had port forwarding setup, allowing me to connect to the desktop remotely via TightVNC, thereby allowing me to control it from elsewhere. To do this, I assigned each machine on the network an internal IP address, and the port forwarding has worked fine. Only issue is when the laptops are taken elsewhere, they have issues connecting wirelessly, as they are always trying to get the LAN specified in the network settings in Windows.

I mentioned this issue to a colleague last week, who suggested instead of modifying the network settings on each machine, I set it up so that the MAC address is assigned the internal IP instead. I did this and bingo, it all works really well.

Only issue is tonight, when I try to connect to my desktop using TightVNC as I have done previously (and has been fine for over two years) now it refuses to connect. Apart from entering in the IP address/MAC address for each machine on my network, I didn't change any port forwarding rules. I deleted them and left the space empty, but that didn't work either. I'm sure it has to do with specifying the internal IP in the router instead of on the machine, but is there some way I can set up the router to allow a connection remotely using TightVNC?

Sorry for the novel, it's a pretty complex situation and I thought I should explain it all. If I've missed anything out or something doesn't make sense please say so.

Any assistance gratefully accepted.

Create new topic


3301 posts

Uber Geek
+1 received by user: 627


  Reply # 425346 9-Jan-2011 00:01
Send private message

Forgot to add:

* I'm using no-ip and forwarding to internal IP 192.168.1.9:5800
* This doesn't work externally from the network either (I just tested it from another connection)
* I have been to http://portforward.com/help/portcheck.htm and downloaded the tool and it says port 5800 is not open

My port forwarding rules look like this:

Application Name External Packet Internal Host
IP Address Protocol Port IP Address Port

Network ALL TCP 5800 192.168.1.9 5800

I've also turned off ZoneAlarm to see if this would make any difference (this had been configured previously and had been working with the setup too) but it didn't change anything.

If worst comes to worst, I can re-enter the IP addresses individually onto each machine again...but I'd prefer not to, if I can help it.

73 posts

Master Geek
+1 received by user: 1


  Reply # 425349 9-Jan-2011 00:15
Send private message

Im not really familiar with that modem, but can it do Address Reservation and assign static ips over dhcp?  That would be a more elegant solution, or is that what you just described with manually entering ips and mac addresses?

Other thing to check is that Isp is not blocking those ports.  You should at least see the port is open when doing a port scan, try http://www.grc.com/x/ne.dll?bh0bkyd2 (shields up) and do a scan from inside your network.

If you are getting port is stealth, then it is not making it through your router.

If you are getting port is closed then its getting forwarded from your router but the service may not be running on the destination machine.

edit :  windows firewall off too?


 
 
 
 




3301 posts

Uber Geek
+1 received by user: 627


  Reply # 425351 9-Jan-2011 00:31
Send private message

Yes, it appears it can. The router has a "Reserved IP Address List", which is where I entered all the MAC addresses and assigned the IP's accordingly - and since then is where I've come unstuck.

It won't be the ISP or firewall settings, as both of those things were not changed, and this all worked perfectly before I entered in the IP addresses directly on the router, as opposed to doing it manually on each machine :(

73 posts

Master Geek
+1 received by user: 1


  Reply # 425352 9-Jan-2011 00:34
Send private message

Have you tried rebooting the router?

And are all machines set to get ip address automatically from dhcp.



3301 posts

Uber Geek
+1 received by user: 627


  Reply # 425353 9-Jan-2011 00:39
Send private message

Yes, done that a few times, and no, the machines have their IP addresses specified in the router, otherwise I can't access the desktop machine remotely - using no-ip it forwards to my external IP (I don't have a static) and from there it forwards to the machine on the network, which means it needs the same internal IP.

73 posts

Master Geek
+1 received by user: 1


  Reply # 425355 9-Jan-2011 00:46
Send private message

I have a similar setup, with dyndns, except router assigns pc fixed address over dhcp.
I think you might be having connectivity issues, can you connect to your desktop from inside your network.


Also the reserved IPs need to be in the range of the Start and End IP on router.



3301 posts

Uber Geek
+1 received by user: 627


  Reply # 425356 9-Jan-2011 00:48
Send private message

Yes that works fine.

I think I fixed the problem by simply specifying the IP address the desktop should have in Network settings on the Control Panel, on that machine only - all the others still get their information from the router. Seems to be working fine now.

Thanks for your help anyway :)

Create new topic



Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

Netatmo launches smart home products in New Zealand
Posted 20-Nov-2017 20:06


Huawei Mate 10: Punchy, long battery life, artificial intelligence
Posted 20-Nov-2017 16:30


Propel launch Disney Star Wars Laser Battle Drones
Posted 19-Nov-2017 21:26


UFB killer app: Speed
Posted 17-Nov-2017 17:01


The case for RSS — MacSparky
Posted 13-Nov-2017 14:35


WordPress and Indieweb: Take control of your online presence — 6:30 GridAKL Nov 30
Posted 11-Nov-2017 13:43


Chorus reveals technology upgrade for schools, students
Posted 10-Nov-2017 10:28


Vodafone says Internet of Things (IoT) crucial for digital transformation
Posted 10-Nov-2017 10:06


Police and Facebook launch AMBER Alerts system in NZ
Posted 9-Nov-2017 10:49


Amazon debuts Fire TV Stick Basic Edition in over 100 new countries
Posted 8-Nov-2017 05:34


Vodafone VoIP transition to start this month
Posted 7-Nov-2017 12:33


Spark enhances IoT network capability
Posted 7-Nov-2017 11:33


Vocus NZ sale and broadband competition
Posted 6-Nov-2017 14:36


Hawaiki reaches key milestone in landmark deep-sea fibre project
Posted 4-Nov-2017 13:53


Countdown launches new proximity online shopping app
Posted 4-Nov-2017 13:50



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.