Geekzone: technology news, blogs, forums
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.

1574 posts

Uber Geek
+1 received by user: 11

Topic # 74925 10-Jan-2011 22:22
Send private message

Hey Guys and Gals,

I have been trying to help a friend set up their mac book to connect to the WiFi off a new Telecom Thompson TG585v7 Wireless gateway.

We have entered the password correctly, but it just keeps saying 'Invalid Password'.
A quick google search has said that deleting the System.keychain file from the /Library/Keychains/ directory will solve it.
I have tried this, but it is still saying invalid password.

Other google solutions have been to change the Wifi channel on the router to change to a less crowded channel.
I have had limited success with this. A change of channel initially allows the mac to connect, but after a few seconds it just drops the connection again. And then when we try to manually connect with the correct password, it just says the same thing... 'invalid password'.

We have a Sony Vaio (Windows 7) laptop connecting to the same Telecom wireless gateway with an absolutely rock solid connection.

Has anyone come across this problem before?
Does anyone have any solutions?

Any help would be greatly appreciated. Smile

Create new topic
29 posts



  Reply # 425938 10-Jan-2011 22:36
Send private message

What wireless security is the Thomson router running? WEP?
Switching to WPA may help.

Worked for me, YMMV. :)

1574 posts

Uber Geek
+1 received by user: 11

  Reply # 425942 10-Jan-2011 22:40
Send private message

Quoban: What wireless security is the Thomson router running? WEP?
Switching to WPA may help.

Worked for me, YMMV. :)

Sorry, I should have mentioned that in the original post.
It is set on WPA + WPA2 security mode.
I have tried it on WPA2 mode only, but still to no avail.

I may try it on WEP as a last resort, but really not keen on sending data freely into the atmosphere ;)

Thanks for your suggestion though. Very much appreciated. :)


1574 posts

Uber Geek
+1 received by user: 11

  Reply # 426296 11-Jan-2011 20:45
Send private message



Any suggestions would be really helpful.

Cheers :)

26 posts


  Reply # 426952 13-Jan-2011 21:21
Send private message

I'm having the same issue. Keep hitting return and eventually the Thompson will accept the password.

Seems these Thompson modems are just crap.

See this thread:

1574 posts

Uber Geek
+1 received by user: 11

  Reply # 426977 13-Jan-2011 23:32
Send private message

Thanks for your reply.
I think you may be right there.

After reading through a few of the Telecom Thompson 585 related threads, it seems that they are just a bit on the flakey side.

One thing that is becoming ever more apparent is that you usually get what you pay for.
I should have known.

I might try forcing it to use G mode instead of multi-mode B/G/N to see if that helps. It looks like some people have had some success doing that.

Again, thanks for your reply. Laughing

26 posts


  Reply # 427006 14-Jan-2011 08:04
Send private message

Let us know if you do find a solution, I imagine this will be a common issue considering the number of MacBooks around these days.

Create new topic

Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:

Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:

Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:

News »

Netatmo launches smart home products in New Zealand
Posted 20-Nov-2017 20:06

Huawei Mate 10: Punchy, long battery life, artificial intelligence
Posted 20-Nov-2017 16:30

Propel launch Disney Star Wars Laser Battle Drones
Posted 19-Nov-2017 21:26

UFB killer app: Speed
Posted 17-Nov-2017 17:01

The case for RSS — MacSparky
Posted 13-Nov-2017 14:35

WordPress and Indieweb: Take control of your online presence — 6:30 GridAKL Nov 30
Posted 11-Nov-2017 13:43

Chorus reveals technology upgrade for schools, students
Posted 10-Nov-2017 10:28

Vodafone says Internet of Things (IoT) crucial for digital transformation
Posted 10-Nov-2017 10:06

Police and Facebook launch AMBER Alerts system in NZ
Posted 9-Nov-2017 10:49

Amazon debuts Fire TV Stick Basic Edition in over 100 new countries
Posted 8-Nov-2017 05:34

Vodafone VoIP transition to start this month
Posted 7-Nov-2017 12:33

Spark enhances IoT network capability
Posted 7-Nov-2017 11:33

Vocus NZ sale and broadband competition
Posted 6-Nov-2017 14:36

Hawaiki reaches key milestone in landmark deep-sea fibre project
Posted 4-Nov-2017 13:53

Countdown launches new proximity online shopping app
Posted 4-Nov-2017 13:50

Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.

Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.