Geekzone: technology news, blogs, forums
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.

3 posts

Wannabe Geek

Topic # 82999 8-May-2011 14:46
Send private message

Network setup as per picture below:

The DLink wireless router had DHCP and UPnP turned off so it was only acting as wireless access point/switch.

Everything was working fine up until last night, while I wasn't home my brother plugged a network device into the WAN of the DLink wireless router. The internet then stopped working and all devices attached to the Wireless switch showed the network error "Limited network Access"

So far I have done a factory reset on the Dlink and tried setting up as it was before by:
-Turning off DHCP
-Turning off UPnP
-Setting the IP of the DLink to (After the reset the ip is The DHCP range of the Vodafone router/modem is

However when i plug the vodafone router/modem back into the DLink and try to repair the network of one of the PC's attached to the DLink, it fails and shows a message that there is no connectivity in the network.

So i opened up the CMD and ran arp -a and it showed that (which is the ip of the vodafone router) is invalid.

What is wrong with the switch? how do i get it to work again?

Note: The router are at opposite ends of the house (About 30m) and I had the DLink before I got the Vodafone Modem/Router so that's why I have this set-up

Create new topic
148 posts

Master Geek

  Reply # 466827 8-May-2011 17:44
Send private message

What are the other settings of the dlink? Subnet Mask? Default Gateway?

When I used a second switch to extend my total available ports from 4 to 6, I had to specify the gateway as the ip of the dhcp device.

3 posts

Wannabe Geek

Reply # 466832 8-May-2011 17:54
Send private message

Subnet mask is the same as the Vodafone router There is no option to change the default gateway. I had another spare router (not wireless) and I set it up in the same way I set up the DLink and it is working fine. I think that the DLink may be broken.


148 posts

Master Geek

  Reply # 466845 8-May-2011 18:18
Send private message

This sort of action shouldn't break it. I haven't had any routers fall over like that though.

Does the dlink work as a switch to the other items connected to it if you enable dhcp and disconnect from the vodafone?

Does the dlink work as a modem on its own?

Is there a bridging setting on either of them?

3 posts

Wannabe Geek

  Reply # 466851 8-May-2011 18:26
Send private message

The DLink isn't a modem/router its just a wireless router. I don't know whether my brother would be tell the truth about what exactly happened. I have a manual which explains how to set up the DLink for switching and I have followed it exactly but it doesn't work.

148 posts

Master Geek

  Reply # 466858 8-May-2011 18:55
Send private message

If i put myself in your position, I have a few more questions that I would ask.

For example, what is a WAN port doing on a device that isn't a modem? I thought that was the connection to the WAN?

Has the device been rebooted since you set the dhcp to off and set the static ip?

Can you check if you set a static ip on the vodafone device for the dlink one previously?

There may be more questions depending on any answers you want to give.

3121 posts

Uber Geek
+1 received by user: 541


  Reply # 466874 8-May-2011 19:30
Send private message

By making the Dlink a plain access point, it doesnt matter what ip / subnet / gateway you program it, as long as it is outside the DHCP range of the VF modem/router.

You have probably thought of this but

Next, because computers are not using the dlink to connect to the internet, you dont plug anything into the dlink's WAN port. The vodafone router is connected to the dlink, via the dlink's LAN port 1,2,3, or 4.

Ray Taylor
Taylor Broadband (rural hawkes bay)

There is no place like localhost
For my general guide to extending your wireless network Click Here

334 posts

Ultimate Geek
+1 received by user: 43

  Reply # 467393 10-May-2011 08:42
Send private message

Did you try shutting everything down on your in computers, router and switch. And by shutting down I mean everything off at the same time. Then turn/plug power back to the router...then switch and then bring the computer system or any other devices online.

If everything was working fine before, you shouldn't have to mess with things, powering down then back up should bring things online. that things have been tinkered with, it is hard to say.

4216 posts

Uber Geek
+1 received by user: 943


  Reply # 467395 10-May-2011 08:48
Send private message

Is the cable between the two units OK? It looks like the Vodafone Unit is not talking to the Dlink, because when the Dlink is acting as a switch (ie, routing off), then everything connected to it will get their network addresses via the DHCP from the Vodafone unit.

Are the correct lights on both units for the cable that runs between them - ie light 4 on the vodafone and light 1 on the Dlink?

4216 posts

Uber Geek
+1 received by user: 943


  Reply # 467402 10-May-2011 09:16
Send private message

Just had another thought - a good way of testing that cable would be to plug it directly into a PC/Laptop (so go from VF router to PC, bypassing Dlink). If you get net access that way, it tells you that the VF unit and the cable are working OK and the problem is the Dlink.

1977 posts

Uber Geek
+1 received by user: 130


  Reply # 468059 11-May-2011 21:10
Send private message

trig42: Just had another thought - a good way of testing that cable would be to plug it directly into a PC/Laptop (so go from VF router to PC, bypassing Dlink). If you get net access that way, it tells you that the VF unit and the cable are working OK and the problem is the Dlink.

But then it could be a crossover cable... Is the same cable connected to the modem as you had before? Tried all of the ports on both routers in case port was damaged? Do any cables/computers work if connected to the modem?

If you really want to use the WAN port to make it a wireless router, you could setup half-bridge mode on the modem too.

Qualified in business, certified in fibre, stuck in copper, have to keep going  ^_^

Create new topic

Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:

Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:

Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:

News »

Windows no longer Microsoft’s main focus
Posted 13-Mar-2018 07:47

Why phone makers are obsessed with cameras
Posted 11-Mar-2018 12:25

New Zealand Adopts International Open Data Charter
Posted 3-Mar-2018 12:48

Shipments tumble as NZ phone upgrades slow
Posted 2-Mar-2018 11:48

Oppo R11s: high-end Android, budget price
Posted 27-Feb-2018 16:27

Samsung New Zealand introducing the Galaxy S9 and S9+
Posted 26-Feb-2018 07:00

Fujifilm X beats its best with new top of the range, high-performance camera
Posted 24-Feb-2018 14:05

One million kiwis affected by cybercrime
Posted 24-Feb-2018 13:58

New Zealanders want to engage with government online and via mobile apps
Posted 24-Feb-2018 13:56

Samsung launches Samsung Max
Posted 24-Feb-2018 13:52

CPTPP text and National Interest Analysis released for public scrutiny
Posted 21-Feb-2018 19:43

Foodstuffs to trial digitised shopping trolleys
Posted 21-Feb-2018 18:27

2018: The year of zero-login, smart cars & the biometrics of things
Posted 21-Feb-2018 18:25

Intel reimagines data centre storage with new 3D NAND SSDs
Posted 16-Feb-2018 15:21

Ground-breaking business programme begins in Hamilton
Posted 16-Feb-2018 10:18

Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.

Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.