Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.


90 posts

Master Geek


Topic # 9087 19-Aug-2006 02:59
Send private message

I was hoping for a bit of advice for stting up my pc so I could access my files from work.

Having read a fair bit about it, I am confident that I have set everthing up correctly, but when I try to access the ftp site, all I get is the DSL modem/router configuration page.  (DL-504G)

I have done some experimenting, and it appears that the port forwarding is not working, or that port 21 is blocked by something else.  (www.canyouseeme.org times out if I ask it to check port 21)

I believe that I have set the forwarding up correctly: used ipconfig to find out my local pc IP address, then set this as the private IP with private and public port set to 21, allowing all protocols.

I assume that everthing else I have done has worked, but I suppose that I can't really tell until the router decides to, well, route me, I guess...

Have also tried disabling all firewalls and putting my pc IP address into a DMZ (briefly!) but to no avail.  This suggests to me that it may not be the port forwarding, but as a newcomer to all this I am not sure.

Any thoughts appreciated.

Using Win Xp Pro; D-Link DL 504G.

Cheers, Jase.





Create new topic
BDFL - Memuneh
61001 posts

Uber Geek
+1 received by user: 11841

Administrator
Trusted
Geekzone
Lifetime subscriber

Reply # 44298 19-Aug-2006 09:00
Send private message

First thing is to see if the FTP server is working ok. On your PC, open the command prompt and try logging into your own server by using "ftp localhost". If all is ok you should be ask for username and password.

Then make sure your software firewall on your PC allows FTP connections. This will be either Windows Firewall, or Zone Alarm, or Norton Internet Security. Make sure you only have one of these too - never run more than one firewall software. If you have ZA or NIS, be sure to disable the Windows firewall software.

Configure your FTP server to not allow anonymous logins! This is very important, otherwise people will be able to read/write.

Do you have a static IP address? When accessing from outside your network you need to use either a static IP address or a dynamic DNS service. These services are good even for static IP because you can give your machine an easy to remember name. If your IP is dynamic, there are programs that will update the address on the server when it changes.

Also, when accessing your server, from within your own network (not from external) it's normal to reach a router page - the routers get confused with the external IP address being referenced as being themselves and won't redirect the ports. It happens on my Belkin. It just means that you have to test from outside - but you say an external test failed. I'd check the software firewalls for that.


Also, which ISP are you using? Some ISPs block standard ports. TelstraClear does not block, but Xtra might - I am sure they do block port 25 (smtp) for example.









90 posts

Master Geek


  Reply # 44307 19-Aug-2006 10:39
Send private message

Thanks freitasm.

Failed on the first count: Command "ftp localhost" returns "Connected to josan" followed immediately by "Connection closed by remote host". 

Everything else in your post I have taken care of, and works fine.  I will try to raise the dead at xtra and find out if they block ports, but I don't think this is the answer, based on the first line.

As I said, I went as far as disabling NIS and DMZing my PCs IP address briefly to see if that worked.

I followed

http://www.pcstats.com/articleview.cfm?articleID=1491

to set up ftp on Xp, and everything installed smoothly.

Your advice about anonymous logins conflicts with what I have read about the passwords not being encypted - from what I have read it is best to force anonymous logins and only grant read access.  Your thoughts on this?

I will have a play with the ftp settings and see if I can get the localhost to work, but am shooting a bit blindly.

Cheers for the tips.

BDFL - Memuneh
61001 posts

Uber Geek
+1 received by user: 11841

Administrator
Trusted
Geekzone
Lifetime subscriber

Reply # 44308 19-Aug-2006 10:44
Send private message

When you do "ftp localhost" you should not receive "Connection closed by remote host", since you are on the same host. In this case, it should simply ask for your credentials. It points to something wrong on your configuration. You should sort this out before going to xTra.

I always disable anonymous logins, unless you don't mind everyone being able to read your files? Passwords are not encrypted, but you can rotate these now and then...







90 posts

Master Geek


  Reply # 44909 29-Aug-2006 12:49
Send private message

Thanks again.  

If I ftp to my local IP address, it asks for my user name/password and connects happily.  I have yet to try from a pc external to my own.

If I try "ftp localhost" I still get the disconnection message as before.  I have attempted to find what the difference between doing these 2 processes is with no luck

I see your point about anonymous logins...

Create new topic

Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

Targus set sights on enterprise and consumer growth in New Zealand
Posted 13-Aug-2018 13:47


Huawei to distribute nova 3i in New Zealand
Posted 9-Aug-2018 16:23


Home robot Vector to be available in New Zealand stores
Posted 9-Aug-2018 14:47


Panasonic announces new 2018 OLED TV line up
Posted 7-Aug-2018 16:38


Kordia completes first live 4K TV broadcast
Posted 1-Aug-2018 13:00


Schools get safer and smarter internet with Managed Network Upgrade
Posted 30-Jul-2018 20:01


DNC wants a safer .nz in the coming year
Posted 26-Jul-2018 16:08


Auldhouse becomes an AWS Authorised Training Delivery Partner in New Zealand
Posted 26-Jul-2018 15:55


Rakuten Kobo launches Kobo Clara HD entry level reader
Posted 26-Jul-2018 15:44


Kiwi team reaches semi-finals at the Microsoft Imagine Cup
Posted 26-Jul-2018 15:38


KidsCan App to Help Kiwi Children in Need
Posted 26-Jul-2018 15:32


FUJIFILM announces new high-performance lenses
Posted 24-Jul-2018 14:57


New FUJIFILM XF10 introduces square mode for Instagram sharing
Posted 24-Jul-2018 14:44


OPPO brings advanced technology to the smartphone market with new device
Posted 24-Jul-2018 09:20


Hawaiki Transpacific cable ready-for-service
Posted 20-Jul-2018 11:29



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.