Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




4 posts

Wannabe Geek


# 14987 30-Jul-2007 04:52
Send private message

I just bought an iriver clix, followed the setup instructions but it seems to have skipped the step where it goes through device setup with my computer. The USB just says Unknown Device. Anyone know how I can introduce them to each other? Thanks!

Create new topic
BDFL - Memuneh
64866 posts

Uber Geek

Administrator
Trusted
Geekzone
Lifetime subscriber

# 80300 30-Jul-2007 08:51
Send private message

On your CD there should be a folder with drivers. When you plug the device you would have the option to point to where to find the drivers.

If not, uninstall the software, reboot, install again, reboot and then plug the device.







4 posts

Wannabe Geek


  # 80308 30-Jul-2007 09:33
Send private message

Thank you for replying. From what I can tell from their website, all the drivers are on the clix...but my computer can't see them because it doesn't recognize the device. The CD that came with it seems to only have Media Player 11. I'll try to remove that and start over...see if it doesn't clue my computer in. Thanks!

 
 
 
 




4 posts

Wannabe Geek


# 80742 1-Aug-2007 14:59
Send private message

No luck!

I reinstalled and it still doesn't have a clue. I verified that the drivers are supposed to be on the clix but I can't tell my computer to go get them...if anyone has other suggestions I would appreciate it. I'm about to toss the clix and my computer out the window.

Thank you!

93 posts

Master Geek
Inactive user


  # 80757 1-Aug-2007 17:23
Send private message

Have you tried looking for the drivers on the iRiver website? Did the uninstall - reinstall not work?

1874 posts

Uber Geek

Trusted

  # 83446 23-Aug-2007 09:19
Send private message

Im a computer tech and run into the "unknowen device - error 10" problem all the time. Theres a possibility that it could be your usb port, can you plug other devices into that port without a problem? Id try a different port anyway.

Failing that, uninstall the driver. Remove the device from device manager (control panel-system-hardware-device manager).
Then run a couple of system cleaners, the first being ccleaner (http://www.ccleaner.com/download) and a good registry cleaner, i highly recommend to everyone regvac (www.regvac.com). Run both of these programs then reboot. Do not insert the device yet!! Install the  latest version of the driver from the webiste then insert the device when it prompts you to. Hopefully that solves the problem. IF not then you may have to drop it into a tech to have a look at, almost certainly a clean install of windows will fix the problem, but its a bit of overkill Laughing





4 posts

Wannabe Geek


  # 83461 23-Aug-2007 10:49
Send private message

Thanks for taking the time to reply. I actually ordered a second clix and had the same problem so I think my computer just doesn't like them...I returned both, ordered a Creative Zen and it worked right out of the box!

Create new topic



Twitter and LinkedIn »



Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

Microsoft Translator understands te reo Māori
Posted 22-Nov-2019 08:46


Chorus to launch Hyperfibre service
Posted 18-Nov-2019 15:00


Microsoft launches first Experience Center worldwide for Asia Pacific in Singapore
Posted 13-Nov-2019 13:08


Disney+ comes to LG Smart TVs
Posted 13-Nov-2019 12:55


Spark launches new wireless broadband "Unplan Metro"
Posted 11-Nov-2019 08:19


Malwarebytes overhauls flagship product with new UI, faster engine and lighter footprint
Posted 6-Nov-2019 11:48


CarbonClick launches into Digital Marketplaces
Posted 6-Nov-2019 11:42


Kordia offers Microsoft Azure Peering Service
Posted 6-Nov-2019 11:41


Spark 5G live on Auckland Harbour for Emirates Team New Zealand
Posted 4-Nov-2019 17:30


BNZ and Vodafone partner to boost NZ Tech for SME
Posted 31-Oct-2019 17:14


Nokia 7.2 available in New Zealand
Posted 31-Oct-2019 16:24


2talk launches Microsoft Teams Direct Routing product
Posted 29-Oct-2019 10:35


New Breast Cancer Foundation app puts power in Kiwi women's hands
Posted 25-Oct-2019 16:13


OPPO Reno2 Series lands, alongside hybrid noise-cancelling Wireless Headphones
Posted 24-Oct-2019 15:32


Waikato Data Scientists awarded $13 million from the Government
Posted 24-Oct-2019 15:27



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.


Support Geekzone »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.