Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




775 posts

Ultimate Geek
+1 received by user: 103


Topic # 130839 30-Sep-2013 09:33
Send private message

We are visiting the states. We want to set up an iPhone 4S (ios7, nz telecom prepay) so that it can make and receive calls and texts, but NOT use any data, except on wifi.

I've had a quick google but standing in the airport after a long flight is not conducive to careful research!

I have "mobile" set to OFF and it has received a text from telecom saying we are roaming. Carrier has gone automatically to AT&T.

What do I need to do? If anything?

Thanks for the help.




HTPC: Antec NSK2480B case, AMD A4-5300 CPU, Asus F2A85-M LE mobo, WD Caviar Green 64Mb 2TB HDD, HD Homerun, Win7 Home Premium, RAM 1600Mhz 4Gb.
iPad air 2


Create new topic
Banana?
4573 posts

Uber Geek
+1 received by user: 1119

Subscriber

  Reply # 904905 30-Sep-2013 09:42
Send private message

Just turn off Mobile Data. This will stop iMessage working, but that shouldn't be an issue for you (texts will still go).

There is a switch in the settings to turn off Data Roaming, which should be enough, but to be sure, just switch off mobile data.



775 posts

Ultimate Geek
+1 received by user: 103


  Reply # 905465 1-Oct-2013 05:04
Send private message

The Data Roaming switch has gone from ios7, which is a shame.




HTPC: Antec NSK2480B case, AMD A4-5300 CPU, Asus F2A85-M LE mobo, WD Caviar Green 64Mb 2TB HDD, HD Homerun, Win7 Home Premium, RAM 1600Mhz 4Gb.
iPad air 2


 
 
 
 


2358 posts

Uber Geek
+1 received by user: 378

Trusted

  Reply # 905469 1-Oct-2013 07:20
Send private message

Data Roaming switch is still there on iOS7 . Under Settings... Cellular and Turn off Data Roaming.


Banana?
4573 posts

Uber Geek
+1 received by user: 1119

Subscriber

  Reply # 905516 1-Oct-2013 08:54
Send private message

Yep, it's there on mine too.



775 posts

Ultimate Geek
+1 received by user: 103


  Reply # 905758 1-Oct-2013 15:31
Send private message

?strange?

I have settings, then a list of

Airplane Mode
Wi-Fi
Bluetooth
Mobile
Personal hotspot
Carrier

Under Mobile I have

Mobile Data (switch)
Enable 3G (switch)
Mobile Data Network

Is here something I'm missing?




HTPC: Antec NSK2480B case, AMD A4-5300 CPU, Asus F2A85-M LE mobo, WD Caviar Green 64Mb 2TB HDD, HD Homerun, Win7 Home Premium, RAM 1600Mhz 4Gb.
iPad air 2


3062 posts

Uber Geek
+1 received by user: 484

Trusted
Subscriber

  Reply # 908395 5-Oct-2013 12:10
Send private message

The data roaming switch disappears if you disable mobile data. Did you perchance disable mobile data prior to trying to disable mobile data roaming?

Create new topic



Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.


Support Geekzone »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.