Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




71 posts

Master Geek


# 174973 12-Jun-2015 15:33
Send private message

I'm trying to use a personal hotspot for the first time to use iPhone 3G/4g data on my iMac. Once enabled on the phone the hotspot shows up easily on the iMac and appears to connect fine. However when connected I have no internet connection whatsoever.

I've tried this via USB and wifi. Both connect but neither work. I've tried resetting iPhone network settings. I've tried renaming the phone. I've tried resetting hotspot wifi password. I've tried deleting and recreating the iPhone USB network option. I've tried restarting both devices many times. I've tried every little solution I can find on the Internet and still no luck. Always appears to connect to hotspot but never any internet connection.

Data works fine on the phone. The hotspot also works when I use it with my iPad. It just won't work on the iMac.

Phone is iPhone6 iOS8. IMac is Yosemite.

Filter this topic showing only the reply marked as answer View this topic in a long page with up to 500 replies per page Create new topic
 1 | 2
5453 posts

Uber Geek
+1 received by user: 1904


  # 1323473 12-Jun-2015 15:47
Send private message

What does the network system pref on the iMac say for the connection?



71 posts

Master Geek


  # 1323483 12-Jun-2015 15:51
Send private message

It says it's connected.

 
 
 
 


5453 posts

Uber Geek
+1 received by user: 1904


  # 1323492 12-Jun-2015 15:56
Send private message

Is it the only connected network interface? Can you ping the phone?



71 posts

Master Geek


  # 1323509 12-Jun-2015 16:07
Send private message

It was not the only connection. I had a dud Ethernet connection that was connected but not actually functioning because orcon is lame again. I disconnected the Ethernet and now it works! So simple I can't believe I wasted hours on this.

5453 posts

Uber Geek
+1 received by user: 1904


  # 1323536 12-Jun-2015 16:31
One person supports this post
Send private message

In the network prefs, set the service order under the cog icon. If you have multiple active network interfaces, you need to configure this correctly.

Any inactive interface will automatically be moved to a lower priority than an active one (hence why it works when you unplug the ethernet), but it you want to automatiically swith to iPhone tether when connected, just change the service order.

19 posts

Geek
Inactive user


  # 1353661 28-Jul-2015 18:56
Send private message

It can be a security issue... are you using WAP or WEP

I iz your trusted friend
5833 posts

Uber Geek
+1 received by user: 147

Mod Emeritus
Trusted
Lifetime subscriber

  # 1353701 28-Jul-2015 19:21
Send private message

If you paired your iPhone to your iMac over Bluetooth, then you should be able to initiate hotspot connection by picking the iPhone from the WiFi icon. The hotspot icon is a chain link.

Failing that, you can enable Personal Hotspot on the iPhone and just plainly connect with Lightning cable to the USB port and it will automatically use iPhone for data connection.

http://www.macrumors.com/2014/10/23/how-to-instant-hotspot/




Internet is my backyard...

 

«Geekzone blog: Tech 'n Chips Takeaway» «Personal blog: And then...»

 

Please read the Geekzone's FUG

 


 
 
 
 


5453 posts

Uber Geek
+1 received by user: 1904


  # 1353708 28-Jul-2015 19:30
Send private message

sahilchraya: It can be a security issue... are you using WAP or WEP


It doesn't use either. WPA2 is used.

https://support.apple.com/en-nz/HT201926

16605 posts

Uber Geek
+1 received by user: 3273

Trusted

  # 1353729 28-Jul-2015 19:47
Send private message

I tried, and failed as per OP
rMBP late 2013 Yosemite 10.4
iPhone 6 Plus iOS8.4
iPad Air iOS8.4

Connected on the Mac, Option-Wifi shows the connection details, but Internet Unreachable
iPad connects and works well.

Service Order I put wifi at the top of the two BT and the Thunderbolt
AP order I put the hotspot at the top of the two wifi's, the Airport Extreme 2.4 and 5

Hmmm


5453 posts

Uber Geek
+1 received by user: 1904


  # 1353790 28-Jul-2015 20:40
Send private message

Is the phone regonsing the hotspot being connected?

16605 posts

Uber Geek
+1 received by user: 3273

Trusted

  # 1353796 28-Jul-2015 20:49
Send private message

RunningMan: Is the phone regonsing the hotspot being connected?


Yep. MR suggests logging out of iCloud then back in, then I have to answer all these "Do you want to delete this stuff from he Mac if you turn off iCloud Drive" 
All systems are go, connects to the Instant Hotspot, everything is fine except Internet Unreachable in the Option-Wifi . Handoff, Continuity all work great, Instant Hotspot to the iPad works great. Apple, it almost always just works! I know they are going back to an older network protocol or function in El Capitan so maybe that will fix this issue, its not just me, going by the web. But my Transcend $20 32GB USB3 pen drive works great as! I like my Apple gear but given the limited hardware thats all in house, you'd think they;d do a bit better.

5453 posts

Uber Geek
+1 received by user: 1904


  # 1353810 28-Jul-2015 20:59
Send private message

Try creating a new location in Network, with just the single Wifi (hotspot) connection, verify that it works (should see router and DNS servers populated) and then work from there...

16605 posts

Uber Geek
+1 received by user: 3273

Trusted

  # 1353858 28-Jul-2015 21:46
Send private message

RunningMan: Try creating a new location in Network, with just the single Wifi (hotspot) connection, verify that it works (should see router and DNS servers populated) and then work from there...


That worked, cheers. Internet is reachable with the new Location. I will need to switch to the new location to get Reachable, why is that? The other wifi's also work on the new location. I set the service order to the same as the new location in the Automatic location, BT DUN  WIFI   BT PAN   Thunderbolt, but no change. BT DUN is now BT DUN 2 in the Automatic location's service order

16605 posts

Uber Geek
+1 received by user: 3273

Trusted

  # 1353869 28-Jul-2015 21:55
Send private message

Under the Automatic location my DNS is the 659b Router 192.168.1.254 while under the new location the DNS is the iPhone 172 address. It has its 172 IP address and its router 172 address. So, when its on the Auto location, the 659b is the DNS and no go, on the new location its the iPhones router address and it works. Sound sensible, but this should work out of the box for everyone?

2514 posts

Uber Geek
+1 received by user: 541
Inactive user


  # 1354031 29-Jul-2015 07:07
Send private message

tdgeek: I tried, and failed as per OP
rMBP late 2013 Yosemite 10.4
iPhone 6 Plus iOS8.4
iPad Air iOS8.4

Connected on the Mac, Option-Wifi shows the connection details, but Internet Unreachable
iPad connects and works well.

Service Order I put wifi at the top of the two BT and the Thunderbolt
AP order I put the hotspot at the top of the two wifi's, the Airport Extreme 2.4 and 5

Hmmm



I had this issue, I had to change the name of my iphone from Richard's Iphone to Richards Iphone.

This was connecting to Windows PC but worth a try.

 1 | 2
Filter this topic showing only the reply marked as answer View this topic in a long page with up to 500 replies per page Create new topic



Twitter and LinkedIn »



Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

Xero announces new smarter tools, push into the North American market
Posted 19-Jun-2019 17:20


New report by Unisys shows New Zealanders want action by social platform companies and police to monitor social media sites
Posted 19-Jun-2019 17:09


ASB adds Google Pay option to contactless payments
Posted 19-Jun-2019 17:05


New Zealand PC Market declines on the back of high channel inventory, IDC reports
Posted 18-Jun-2019 17:35


Air New Zealand uses drones to inspect aircraft
Posted 17-Jun-2019 15:39


TCL Electronics launches its first-ever 8K TV
Posted 17-Jun-2019 15:18


E-scooter share scheme launches in Wellington
Posted 17-Jun-2019 12:34


Anyone can broadcast with Kordia Pop Up TV
Posted 13-Jun-2019 10:51


Volvo and Uber present production vehicle ready for self-driving
Posted 13-Jun-2019 10:47


100,000 customers connected to fibre broadband network through Enable
Posted 13-Jun-2019 10:35


5G uptake even faster than expected
Posted 12-Jun-2019 10:01


Xbox showcases 60 anticipated games
Posted 10-Jun-2019 20:24


Trend Micro Turns Public Hotspots into Secure Networks with WiFi Protection for Mobile Devices
Posted 5-Jun-2019 13:24


Bold UK spinoff for beauty software company Flossie
Posted 2-Jun-2019 14:10


Amazon Introduces Echo Show 5
Posted 1-Jun-2019 15:32



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.


Support Geekzone »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.