Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.


6310 posts

Uber Geek
+1 received by user: 1080

Trusted
Lifetime subscriber

Topic # 204320 27-Sep-2016 11:11
Send private message

I'm posting this on behalf of a friend. He bought an iPhone 7 and ported his number from Vodafone to Skinny Direct. When he tries to send a text message to Canada, it comes up with "not delivered". Resetting network settings didn't help. Skinny hasn't been able to find anything wrong, and suggested that he try the SIM in a different phone.

 

We've just put his SIM into my iPhone 6, and sent a message to the same number, and it sent successfully. We've been through the settings and can't find any obvious differences.

 

Texts to NZ and Australia work fine. Does anyone know what could cause this sort of issue?


Filter this topic showing only the reply marked as answer Create new topic
2082 posts

Uber Geek
+1 received by user: 218

Trusted
Subscriber

  Reply # 1641423 27-Sep-2016 18:51
Send private message

Is he sure he's holding it right?

 

 

Sounds like a factory reset might be the next thing to try.




MacBook Pro 13" w/ Touch Bar (Early 2017) | iPad Pro 10.5 Wi-Fi 128GB (Space Grey) | iPhone 8 Plus 64GB (Product RED) | HomePod (Space Grey) | Apple TV 4K | Apple TV (4th Generation) | Apple Watch Series 3 42mm (Space Grey)

3687 posts

Uber Geek
+1 received by user: 2131

Trusted
Lifetime subscriber

  Reply # 1641431 27-Sep-2016 19:19
Send private message

When SIM is in the iPhone7 delete the contact and save it again using the correct international format +1xxxxxxxxx




Ex JohnR VodafoneNZ 17 years 4 days

3091 posts

Uber Geek
+1 received by user: 1561


  Reply # 1641443 27-Sep-2016 19:37
Send private message

Failing as an iMessage or SMS?  Turn off iMessage and try again perhaps?  Failing that as outlined I suspect it will be with the contact settings.  Delete the contact and try again making sure to use the correct international codes (or get the person in Canada to text first and then save those details in the contacts.  





Always be yourself, unless you can be Batman, then always be the Batman



4480 posts

Uber Geek
+1 received by user: 2476

Trusted

  Reply # 1641464 27-Sep-2016 20:42
One person supports this post
Send private message

It's aboot time they fixed that issue!




6310 posts

Uber Geek
+1 received by user: 1080

Trusted
Lifetime subscriber

  Reply # 1641478 27-Sep-2016 21:10
Send private message

The contact is already in +1 format and we already tried deleting and re-adding it. It's SMS, not iMessage. Hopefully it's not going to need a factory reset!

12025 posts

Uber Geek
+1 received by user: 3908

Trusted
Lifetime subscriber

  Reply # 1641492 27-Sep-2016 22:01
Send private message

Is it because no one in Canada has a mobile phone yet? surprised






Filter this topic showing only the reply marked as answer Create new topic

Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.