Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




8 posts

Wannabe Geek


Topic # 23933 11-Jul-2008 13:10
Send private message

Sorry not sure if this is the best topic to post this in. Just got my new iphone and trying to connect to the exchange server. Get an error:

Unable to verify Certificate
The certificate from mail.*.co.nz for account """" could not be verified.

I click Accept and it says verification failed. Belive the issue is a problem with the security certificate but not sure why it says """". Hoping someone might be able to help

View this topic in a long page with up to 500 replies per page Create new topic
 1 | 2
163 posts

Master Geek
+1 received by user: 5


  Reply # 146757 11-Jul-2008 13:52
Send private message

Maybe your SSL certificate for Exchange is self-signed (so it can't be validated), or it may have expired...



8 posts

Wannabe Geek


  Reply # 146761 11-Jul-2008 13:58
Send private message

Thanks very much for the help. Exchange is not something I have played around with too much especially the certificate side of things; our guy who does this side of things is away on leave for a while. Have checked in IIS under Exchange and the certificate shows it is issued to the mail server and until 2010. It is called an SSL certificate for OWA which I think sounds like what it should be.

I did read the following and wondered if this may be an issue? Not sure what the ActiveSync server name refers to?:

The iPhone might now warn you that it couldn’t validate your account.  This is because it couldn’t correctly pick out your exchange server name.  If this is the case, enter your server name in the window.  Make sure you enter your ActiveSync server name, not the OWA server (as in Entourage) or the real Exchange server (as in Outlook).

**Update**

Have been checking some more and found out the Active-Sync directory did not have ssl authentication turned on. Enabled it and the iphone said the account had been verified in the setup screen. But if I go to my inbox it can't find any messages and am unable to send ' An error occured when delivering this message'. It also occassionally pops up and says it can't verify the certificate

 
 
 
 


Professional yak shaver
1598 posts

Uber Geek
+1 received by user: 7

Trusted
BitSignal
Subscriber

  Reply # 146835 11-Jul-2008 15:33
Send private message

dmitchell: Thanks very much for the help. Exchange is not something I have played around with too much especially the certificate side of things; our guy who does this side of things is away on leave for a while. Have checked in IIS under Exchange and the certificate shows it is issued to the mail server and until 2010. It is called an SSL certificate for OWA which I think sounds like what it should be.

I did read the following and wondered if this may be an issue? Not sure what the ActiveSync server name refers to?:

The iPhone might now warn you that it couldn’t validate your account.  This is because it couldn’t correctly pick out your exchange server name.  If this is the case, enter your server name in the window.  Make sure you enter your ActiveSync server name, not the OWA server (as in Entourage) or the real Exchange server (as in Outlook).

**Update**

Have been checking some more and found out the Active-Sync directory did not have ssl authentication turned on. Enabled it and the iphone said the account had been verified in the setup screen. But if I go to my inbox it can't find any messages and am unable to send ' An error occured when delivering this message'. It also occassionally pops up and says it can't verify the certificate


It sounds like your Exchange server has a self-signed certificate. In that case, you might be out of luck. Try Googling for "iphone self-signed certificate exchange".

The other option is going to www.certificatesforexchange.com and just buying one. ;)

Saves a lot of hassle!




"Roads? Where we're going, we don't need roads." - Doc Emmet Brown



8 posts

Wannabe Geek


  Reply # 147037 12-Jul-2008 09:38
Send private message

Thanks for that. Managed to install the certificate on the iphone and got it working correctly. Only thing left now is to get my calendar to sync. It is syncing my personal calendar which I don't use since we just share a public calendar. Can't seem to find any way to change it. Be good if there was a way in exchange to tell it to use the public folder as default calendar

BDFL - Memuneh
58935 posts

Uber Geek
+1 received by user: 10300

Administrator
Trusted
Geekzone
Subscriber

Reply # 147041 12-Jul-2008 09:58
Send private message
4 posts

Wannabe Geek


  Reply # 148296 15-Jul-2008 21:05
Send private message

is there a cheap application/plugin that will automatically copy calendar from public folder to a personal pst file?

2 posts

Wannabe Geek


  Reply # 148414 16-Jul-2008 08:58
Send private message

If you have a self-signe certificate you can just get around the authorization error by saving your settings. Then go back into the configuration and turn off SSL. You should connect with no problem.
But I recommend going with a SSL cert you can a cheap one for around $30.00 USD

2 posts

Wannabe Geek


  Reply # 148416 16-Jul-2008 09:00
Send private message

Hi ader,
Have you tried just exporting your shared calendar .pst then importing into your personal one?

BDFL - Memuneh
58935 posts

Uber Geek
+1 received by user: 10300

Administrator
Trusted
Geekzone
Subscriber

Reply # 148419 16-Jul-2008 09:04
Send private message

Also note I just posted in another thread that Apple's implementation won't sync anything but "Inbox" - so if you have server side rules moving incoming e-mail to specific folders, you won't have those on your device.

Also it won't work for meeting requests.




40 posts

Geek


  Reply # 148480 16-Jul-2008 12:57

freitasm:
Also it won't work for meeting requests.


Just got one of my work mates to set up a meeting. The request arrived on the iphone, I accepted and he got a response back.

4 posts

Wannabe Geek


  Reply # 148602 16-Jul-2008 19:10
Send private message

Hi, I couldn't find how to copy manually from the public calendar to the personal one. I did see that you can copy to a personal folder but this creates a new calendar not update the default existing one. It would have meant the two calendars weren't synced. The cheapest option I have found is QSynchronisation a plugin that hopefully do what I require. Am testing it in the trial version. So far so good, it's copied the calendar, my iPhone has downloaded it and I've been able to accept and decline invitations fine... :)

Hawkes Bay
8477 posts

Uber Geek
+1 received by user: 4

Mod Emeritus
Trusted
Subscriber

  Reply # 148634 16-Jul-2008 20:44
Send private message

freitasm: Also it won't work for meeting requests.

Are you saying the iPhone cant respond properly to meeting requests?

*Crikey*




Visit http://www.thecloud.net.nz for New Zealand based Hosted Exchange, Virtual Servers, Web Hosting, FTP Backup & more.
(1GB free FTP storage, or larger plans from $5.75)
 
 - Setup your own mailserver at home on Ubuntu Server - full step by step howto here.
 - Have you seen this: Nathan "KFC4LIFE" Dunn.


40 posts

Geek


  Reply # 148878 17-Jul-2008 15:17

tonyhughes:
freitasm: Also it won't work for meeting requests.

Are you saying the iPhone cant respond properly to meeting requests?

*Crikey*


It responds and updates fine.
The issue is that you cant create a meeting and invite people from the iphone.

Hawkes Bay
8477 posts

Uber Geek
+1 received by user: 4

Mod Emeritus
Trusted
Subscriber

  Reply # 148883 17-Jul-2008 15:21
Send private message

CraigC:
tonyhughes:
freitasm: Also it won't work for meeting requests.

Are you saying the iPhone cant respond properly to meeting requests?

*Crikey*


It responds and updates fine.
The issue is that you cant create a meeting and invite people from the iphone.

Ahhh... thats not quite so bad...




Visit http://www.thecloud.net.nz for New Zealand based Hosted Exchange, Virtual Servers, Web Hosting, FTP Backup & more.
(1GB free FTP storage, or larger plans from $5.75)
 
 - Setup your own mailserver at home on Ubuntu Server - full step by step howto here.
 - Have you seen this: Nathan "KFC4LIFE" Dunn.


40 posts

Geek


  Reply # 149199 18-Jul-2008 16:19

Im having a couple of issues, one i know what the solution is but the other is a little annoyning.

If you running Exchange 2007 without SP1 attachments dont download. SP1 should fix this.
Second issue is that if im connected to our internal wireless network, push email stops working after a short period of time after a restart on the handset. Soon as i switch to 3G it starts working again.

Edit: Found out whats happening with my wireless issue. http://support.apple.com/kb/TS1868

 1 | 2
View this topic in a long page with up to 500 replies per page Create new topic



Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

Vodafone TV — television in the cloud
Posted 17-Oct-2017 19:29


Nokia 8 review: Classy midrange pure Android phone
Posted 16-Oct-2017 07:27


Why carriers might want to embrace Commerce Commission study, MVNOs
Posted 13-Oct-2017 09:42


Fitbit launches Ionic, its health and fitness smartwatch
Posted 12-Oct-2017 15:52


Xero launches machine learning automation to improve coding accuracy for small businesses
Posted 12-Oct-2017 15:45


Bank of New Zealand uses Intel AI to detect financial crime
Posted 12-Oct-2017 15:39


Sony launches Xperia XZ1, a smartphone with real-time 3D capture
Posted 11-Oct-2017 10:26


Notes on Nokia’s phone comeback
Posted 10-Oct-2017 10:06


Air New Zealand begins Inflight Wi-Fi rollout
Posted 9-Oct-2017 20:16


The latest mobile phones in perspective
Posted 9-Oct-2017 18:34


Review: Acronis True Image 2018 — serious backup
Posted 8-Oct-2017 11:22


Lenovo launches ThinkPad Anniversary Edition 25
Posted 7-Oct-2017 23:16


Less fone, more tech as Vodafone gets brand make-over
Posted 6-Oct-2017 08:16


API Talent Achieves AWS MSP Partner Status
Posted 5-Oct-2017 21:20


Stellar Consulting Group now a Domo Partner
Posted 5-Oct-2017 21:03



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.