Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




11 posts

Geek


Topic # 245187 23-Jan-2019 01:07
Send private message quote this post

Hi, I have recently discovered that some of my iCloud contacts have been missing off all of my Idevices signed into my Apple ID. I have checked apple support website and I have followed that troubleshooting guide (disable/enable, all groups etc) and was wondering if anybody has had the same problem and has been able to fix it.

Harry

View this topic in a long page with up to 500 replies per page Create new topic
 1 | 2
1433 posts

Uber Geek
+1 received by user: 273

Subscriber

  Reply # 2166988 24-Jan-2019 15:07
One person supports this post
Send private message quote this post

Have you tried logging into iCloud via your browser and see if the contacts are in the cloud but not synchronised?





Laptop: MacBook Pro (15-inch, 2017)
Desktop: iMac (27-inch, 2017)
Smartphone: iPhone Xs Max 256GB 'Space Grey'
Additional devices: Unifi Security Gateway, Unifi Switch, Unifi AP AC HD, Unifi Cloud Key, Apple TV 4K 64GB
Services: iCloud, YouTube Premium, Wordpress, Skinny

 


5358 posts

Uber Geek
+1 received by user: 1406

Moderator
Trusted
Lifetime subscriber

  Reply # 2167041 24-Jan-2019 17:28
Send private message quote this post

Make sure iCloud syncing for contacts is turned on on the device with the source of truth for your contacts. Eg if all your contacts are on your Mac go to the icloud settings and make.sure the slider is on for Contacts. Then do the same on each device that you want those contacts synced to.

 
 
 
 




11 posts

Geek


  Reply # 2167044 24-Jan-2019 17:33
Send private message quote this post

gehenna: Make sure iCloud syncing for contacts is turned on on the device with the source of truth for your contacts. Eg if all your contacts are on your Mac go to the icloud settings and make.sure the slider is on for Contacts. Then do the same on each device that you want those contacts synced to.

I have done this and I have checked on my iCloud dashboard online, I have toggled on and off the slider but still no contacts :(

3033 posts

Uber Geek
+1 received by user: 299


  Reply # 2167046 24-Jan-2019 17:37
Send private message quote this post

Try signing out of the iCloud account and signing back in again.




11 posts

Geek


  Reply # 2167051 24-Jan-2019 17:49
Send private message quote this post

CYaBro:

Try signing out of the iCloud account and signing back in again.


Just tried that on all my devices still nothing. Would apple be able to restore it from a backup, as iCloud is always backing up?

1008 posts

Uber Geek
+1 received by user: 431

Trusted
Subscriber

  Reply # 2167164 24-Jan-2019 19:42
One person supports this post
Send private message quote this post

Have you removed any old email accounts from your devices recently, or something similar? Many accounts, such as gmail.com or outlook.com, allow contacts to be stored as part of them and iOS has an annoying way to set them as the default for storing contacts unless you tell it otherwise. When did you last see the contacts and what has happened since then that may have caused them to disappear?








11 posts

Geek


  Reply # 2167175 24-Jan-2019 20:39
Send private message quote this post

Brumfondl:

Have you removed any old email accounts from your devices recently, or something similar? Many accounts, such as gmail.com or outlook.com, allow contacts to be stored as part of them and iOS has an annoying way to set them as the default for storing contacts unless you tell it otherwise. When did you last see the contacts and what has happened since then that may have caused them to disappear?


I haven’t edited/ deleted any other accounts on my device that contacts could have been saved to

5358 posts

Uber Geek
+1 received by user: 1406

Moderator
Trusted
Lifetime subscriber

  Reply # 2167182 24-Jan-2019 20:59
Send private message quote this post

Have you got all contacts groups ticked to show everything in the Address Book and Contacts apps?  Sometimes the contacts will be there but deselected from view. 




11 posts

Geek


  Reply # 2167184 24-Jan-2019 21:03
Send private message quote this post

gehenna:

Have you got all contacts groups ticked to show everything in the Address Book and Contacts apps?  Sometimes the contacts will be there but deselected from view. 


Yes I have done this too on all of my devices.

1742 posts

Uber Geek
+1 received by user: 475


  Reply # 2167208 24-Jan-2019 23:15
Send private message quote this post

matisyahu:

Have you tried logging into iCloud via your browser and see if the contacts are in the cloud but not synchronised?

you haven’t confirmed if you’ve done this yet.

Also this will sound crazy but see what happens if you set the date on your phone back a year.

How confident are you that the contacts you’ve had dropped we’re actually stored in iCloud? What is the default account set to for contacts? Have you checked deleted items on any exchange accounts? Have you checked for the contacts on any of the other accounts?

Is it possible the contacts were stored “on this device” and only making to the other devices from iCloud restores?

886 posts

Ultimate Geek
+1 received by user: 188

Trusted

  Reply # 2167260 25-Jan-2019 00:41
Send private message quote this post

MadEngineer:

 

... Is it possible the contacts were stored “on this device” and only making to the other devices from iCloud restores?

 

The truth shall set you free. So, so many hours spent diagnosing contact & calendar issues because of this default location that seems to change with every update & permutaion of which account was first used.





Please keep this GZ community vibrant by contributing in a constructive & respectful manner.




11 posts

Geek


  Reply # 2167261 25-Jan-2019 00:43
Send private message quote this post

MadEngineer:
matisyahu:

Have you tried logging into iCloud via your browser and see if the contacts are in the cloud but not synchronised?

you haven’t confirmed if you’ve done this yet.

Also this will sound crazy but see what happens if you set the date on your phone back a year.

How confident are you that the contacts you’ve had dropped we’re actually stored in iCloud? What is the default account set to for contacts? Have you checked deleted items on any exchange accounts? Have you checked for the contacts on any of the other accounts?

Is it possible the contacts were stored “on this device” and only making to the other devices from iCloud restores?

I have tried all of these and none of them have been able to find the contacts, also iPhones don’t save contacts to the sim however you can import them from the sim which I have tried

1567 posts

Uber Geek
+1 received by user: 228


  Reply # 2167275 25-Jan-2019 07:50
Send private message quote this post

Husband has some contacts stored in I think gmail or google. Every time we set up a new iphone or whatever for him it looks like some of his contacts (in the idevice contacts app) are missing until I add his gmail/google contacts in the settings then they all show up. Under contacts/accounts then add account.

682 posts

Ultimate Geek
+1 received by user: 170

Subscriber

  Reply # 2167377 25-Jan-2019 12:10
Send private message quote this post

Had this problem last year and my fix was:

 

NOTE: a) Backup your desktop first. b) At any stage with the following, after you have archived your Contacts, and you are asked to delete Contacts, do so.

 

     

  1. On your desktop computer: Open up Contacts then; File > Export > Contacts Archive
  2. On your desktop computer: Open up System Preferences > iCloud and untick Contacts
  3. Via desktop browser sign into your iCloud account > Contacts
  4. Click the gear wheel bottom left and Select all now click Delete ensure ALL Contacts are deleted
  5. Sign out of iCloud
  6. On each of your iDevices go into Settings > Apple ID account at very top of Settings list and select iCloud and untick Contacts
  7. On each of your iDevices go into Settings > Passwords and Accounts and select your iCloud account and untick Contacts
  8. Reboot all your iDevices and wait 5 minutes - this wait is important for the servers to catch up on everything.
  9. Now you should not have any Contacts listed on your desktop or any iDevice or anywhere
  10. Open up desktop Contacts and File > Preferences > Accounts and ensure that iCloud is listed in left column and selected.
  11. In right pane ensure 'Enable this account' is ticked and 'Fetch' is set to 'Automatically'
  12. Open up desktop Contacts and File > Import
  13. These imported contacts need to be under the iCloud heading in the left column
  14. On your desktop computer: Open up System Preferences > iCloud and tick Contacts
  15. Wait 5 minutes for the servers to catch up
  16. Via desktop browser sign into your iCloud account > Contacts and check to ensure all your contacts are there
  17. On each of your devices go into Settings > Apple ID account at very top of Settings list and select iCloud and tick Contacts
  18. On each of your devices go into Settings > Passwords and Accounts and select your iCloud account and tick Contacts

 


You should be good to go - I hope cool





iMac 27" (late 2013), Airport Time Capsule + Airport Express, iPhone7, iPad6, iPad Mini2

 

Panasonic Blu-ray PVR DMR-BWT835 + Panasonic Viera TH-L50E6Z, Chromecast Ultra




11 posts

Geek


  Reply # 2167385 25-Jan-2019 12:21
Send private message quote this post

FineWine:

Had this problem last year and my fix was:


NOTE: a) Backup your desktop first. b) At any stage with the following, after you have archived your Contacts, and you are asked to delete Contacts, do so.



  1. On your desktop computer: Open up Contacts then; File > Export > Contacts Archive

  2. On your desktop computer: Open up System Preferences > iCloud and untick Contacts

  3. Via desktop browser sign into your iCloud account > Contacts

  4. Click the gear wheel bottom left and Select all now click Delete ensure ALL Contacts are deleted

  5. Sign out of iCloud

  6. On each of your iDevices go into Settings > Apple ID account at very top of Settings list and select iCloud and untick Contacts

  7. On each of your iDevices go into Settings > Passwords and Accounts and select your iCloud account and untick Contacts

  8. Reboot all your iDevices and wait 5 minutes - this wait is important for the servers to catch up on everything.

  9. Now you should not have any Contacts listed on your desktop or any iDevice or anywhere

  10. Open up desktop Contacts and File > Preferences > Accounts and ensure that iCloud is listed in left column and selected.

  11. In right pane ensure 'Enable this account' is ticked and 'Fetch' is set to 'Automatically'

  12. Open up desktop Contacts and File > Import

  13. These imported contacts need to be under the iCloud heading in the left column

  14. On your desktop computer: Open up System Preferences > iCloud and tick Contacts

  15. Wait 5 minutes for the servers to catch up

  16. Via desktop browser sign into your iCloud account > Contacts and check to ensure all your contacts are there

  17. On each of your devices go into Settings > Apple ID account at very top of Settings list and select iCloud and tick Contacts

  18. On each of your devices go into Settings > Passwords and Accounts and select your iCloud account and tick Contacts



You should be good to go - I hope cool


Thank you very much for all of your help I will try this when o have time :)

 1 | 2
View this topic in a long page with up to 500 replies per page Create new topic


Donate via Givealittle


Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

A call from the companies providing internet access for the great majority of New Zealanders, to the companies with the greatest influence over social media content
Posted 19-Mar-2019 15:21


Two e-scooter companies selected for Wellington trial
Posted 15-Mar-2019 17:33


GeForce GTX 1660 available now
Posted 15-Mar-2019 08:47


Artificial Intelligence to double the rate of innovation in New Zealand by 2021
Posted 13-Mar-2019 14:47


LG demonstrates smart home concepts at LG InnoFest
Posted 13-Mar-2019 14:45


New Zealanders buying more expensive smartphones
Posted 11-Mar-2019 09:52


2degrees Offers Amazon Prime Video to Broadband Customers
Posted 8-Mar-2019 14:10


D-Link ANZ launches D-Fend AC2600 Wi-Fi Router Protected by McAfee
Posted 7-Mar-2019 11:09


Slingshot commissions celebrities to design new modems
Posted 5-Mar-2019 08:58


Symantec Annual Threat Report reveals more ambitious, destructive and stealthy attacks
Posted 28-Feb-2019 10:14


FUJIFILM launches high performing X-T30
Posted 28-Feb-2019 09:40


Netflix is killing content piracy says research
Posted 28-Feb-2019 09:33


Trend Micro finds shifting threats require kiwis to rethink security priorities
Posted 28-Feb-2019 09:27


Mainfreight uses Spark IoT Asset Tracking service
Posted 28-Feb-2019 09:25


Spark IoT network now covers 98% of New Zealand population
Posted 19-Feb-2019 09:28



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.


Support Geekzone »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.