Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




314 posts

Ultimate Geek
+1 received by user: 11


Topic # 90126 15-Sep-2011 11:26
Send private message

Hi, I'm experimenting around with web proxies for various reasons, and I'm trying to get some working on Port 80, and no matter what proxy address I use, as long as it's got a port 80, won't work. They all test okay, on the tester I have, but when I add them, It appears to have connected, untill I do a IP check, and it's like I havn't got a proxy on at all. So I'm it appears I'm still browsing from my NZ IP, even though I specified to connect to a UK proxy. Most of the proxies are on Port 80, and every one I tried as far as I can remember on port 80, all do the same thing. Is it Slingshot, who block stuff like that, or I have got, or have had previous Proxy software on my computer, which I'm pretty sure I have deleted, expect for the one program I use, and it's still not working.


Anyone got any suggestions?

Thanks      

Create new topic
622 posts

Ultimate Geek
+1 received by user: 12


  Reply # 521407 15-Sep-2011 12:01
Send private message

what I use is freeproxy v4 its very good and silly virus scanners flah it
as malware which its not LOL it works very well

a proxy allows you to share a internet connect on a pc with
others on a lan. that pc can be vpn as well and if running
proxy on it any pc then can access the same vpn account
hence www and email etc


i normally config http on proxy and use port 8080


on firefox I select the pc ip running the proxy e..g 192.168.1.1

and port 8080 and tick for all protocols (except socks which I setup a 1080
socks 5 on proxy as well)

its thay simple

now if it dont work most likely you have a firewall or virus scanner blocking ports
or lan locations.. so disable to see if works


its possible you have other soft using port 80 conflicting with proxy soft

freepotxy however willl provide a error log I believe if conflicts


theres a good firefox add-on called foxyproxy ca make it easy to setup settings on firwfox for
proxy servers and enabled the advance features like DNS requests via proxy as well

PING and ipconfig /all in dos prompt are handy to
make sue basic replies are working or finding out ips

not sure if thats what you were asking though

622 posts

Ultimate Geek
+1 received by user: 12


  Reply # 521411 15-Sep-2011 12:08
Send private message

oh yeah sounds like you mean using open external proxies rather then a home proxy.. but a home proxy you
can also select use external proxy via the freeproxy settings.. so you get lan proxy to ext proxy that all pcs can access. then you can just change on settings and not all affect pcs

personnally theres a better product called proxyswitcher.. perhaps try that software it runs on port 3128

and is free for basic mode.. and pro dont cos much.. comes in handy if not using VPN

on telecom not noticed them blocking port 80 but i doubt slingshot is.. still say its some other soft
on pc blocking you?
you could always do some testing via vmware with xp its also has a trail period
if not got it
comes in handy for trouble shooting stuff

 
 
 
 


3259 posts

Uber Geek
+1 received by user: 643

Trusted

  Reply # 522484 17-Sep-2011 22:16
Send private message

I reckon it will be slingshots transparent proxy that intercepts port 80 traffic.

Try logging into the slingshot control panel on their website and disabling the proxy / cache service, then rebooting your router.




Ray Taylor
Taylor Broadband (rural hawkes bay)
www.ruralkiwi.com

There is no place like localhost
For my general guide to extending your wireless network Click Here




622 posts

Ultimate Geek
+1 received by user: 12


  Reply # 522492 17-Sep-2011 22:39
Send private message

yeo you could be right.. at least they can give you a option to disable it

lucky theres enough ext proxies that dont use port 80

you think slingshot would say if that ip hostname dont exist in cache they
by pass caching transparent proxy automaically though

i recall when with ihug a friend could not login to his works

special logjn page since the proxy was redirecting or blocking
a ip be creation of something.. bug perhaps in the coding


only way was to use a ext proxy as a bounce to it.. lol

always annoying when they control your web to much

i guess thats the problem with all you can eat they have some hardware filtering
blocking stuff

so people will be try8ing to encrypt and use other ports

or udp instead of tcp to get around it

1984 posts

Uber Geek
+1 received by user: 133

Trusted

  Reply # 523256 19-Sep-2011 21:10
Send private message

raytaylor: I reckon it will be slingshots transparent proxy that intercepts port 80 traffic.

Try logging into the slingshot control panel on their website and disabling the proxy / cache service, then rebooting your router.

Yes have you got the web cache set to "on" in the slingshot internet settings? Some proxies have an alternative port or can function as a SOCKS proxy on a different port.




Qualified in business, certified in fibre, stuck in copper, have to keep going  ^_^

Create new topic



Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.