Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




27266 posts

Uber Geek
+1 received by user: 6692

Moderator
Trusted
Biddle Corp
Lifetime subscriber

Topic # 115545 29-Mar-2013 08:56
Send private message

I was just doing some testing for somebody and noticed their Genius has DNS resolution enabled on the WAN interface meaning I can browse the web using somebody's Orcon IP. Is this the standard setup for all Genius devices? If so it's no wonder the internet is being flooded with so many DNS DDoS attacks..





Filter this topic showing only the reply marked as answer Create new topic
338 posts

Ultimate Geek
+1 received by user: 30

Lifetime subscriber

  Reply # 789138 29-Mar-2013 10:40
Send private message

Orcon publish their DNS servers here http://www.orcon.net.nz/support/gfaq_page/what_are_your_dns_server_addresses and presumably these servers can only be used by users logged on to their network.  If I was Orcon I would be concerned only if non-Orcon users could use these servers.  My apologies if I have misunderstood your post.



27266 posts

Uber Geek
+1 received by user: 6692

Moderator
Trusted
Biddle Corp
Lifetime subscriber

  Reply # 789141 29-Mar-2013 10:48
Send private message

OldGeek: Orcon publish their DNS servers here http://www.orcon.net.nz/support/gfaq_page/what_are_your_dns_server_addresses and presumably these servers can only be used by users logged on to their network.  If I was Orcon I would be concerned only if non-Orcon users could use these servers.  My apologies if I have misunderstood your post.


The Orcon DNS servers won't resolve queries if you're outside the Orcon network. This is standard practice for an ISP these days.

The issue I've seen is individual Genius devices responding to DNS queries (at least the one device I tested), ie browsing the net using a DNS IP address of an Orcon customer which means they'll be stung traffic usage for these DNS requests. There are lots of poorly configured devices out there like this, and in the past it wasn't a big deal. It is very poor from a security perspective now.

 
 
 
 


1387 posts

Uber Geek
+1 received by user: 134


  Reply # 789168 29-Mar-2013 11:07
Send private message

they may be filtering dns at the border for residential users (stopping users running their own dns server in the process)

i'd recommend to try doing a resolution from international on effected IP .. 

if it works, then this is a VERY SEVERE issue.




27266 posts

Uber Geek
+1 received by user: 6692

Moderator
Trusted
Biddle Corp
Lifetime subscriber

  Reply # 789188 29-Mar-2013 11:45
Send private message

mercutio: they may be filtering dns at the border for residential users (stopping users running their own dns server in the process)

i'd recommend to try doing a resolution from international on effected IP .. 

if it works, then this is a VERY SEVERE issue.



Resolution works from a number of websites offering nslookup type services.


1387 posts

Uber Geek
+1 received by user: 134


  Reply # 789189 29-Mar-2013 11:49
One person supports this post
Send private message

sbiddle:
mercutio: they may be filtering dns at the border for residential users (stopping users running their own dns server in the process)

i'd recommend to try doing a resolution from international on effected IP .. 

if it works, then this is a VERY SEVERE issue.



Resolution works from a number of websites offering nslookup type services.



someone from inside orcon with authority really needs to do a scan on their whole ip address range checking for open resolvers.

was firewall enabled on the genius?




27266 posts

Uber Geek
+1 received by user: 6692

Moderator
Trusted
Biddle Corp
Lifetime subscriber

  Reply # 789197 29-Mar-2013 11:54
Send private message

mercutio:
sbiddle:
mercutio: they may be filtering dns at the border for residential users (stopping users running their own dns server in the process)

i'd recommend to try doing a resolution from international on effected IP .. 

if it works, then this is a VERY SEVERE issue.



Resolution works from a number of websites offering nslookup type services.



someone from inside orcon with authority really needs to do a scan on their whole ip address range checking for open resolvers.

was firewall enabled on the genius?



Unsure, but I assume so. I was just checking something for somebody who had noticed a lot of extra usage on their connection.


1387 posts

Uber Geek
+1 received by user: 134


  Reply # 789204 29-Mar-2013 12:05
Send private message

sbiddle:
mercutio:
sbiddle:
mercutio: they may be filtering dns at the border for residential users (stopping users running their own dns server in the process)

i'd recommend to try doing a resolution from international on effected IP .. 

if it works, then this is a VERY SEVERE issue.



Resolution works from a number of websites offering nslookup type services.



someone from inside orcon with authority really needs to do a scan on their whole ip address range checking for open resolvers.

was firewall enabled on the genius?



Unsure, but I assume so. I was just checking something for somebody who had noticed a lot of extra usage on their connection.



i checked someone on genius's connection after reading this because they had high usage a few days ago, and found their dns was open too.  and that their firewall was disabled, and enabling it fixed it.

i couldn't see any option to disable wan dns resolution.

82 posts

Master Geek
+1 received by user: 3


  Reply # 789210 29-Mar-2013 12:29
One person supports this post
Send private message

Mercutio is right, I have tested.
DNS resolution on the WAN interface only works with the firewall off.

They may want to enable the firewall in the Genius modem
Advanced Settings > Firewall > enable

23 posts

Geek
+1 received by user: 8

Trusted
HD Net

  Reply # 789239 29-Mar-2013 13:38
Send private message

By default - the Genius is configured to block pretty much all service ports on the WAN side, with NAT-PMP or UPnP pinholes being created for connections as requested by a PC on the LAN.

It requires user intervention to manually disable the Firewall and is not something that we would ever recommend.



27266 posts

Uber Geek
+1 received by user: 6692

Moderator
Trusted
Biddle Corp
Lifetime subscriber

  Reply # 789270 29-Mar-2013 14:24
Send private message

I can confirm that this issue has been resolved by reanabling the firewall.

Filter this topic showing only the reply marked as answer Create new topic



Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.