Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.


View this topic in a long page with up to 500 replies per page Create new topic
1 | 2 | 3
28210 posts

Uber Geek

Moderator
Trusted
Biddle Corp
Lifetime subscriber

  # 1388179 15-Sep-2015 20:31
Send private message

Ragnor: Here's where I think you need to be going (dhcp client on the vlan, no vlan in the bridge), example (port 1 for wan):

 

# vlan
/interface vlan add name=vlan1 vlan-id=10 interface=ether1
# dhcp client
/ip dhcp-client add interface=vlan1 disabled=no
# bridge
/interface bridge add name=bridge1
/interface bridge port add interface=ether2 bridge=bridge1
.. etc

 



That's a setup for using a Mikrotik as a bridge/switch to tag traffic - such as when you want to use a router that doesn't support 802.1p tagging on a UFB connection that requires a VLAN tag.

It's not the type of setup you'd use when using the Mikrotik as a router.




17 posts

Geek


  # 1388180 15-Sep-2015 20:31
Send private message

I appreciate your help friend, but as one Freddy Kreuger once said .. 'welcome to my nightmare'.


[admin@MikroTik] /ip dhcp-client> print detail
Flags: X - disabled, I - invalid
0 interface=vlan1 add-default-route=yes default-route-distance=1 use-peer-dns=yes use-peer-ntp=yes
dhcp-options=hostname,clientid status=requesting... dhcp-server=60.234.8.5

I just can't seem to make it stick. No matter which way I spin it the DHCP client refuses the status. This is with your above configuration; it's like Orcon is refusing my connection. I've already checked that I don't have to MAC clone and I've tried cloning the Genius.

The 'simple' issue if you want to call it that; is I can't seem to get a status from Orcon. My understanding is it should be pretty straight forward. VLan10, DHCP-Client, Ethernet Port. The best I have gotten is 'requesting'. I've tried every configuration I can think of but every /ip dhcp-client print detail returns status=requesting... and I never quite get past it.

 
 
 
 


1245 posts

Uber Geek


  # 1388187 15-Sep-2015 20:49
Send private message

The config you posted earlier looked OK.

How have you cloned the MAC? - this may be the key to the issue.

You could create a second bridge for the VLAN and put in the mac from the Genius in there - some more info here

http://wiki.mikrotik.com/wiki/Change_MAC_address_of_VLAN_interface




17 posts

Geek


  # 1388194 15-Sep-2015 21:09
Send private message

Hmm, I tried this, starting to feel a bit out of my depth here so I'm not sure this is absolutely correct, this gave me the same result 'requesting...':

/interface vlan add name=e10-v10-WAN interface=ether10 vlan-id=10 disabled=no
/interface bridge add name=br-lan
/interface ethernet set ether2,ether3,ether4,ether5 master-port=ether1
/interface ethernet set ether7,ether8,ether9 master-port=ether6
/interface bridge port add bridge=br-lan interface=ether1
/interface bridge port add bridge=br-lan interface=ether6
/interface bridge port add bridge=br-lan interface=wlan1
/ip dhcp-client add interface=e10-v10-WAN disabled=no
/ip address add address=192.168.1.1/24 interface=br-lan
/ip pool add name=lan ranges=192.168.1.100-192.168.1.254
/ip dhcp-server network add address=192.168.1.0/24 dns-server=8.8.8.8 gateway=192.168.1.1
/ip dhcp-server add address-pool=lan authoritative=yes disabled=no interface=br-lan lease-time=3d name=lan
/ip firewall nat add chain=srcnat action=masquerade src-address=192.168.1.0/24 out-interface=e10-v10-WAN

/interface bridge add name=bridgeMAC disabled=no
/interface bridge port add bridge=bridgeMAC disabled=no interface=e10-v10-WAN
/interface bridge set bridgeMAC admin-mac=xx:xx:xx:xx:xx:xx auto-mac=no



1245 posts

Uber Geek


  # 1388201 15-Sep-2015 21:16
Send private message

How did you get the mac of the wan port - did you follow this?

http://www.geekzone.co.nz/forums.asp?forumid=82&topicid=143067



17 posts

Geek


  # 1388207 15-Sep-2015 21:25
Send private message

nitrotech: How did you get the mac of the wan port - did you follow this?

http://www.geekzone.co.nz/forums.asp?forumid=82&topicid=143067


I got it from an ARP -a , I followed those instructions and go the same mac address as the ARP -a gave me. Still no result. Most disheartening.

1245 posts

Uber Geek


  # 1388208 15-Sep-2015 21:26
Send private message

Complete123:
nitrotech: How did you get the mac of the wan port - did you follow this?

http://www.geekzone.co.nz/forums.asp?forumid=82&topicid=143067


I got it from an ARP -a , I followed those instructions and go the same mac address as the ARP -a gave me. Still no result. Most disheartening.


Is the DHCP client now on the wan bridge?

 
 
 
 




17 posts

Geek


  # 1388210 15-Sep-2015 21:35
Send private message

I used the interface to switch the DHCP Client from e10-v10-WAN to bridgeMAC and got the same 'requesting...' result.

At this point I'd like to thank all of you for helping. I have been tearing hair out for the last week or so trying to figure out what I was doing wrong. If nothing else this makes me realize I'm not the only one that's confused. 

1245 posts

Uber Geek


  # 1388216 15-Sep-2015 21:43
Send private message

So in your config above

/interface bridge add name=bridgeMAC disabled=no
/interface bridge port add bridge=bridgeMAC disabled=no interface=e10-v10-WAN
/interface bridge set bridge1 admin-mac=xx:xx:xx:xx:xx:xx auto-mac=no

Is that just a typo? eg. in winbox it shows the correct mac for the bridge



17 posts

Geek


  # 1388219 15-Sep-2015 21:47
Send private message

nitrotech: So in your config above

/interface bridge add name=bridgeMAC disabled=no
/interface bridge port add bridge=bridgeMAC disabled=no interface=e10-v10-WAN
/interface bridge set bridge1 admin-mac=xx:xx:xx:xx:xx:xx auto-mac=no

Is that just a typo? eg. in winbox it shows the correct mac for the bridge


Yeah I just caught that; it was a typo. I actually changed it:

[admin@MikroTik] /ip dhcp-client> print detail
Flags: X - disabled, I - invalid
0 interface=bridgeMAC add-default-route=yes default-route-distance=1
use-peer-dns=yes use-peer-ntp=yes dhcp-options=hostname,clientid
status=requesting... dhcp-server=60.234.8.54


The bridge shows the MAC address I input. That was a typo. If I unplug the ethernet cable it goes to 'searching' and plugging it in gets 'requesting' so it's clearly identifying a connection of sorts.




1245 posts

Uber Geek


  # 1388265 15-Sep-2015 22:07
Send private message

That's really strange - you are on a vlan tagged port? you're not untagged for some reason? - does the DHCP client dish you out an address if you put it on eth10?



17 posts

Geek


  # 1388270 15-Sep-2015 22:22
Send private message

nitrotech: That's really strange - you are on a vlan tagged port? you're not untagged for some reason? - does the DHCP client dish you out an address if you put it on eth10?


It doesn't spit out anything if I connect the laptop directly to ETH10. Oddly it seems to have killed the router (had to reset it; couldnt' even connect with the mac address) I don't think it appreciated it.  The ETH10 was Vlan10 tagged; unless there's some kind of untagging I'm not aware of going on. If I reset it to Home AP and just add VLAN10 to the connection with a DHCP Client I get the same thing, literally identical on ETH1-Gateway. 

I'm at the point where I'd be willing to set up a connection to the router with SSH just to let someone else have a go. Cause I'm totally and utterly stumped. Or even Teamviewer in just to have a go. Unfortunately cause it's a DHCP Server that causes more issues ... I guess I'd have to somehow configure the ports to do this and that's a whole new problem.

1245 posts

Uber Geek


  # 1388282 15-Sep-2015 22:38
Send private message

Complete123:
nitrotech: That's really strange - you are on a vlan tagged port? you're not untagged for some reason? - does the DHCP client dish you out an address if you put it on eth10?


It doesn't spit out anything if I connect the laptop directly to ETH10. Oddly it seems to have killed the router (had to reset it; couldnt' even connect with the mac address) I don't think it appreciated it.  The ETH10 was Vlan10 tagged; unless there's some kind of untagging I'm not aware of going on. If I reset it to Home AP and just add VLAN10 to the connection with a DHCP Client I get the same thing, literally identical on ETH1-Gateway. 

I'm at the point where I'd be willing to set up a connection to the router with SSH just to let someone else have a go. Cause I'm totally and utterly stumped. Or even Teamviewer in just to have a go. Unfortunately cause it's a DHCP Server that causes more issues ... I guess I'd have to somehow configure the ports to do this and that's a whole new problem.


I'm getting confused with what you're up to here, and unsure why you plugged the laptop into the wan port.

I'd suggest going back to the standard config of eth1 for wan.

I'll have a think about things overnight



17 posts

Geek


  # 1388283 15-Sep-2015 22:40
Send private message

nitrotech:
I'm getting confused with what you're up to here, and unsure why you plugged the laptop into the wan port.

I'd suggest going back to the standard config of eth1 for wan.

I'll have a think about things overnight


Perhaps I'm just getting tired now; I thought you were asking of the ETH10 was dishing out a DHCP. It was easy to just plug it in and see what happens .. been at this for about 4 hours so may not be thinking correctly any longer.

I reset it and configured VLAN10 with DHCP Client on ETH1-Gateway. Once I get this working I can change whatever else is needed. Let me know if you think of anything I've tumbled into the area of just yanking at straws.



17 posts

Geek


  # 1388583 16-Sep-2015 15:46
Send private message

As a matter of testing I reset the router and confirmed it was working by using traffic from the Genious to the router.
I then took my NETGEAR GS108T and configured it as so http://www.geekzone.co.nz/forums.asp?forumid=82&topicid=107361
I then used my Mikrotik router and still got no DHCP.

It's quite clear that the genious is doing something I am not.

1 | 2 | 3
View this topic in a long page with up to 500 replies per page Create new topic



Twitter and LinkedIn »



Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

Amazon Studios announces New Zealand as location for its upcoming series based on The Lord of the Rings
Posted 18-Sep-2019 17:24


The Warehouse chooses Elasticsearch service
Posted 18-Sep-2019 13:55


Voyager upgrades core network to 100Gbit
Posted 18-Sep-2019 13:52


Streaming service Acorn TV launches in New Zealand with selection with British shows
Posted 18-Sep-2019 08:55


Bitcoin.com announces partnership with smartphone manufacturer HTC
Posted 16-Sep-2019 21:30


Finalists Announced for Microsoft NZ Partner Awards
Posted 16-Sep-2019 19:37


OPPO Showcases New CameraX Capabilities at Google Developer Days China 2019
Posted 15-Sep-2019 12:42


New Zealand PC Market returns to growth
Posted 15-Sep-2019 12:24


Home sensor charity director speaks about the preventable death which drives her to push for healthy homes
Posted 11-Sep-2019 08:46


Te ao Maori Minecraft world set to inspire Kiwi students
Posted 11-Sep-2019 08:43


Research reveals The Power of Games in New Zealand
Posted 11-Sep-2019 08:40


Ring Door View Cam now available in New Zealand
Posted 11-Sep-2019 08:38


Vodafone NZ to create X Squad
Posted 10-Sep-2019 10:25


Huawei nova 5T to be available 20th September
Posted 5-Sep-2019 11:55


Kogan.com launches prepay challenger brand Kogan Mobile in New Zealand
Posted 3-Sep-2019 11:42



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.


Support Geekzone »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.