Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




79 posts

Master Geek


# 180546 13-Sep-2015 11:33
Send private message

Hi all. I'm been looking though some earlier topics as I've been having trouble with my Magic TV 3600, which now claims that there is no hard disk, though at boot up, I can hear it whirring around, variably, as though the system is trying to read something from it. Anyway, I guess I need a new hard disk but thought I'd try reformatting the original one, first. I realise this probably won't help, from other posts, but I at least wanted to check it. However, the procedure doesn't work for me.

I put in a USB stick with firmware on it (currently 3.23 beta, but I had 3.20 on the stick, and installed, earlier, but no different), get into rescue mode and it detects the firmware on the USB stick. When I press 15900 the display is still at the original FOUND message. I tried this many times, both without upgrading the firmware and after upgrading the firmware.

I'm guessing that it's not offering to format the disk because it thinks there is no disk. But I want to make sure that the disk can be formatted, if I replace it. If not, is there a way to format the disk correctly in a PC? I'm happy to do that.

Any suggestions welcome.

Create new topic


79 posts

Master Geek


  # 1386619 13-Sep-2015 13:10
Send private message

I tried a few things. I had a disk drive in my desktop that didn't have much on it. So I put that in the Magic TV. It didn't recognise it but it showed up on the system info page. However, I still couldn't get the format option in rescue mode. So it's just as well that I didn't just go straight out and buy another HDD.

As the replacement disk was recognised on the system info screen, I put the old one back in and it, too, was listed on the system info page. So, after a bit of exploring of the system menu, I found a check and repair HDD option (something like Settings/Recording Setup/Advanced Options). I tried that but it failed with Error 4, asking me to try again, which I did but it failed with the same error.

So I'm thinking that any HDD replacement would be useless. Maybe if I could get to that HDD format mode, it would help, but that doesn't work. I will try reverting to perhaps the patched firmware, that twolostkiwis made available. Maybe the format option got dumped in later official firmware.

Interestingly, through all of this, I did notice options for formatting, checking and repairing my USB drive and I've also seen messages saying that USB storage is ready. If I have the USB stick in and go to the menu option that tells be about remaining space on the HDD, it also shows my USB drive and even says how much recording I could do on it. However, there seems to be no way to get it to record to the USB. Any hints would be appreciated, as at least a USB drive would enable me to record programmes - at the moment, I can't.

One last thing. I put the original drive in my desktop and it says that partition 2 is an unknown file system (although it seems to detect that it's a journalled file system, jfs), so I guess I wouldn't be able to format it on my linux box, anyway - it would have to be on the Magic TV, if at all.



79 posts

Master Geek


  # 1387090 14-Sep-2015 11:27
Send private message

I tried downgrading to 2lostkiwis' patched 3.17 firmware. Strangely, the rescue procedure got stuck trying to detect it (i.e. display stuck on "RESCUE"), but I managed to install it from the main menu. I put another firmware version on the USB stick and this time it was recognised in the rescue procedure but I still couldn't get to the format disk function, by pressing 15900. Do I have to press anything else? I've tried Enter and a few other keys but no joy.

Still, I can browse to the machine (not sure what good that is) and can telnet to it but I don't know the root password or any other user on the box, so that isn't much good to me (though I'm not sure how I'd try a format from there, anyway).

All hints welcome. I can't really afford a replacement equivalent machine, right now, so I'm banging away at this.

 
 
 
 


cb1

271 posts

Ultimate Geek


  # 1387129 14-Sep-2015 12:35
Send private message

You have to use an official firmware for the rescue. Once it's back up and running you can use one of the patched versions. Also try using another USB flashdrive. I found the rescue didn't work on the flashdrive I had previously used for firmware upgrades, but did using an older/smaller flashdrive.




cb



79 posts

Master Geek


  # 1387196 14-Sep-2015 14:17
Send private message

Thanks, cb1. Yeah, that seems to match my experience. As soon as I tried an official firmware version then it was detected. However, my main problem is this blasted hard disk. I can't get to the format function using the technique mentioned on other threads. I don't know if that would solve my issue (whether it is formatting the original disk or another disk) but I'd like to try, if only I cold get to the format function or could format it on another machine.

442 posts

Ultimate Geek


  # 1387199 14-Sep-2015 14:22
Send private message

cb1: You have to use an official firmware for the rescue. Once it's back up and running you can use one of the patched versions. Also try using another USB flashdrive. I found the rescue didn't work on the flashdrive I had previously used for firmware upgrades, but did using an older/smaller flashdrive.



yes some usb flashdrives are more responsive than others , i found this out myself







 

Amazon Echo

 

Amazon Dot

 

Lifx Bulbs

 

Nexus 5X
Magic TV 3600
Sony EX700

 

Unblocking service
Amazon Fire TV x 2  = Netflix USA + Amazon Prime
Lightbox






79 posts

Master Geek


  # 1387288 14-Sep-2015 16:03
Send private message

Finally, success. My Linux box did report the jfs file system on the large partition of the disk but couldn't mount it and didn't know how to format it. I should have investigated that more. In the end, I installed gparted and this was able format jfs partitions. Whoopee! So I formatted the small ext3 partition (500MB) and the 499.5GB jfs partition. Just a quick format. Put it back in the MTV box and, lo, it works!

So I'm back up and running for now. At least I now know that I can format on my linux box, if needed, in future.

I'd like to figure out the root password on the box, though. Maybe I can try 2lostkiwis' brute force technique, mention on his blog - if I can figure it out.



79 posts

Master Geek


  # 1388281 15-Sep-2015 22:36
Send private message

Hmm, I spoke too soon. It did appear to be going OK but a playback of one programme froze the device and I had to reboot. At least I was able to run the HDD check without errors and it reported "no error". So I've formatted another drive the same way and that seems to be working OK, for now. If it does work for about a week, I'll buy a new drive to replace it (it's smaller and much noisier than the original).

As and aside, I was trying to find a disk checking tool on Linux but couldn't find anything decent. I'm sure that there used to be loads of such tools but I couldn't find any , even at the WD web site. Anyway, that's a different story.

 
 
 
 




79 posts

Master Geek


  # 1392170 22-Sep-2015 19:36
Send private message

That last disk seemed to do the trick, with no problems for over a week. So I've bought a 1TB WD green disk as it is much quieter (couldn't find a 500 GB version, which would have been big enough) and that's gone in a treat. I was lucky in that I had two spare SATA connectors in my Linux desktop, so could partition and format (with gparted) the new one (I needed to create a new msdos partition table to be able to define two primary partitions), then copy the files from the old one to the new one - it all seemed to work.

I had been using the patched version 3.17 firmware but I was missing most programme titles in the recordings, so I've installed the latest non-beta that I could find (3.20).

So far, so good but missing the http server on the patched 3.17 though I probably wouldn't have used it that much.

1026 posts

Uber Geek


  # 1392288 22-Sep-2015 22:16
Send private message

 


There is also a 3.21. I think that was the one that added a pagefile to reduce the frequency of crashes so reboot your Magic TV from the settings menu when it starts to slow down.

 


http://www.magictv.com/nz/downloads/mtv3600_3_21NZ.zip

 


http://www.geekzone.co.nz/forums.asp?topicid=159964&page_no=5

 


http://www.geekzone.co.nz/forums.asp?topicid=159964&page_no=6#1258175

 





79 posts

Master Geek


  # 1392334 22-Sep-2015 23:08
Send private message

Thanks, bfginger. I'll take a look. I have tried the 3.23 beta firmware, and still have that available but maybe I'll go for a non-beta version. However, I find it odd that the only one on their website is 3.20 (though there is a release notes doc for 3.18!).

Create new topic



Twitter and LinkedIn »



Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

Facebook Portal to land in New Zealand
Posted 19-Sep-2019 18:35


Amazon Studios announces New Zealand as location for its upcoming series based on The Lord of the Rings
Posted 18-Sep-2019 17:24


The Warehouse chooses Elasticsearch service
Posted 18-Sep-2019 13:55


Voyager upgrades core network to 100Gbit
Posted 18-Sep-2019 13:52


Streaming service Acorn TV launches in New Zealand with selection with British shows
Posted 18-Sep-2019 08:55


Bitcoin.com announces partnership with smartphone manufacturer HTC
Posted 16-Sep-2019 21:30


Finalists Announced for Microsoft NZ Partner Awards
Posted 16-Sep-2019 19:37


OPPO Showcases New CameraX Capabilities at Google Developer Days China 2019
Posted 15-Sep-2019 12:42


New Zealand PC Market returns to growth
Posted 15-Sep-2019 12:24


Home sensor charity director speaks about the preventable death which drives her to push for healthy homes
Posted 11-Sep-2019 08:46


Te ao Maori Minecraft world set to inspire Kiwi students
Posted 11-Sep-2019 08:43


Research reveals The Power of Games in New Zealand
Posted 11-Sep-2019 08:40


Ring Door View Cam now available in New Zealand
Posted 11-Sep-2019 08:38


Vodafone NZ to create X Squad
Posted 10-Sep-2019 10:25


Huawei nova 5T to be available 20th September
Posted 5-Sep-2019 11:55



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.


Support Geekzone »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.