Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.


View this topic in a long page with up to 500 replies per page Create new topic
1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | 10 | 11 | 12 | 13 | 14 | 15 | 16 | 17 | 18 | 19 | 20 | ... | 22
SandE
4 posts

Wannabe Geek


  #163585 10-Sep-2008 19:49
Send private message

I'm a bit of a noob at this but I've been enjoying your little app successfully for a few months now (Thanks!!).
This latest release looks to have a bit of a bug. It doesn't appear to make/download a new tvguide.xml file.

When I run it in dos it lists the download location as:
C:\Program Files\Team MediaPortal\MediaPortal TV Server\\tvguide.xml

Is that double backslash going to be causing probs or is it just a typo for the echo to screen?
(Also is this the best place to ask?)

Cheers

mentalinc

2044 posts

Uber Geek

Trusted
Subscriber

  #163598 10-Sep-2008 20:20
Send private message

Yes this is the perfect place to ask questions.

It may be the cause of your error, however it is not causing any issues for me on Vista.

May I ask you to go to http://epg.pvr.geek.nz/epg/ and try and download one of the files. If it lets you download then I'm not sure of the issue.
If it gives you an error you need to obtain a new IP address or wait for the ban to be over (I don't control this).

I will be releasing a new version soon which may help solve this issue.




CPU: Intel 3770k| RAM: F3-2400C10D-16GTX G.Skill Trident X |MB:  Gigabyte Z77X-UD5H-WB | GFX: GV-N660OC-2GD gv-n660oc-2gd GeForce GTX 660 | Monitor: Qnix 27" 2560x1440

 

 


 
 
 
 


hads
391 posts

Ultimate Geek

Trusted

  #163613 10-Sep-2008 21:09
Send private message

Hi there,

Could I please get you to either stop distributing the scheduled task example or distribute one with a randomised download time. If the program gets popular then it may cause issues with loading on the server at 9am.

Thanks




mentalinc

2044 posts

Uber Geek

Trusted
Subscriber

  #163618 10-Sep-2008 21:14
Send private message

hads: Hi there,

Could I please get you to either stop distributing the scheduled task example or distribute one with a randomised download time. If the program gets popular then it may cause issues with loading on the server at 9am.

Thanks


Would adding say 9am + random number of minutes between 0-30 mins work?

i.e the default .bat file has 9am (which people are free to change)

If I set the program up to detect if the time 9am then add between 0-30 mins

so times would be between 9:00am and 9:30, assuming people don't change it themselves?

Is the website yours or are you simply looking out for its well being?


edit: this change has been implemented, and will be in the next version I release.




CPU: Intel 3770k| RAM: F3-2400C10D-16GTX G.Skill Trident X |MB:  Gigabyte Z77X-UD5H-WB | GFX: GV-N660OC-2GD gv-n660oc-2gd GeForce GTX 660 | Monitor: Qnix 27" 2560x1440

 

 


hads
391 posts

Ultimate Geek

Trusted

  #163628 10-Sep-2008 21:42
Send private message

Hi again,

Excellent, thanks for the quick response. Yes that type of randomisation is what I was talking about.

Yes, it is my server.

Cheers,

hads




SandE
4 posts

Wannabe Geek


  #163687 11-Sep-2008 08:46
Send private message

OK, now I feel like a twit, I could download that file no probs and it all works fine now. It was happening for three separate installs (all in Wgtn) though so there was definately 'something' going on. The wind must have changed.

Thanks anyway.

PS YAAAY!! The earth still exists!! Tune in next month when they actually use the LHC at full speed and collide particles... (stupid media)

HTPCnewbie
57 posts

Master Geek


  #163967 12-Sep-2008 11:20
Send private message

Metalinc (and others),

Does your application / service support Vista Media Center (VMC)?  Or do I need to use Reven's app / service?

I don't see instructions for VMC on your website...


 
 
 
 


mentalinc

2044 posts

Uber Geek

Trusted
Subscriber

  #164061 12-Sep-2008 18:02
Send private message

HTPCnewbie:

Mentalinc (and others),

Does your application / service support Vista Media Center (VMC)?  Or do I need to use Reven's app / service?

I don't see instructions for VMC on your website...




At this stage no it doesn't - Dont know what will need to be done to get it to work for VMC, but I will have a look into it.

mentalinc




CPU: Intel 3770k| RAM: F3-2400C10D-16GTX G.Skill Trident X |MB:  Gigabyte Z77X-UD5H-WB | GFX: GV-N660OC-2GD gv-n660oc-2gd GeForce GTX 660 | Monitor: Qnix 27" 2560x1440

 

 


night
21 posts

Geek


  #164247 13-Sep-2008 17:19
Send private message

Hey Mentalinc!

The tvguide.xml downloads onto my C drive root, rather than into the TVServer folder, and also when I try to create the scheduler:

C:\Program Files\Team MediaPortal\MediaPortal TV Server>freeviewNZ-EPG-GBPVR.exe
 -task 11:00:00 mediaportalTVServer.bat
Checking for newer version
You already have the latest version
Finding install paths
System.NullReferenceException: Object reference not set to an instance of an object.
   at freeviewNZ_EPG_GBPVR.Program.findInstallPaths()
-task
11:00:00
mediaportalTVServer.bat
http://epg.pvr.geek.nz/epg/listings-freeview.xml.gz
The task will be created under current logged-on user name ("ENVY\night").
Please enter the run as password for ENVY\night: *******

ERROR: The parameter is incorrect.


Also tried 09:00:00 as per the guide, but I get the same error

mentalinc

2044 posts

Uber Geek

Trusted
Subscriber

  #164259 13-Sep-2008 18:24
Send private message

At a guess you are using Vista with a non-admin account, and there are issues reading the registry or, you dont have any of the supported players installed (gbpvr,mediaportal,dvbviewer)

also can you check if
SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\MediaPortal TV Server\InstallPath
exists in your registry (since you say you are using mediaportal tv server)

You could also try   -dvbviewer "C:\Program Files\Team MediaPortal\MediaPortal TV Server\tvguide.xml"

which will do what you are needing.

mentalinc





CPU: Intel 3770k| RAM: F3-2400C10D-16GTX G.Skill Trident X |MB:  Gigabyte Z77X-UD5H-WB | GFX: GV-N660OC-2GD gv-n660oc-2gd GeForce GTX 660 | Monitor: Qnix 27" 2560x1440

 

 


night
21 posts

Geek


  #164270 13-Sep-2008 19:52
Send private message

Sorry!
Windows XP SP2, as admin :)
The registry entry is there as "C:\Program Files\Team MediaPortal\MediaPortal"

C:\Program Files\Team MediaPortal\MediaPortal TV Server>freeviewNZ-EPG-GBPVR.exe -dvbviewer "C:\Program Files\Team MediaPortal\MediaPortal TV Server\tvguide.xml"
Checking for newer version
You already have the latest version
Finding install paths
System.NullReferenceException: Object reference not set to an instance of an object.
   at freeviewNZ_EPG_GBPVR.Program.findInstallPaths()
-dvbviewer
C:\Program Files\Team MediaPortal\MediaPortal TV Server\tvguide.xml
http://epg.pvr.geek.nz/epg/listings-freeview.xml.gz
The path is not of a legal form.
Operation complete


Not sure what -dvbviewer is meant to do, but yeah.. doesn't work? I don't use that program :P

mentalinc

2044 posts

Uber Geek

Trusted
Subscriber

  #164276 13-Sep-2008 20:47
Send private message

Ok I think you are trying to setup mediaportal TV server when you only have mediaportal installed

You need to edit scheduletask.bat
right click on the file select edit

And change it to as shown below.

@echo off
freeviewNZ-EPG-GBPVR.exe -task 09:00:00 mediaportal.bat
pause

now try and schedule the task, it should work much better now.

If you have tv server installed (dont think you do) then ill have to keep thinking.




CPU: Intel 3770k| RAM: F3-2400C10D-16GTX G.Skill Trident X |MB:  Gigabyte Z77X-UD5H-WB | GFX: GV-N660OC-2GD gv-n660oc-2gd GeForce GTX 660 | Monitor: Qnix 27" 2560x1440

 

 


night
21 posts

Geek


  #164278 13-Sep-2008 21:07
Send private message

Says parameter is incorrect
I have MediaPortalTVServer installed

mentalinc

2044 posts

Uber Geek

Trusted
Subscriber

  #164285 13-Sep-2008 22:30
Send private message

I suggest you click start -> run and paste Taskschd.msc press ok and remove any tasks there that are related to epgmediaportal as they could be causing issues.

Don't try to setup the task until the .bat can run without any problems.

What happens when you run "mediaportalTvServer.bat"? (running it from the command prompt will let you see any errors easier).

If there are no issues and it detects mediaportal tv server as being installed (will say so on screen), then try setup the task again.

It seems there is some issue trying to find where tv server is installed.

mentalinc




CPU: Intel 3770k| RAM: F3-2400C10D-16GTX G.Skill Trident X |MB:  Gigabyte Z77X-UD5H-WB | GFX: GV-N660OC-2GD gv-n660oc-2gd GeForce GTX 660 | Monitor: Qnix 27" 2560x1440

 

 


night
21 posts

Geek


  #164293 14-Sep-2008 01:28
Send private message

Taskschd.msc doesn't exist apparently (I'm on XP)
Went into Scheduled Tasks via the start menu, and there's no MediaPortal stuff

C:\Program Files\Team MediaPortal\MediaPortal TV Server>mediaportalTvServer.bat
Checking for newer version
You already have the latest version
Finding install paths
System.NullReferenceException: Object reference not set to an instance of an object
   at freeviewNZ_EPG_GBPVR.Program.findInstallPaths()
-mediaportalTVServer
http://epg.pvr.geek.nz/epg/listings-freeview.xml.gz
download location: \tvguide.xml
C:\\listings-freeview.xml.gz
Operation complete


Dumps tvguide.xml into C root again >_< lol

MediaPortalTvServer.bat (the directory location is correct)
@echo off
"C:\Program Files\Team MediaPortal\MediaPortal TV Server\freeviewNZ-EPG-GBPVR.exe" -mediaportalTVServer


And this is when I run "freeviewNZ-EPG-GBPVR.exe" by itself
http://www.iforce.co.nz/i/04c749e7fb889bfb324ae05a9755c84a.JPG


The plug itself works. It shows in my configuration screens, and the TV Guide appears in MediaPortal - it's just this scheduled task and the .xml file being put into my C root

1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | 10 | 11 | 12 | 13 | 14 | 15 | 16 | 17 | 18 | 19 | 20 | ... | 22
View this topic in a long page with up to 500 replies per page Create new topic





News »

Nanoleaf enhances lighting line with launch of Triangles and Mini Triangles
Posted 17-Oct-2020 20:18


Synology unveils DS16211+
Posted 17-Oct-2020 20:12


Ingram Micro introduces FootfallCam to New Zealand channel
Posted 17-Oct-2020 20:06


Dropbox adopts Virtual First working policy
Posted 17-Oct-2020 19:47


OPPO announces Reno4 Series 5G line-up in NZ
Posted 16-Oct-2020 08:52


Microsoft Highway to a Hundred expands to Asia Pacific
Posted 14-Oct-2020 09:34


Spark turns on 5G in Auckland
Posted 14-Oct-2020 09:29


AMD Launches AMD Ryzen 5000 Series Desktop Processors
Posted 9-Oct-2020 10:13


Teletrac Navman launches integrated multi-camera solution for transport and logistics industry
Posted 8-Oct-2020 10:57


Farmside hits 10,000 RBI customers
Posted 7-Oct-2020 15:32


NordVPN starts deploying colocated servers
Posted 7-Oct-2020 09:00


Google introduces Nest Wifi routers in New Zealand
Posted 7-Oct-2020 05:00


Orcon to bundle Google Nest Wifi router with new accounts
Posted 7-Oct-2020 05:00


Epay and Centrapay partner to create digital gift cards
Posted 2-Oct-2020 17:34


Inseego launches 5G MiFi M2000 mobile hotspot
Posted 2-Oct-2020 14:53









Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.


Support Geekzone »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.