Geekzone: technology news, blogs, forums
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.

7346 posts

Uber Geek
+1 received by user: 3446


Topic # 225541 23-Nov-2017 13:41
Send private message



I have been trying to optimise our TV viewing options since dumping Sky. It should have been relatively straightforward but somehow I keep getting tangled up in ridiculous things that shouldn’t be problems at all.


The latest is the HDMI display on the pc. I made the huge mistake of updating the drivers on this and since then I haven’t been able to get it to work correctly. The display is an AMD Radeon HDMI card and yes, I probably need to replace it with something that works, but I would like understand more about the issue if possible.


I use an HDMI switch to move between different inputs. This has worked well for years. The switch is programmed into my Harmony remote, which automatically selects the correct input for the device I want, as well as other things. Current devices are an Android box, the TV UHF receiver, a satellite box, a DVR and the PC. There also used to be a Sky decoder, now removed and replaced by the Android box.


When I disassembled things to swap the boxes and make some other changes, the HDMI switch and device displays worked fine. In fact, the Radeon card in the PC has worked perfectly for years. I temporarily connected the PC to a different display (720p Panasonic TV) to do some updates. When I put it back, I could not get my main Sony TV to display the PC on the full screen area. Instead there was a box with black borders. I never had this before.


After some fiddling, I was unable to correct the display so I updated the Radeon drivers from the AMD site. This fixed the problem and the display now fills the screen area correctly.


Unfortunately, it also stuffed my HDMI switch. To be more precise, the switch, which is ‘smart’, no longer detects the display from the PC and skips over it. The switch is designed to ignore inputs with no signal so it only selects from active ones. What happens is that the display from the PC is fine when the PC boots, but if I then select another input, I can’t get back to the PC display. If I use the remote to operate the HDMI switch, it skips past the PC. I can override that by manually operating the switch, and then it works fine. I can also get the display back by briefly replugging the HDMI cable which I guess reinitialises something.


So the display is still actually there but some signal is missing which informs the switch of that fact. I rolled back the drivers, then uninstalled them completely, along with all the Catalyst crap that came with them, and let the computer just reinstall the basic card drivers that were there in the first place, but I still have the problem. If I switch the display to a different device, the PC HDMI card is no longer seen when I try to switch back.


When this happens, nothing I can do seems to fix it other than what I have already mentioned. Replugging the cable works. So does manually setting the switch. But nothing I can do from the remote or the keyboard makes any difference.


Is there a solution to this? I have searched for similar problems and there are lots of people complaining about black screens with Radeon cards and AMD seems fairly uninterested. I feel there has to be some simple fix for this because it worked perfectly before and nothing has changed except some software. Surely there is some way of getting back to where I was? If anyone knows, I would be grateful to hear it.



I reject your reality and substitute my own. - Adam Savage

Create new topic
2 posts

Wannabe Geek

  Reply # 1906533 23-Nov-2017 15:53
Send private message

No expert but my guess would be some sort of HDMI/HDCP handshake failure between your video card and your splitter. Since you have busted your display drivers back to basic I would look to blame anything else that was changed in your teardown. Could be as simple as a damaged hdmi cable. Try disconnecting everything from the splitter other than the PC (and one other device so you can switch!:)) with new/different HDMI cables (and splitter port)  from PC to Splitter and see if that changes anything.....good luck





7346 posts

Uber Geek
+1 received by user: 3446


  Reply # 1907198 24-Nov-2017 16:29
Send private message

This must rank fairly high on the scale of tail-chasing computer idiocies. My IR controlled HDMI switch, which has always worked perfectly, suddenly won’t switch back to the streaming pc after being switched from it. The switch doesn’t seem to see that the HDMI card is functioning, though it is, so it skips over that input. Very annoying, especially since it worked perfectly before I did some updates.


So I decided it must be the card’s fault. Maybe it still is, but I have now discovered something new.


I swapped the HDMI card with a different brand and got exactly the same result! So WTF is going on here?


The switch is programmed into my Harmony. So I dug out the original switch remote and tried that. Suddenly the pc works, though there are issues switching to other inputs. But the original remote is flimsy and hasn’t been used for a long time.


I took a look at the Harmony set-up. I had to manually create it because the switch isn’t in the database. It is extremely simple, just five inputs. These are included in the activities that need them. But I can also trigger them manually by choosing the switch device instead of an activity. So I tried that. It works!


So the switch doesn’t switch to the pc if I try to do it via an activity, but it does if I do it via the device setting. Weird. It also works if I get up, walk over to it, and switch it manually. It just doesn’t want to do it from the Harmony activity setting. This would be amusing if it wasn’t the 10,000th stupid problem I have run into while trying to set all this up.


I guess the next thing is to program the Harmony again and see if that makes a difference. First, though, I am going to go have a drink. I need it.



I reject your reality and substitute my own. - Adam Savage

7346 posts

Uber Geek
+1 received by user: 3446


  Reply # 1907676 25-Nov-2017 14:02
One person supports this post
Send private message

I tend to be critical of perceived stupidities and things that don’t work the way I think they should. When it turns out that I am the one who has been led up the garden path (yet again), it is easy to succumb to the temptation to slink away quietly and never mention it again. But I feel compelled to apply the same standard to myself that I bash others with, so here goes:


When I couldn’t switch to the pc, it seemed logical to blame the Radeon card, which has a bad reputation, for a handshaking issue. Especially since I had already had problems with it. So I focussed on that, trying different things and finally swapping the card for a different brand.


When none of this helped, I thought it must be something with the HDMI switch, especially since it worked when I switched it manually. So I focussed on that.


When I couldn’t find anything there, it finally dawned on me to check the Harmony set-up. I thought there might be some kind of timing issue between commands. Imagine my astonishment when I discovered that the command to switch the HDMI input to the pc was completely missing! The device was correctly installed and present, but no command to switch. Nothing. It was just sitting there, not doing a thing.


I have no idea at all how this is possible. Somehow I must have managed to accidentally delete the command while updating the set-up. Instead of doing the obvious and checking that first, I went for the complicated and assumed it had something to do with EDID handshaking.


This whole damned streaming project has been like that. Apart from having myself fitted for a giant dunce cap, I guess the moral is that if something doesn’t work, try the easy solution before thinking of the complicated one. In other words, check those cables first. I also had that one.



I reject your reality and substitute my own. - Adam Savage

1366 posts

Uber Geek
+1 received by user: 345

  Reply # 1907738 25-Nov-2017 19:28
One person supports this post
Send private message

Sounds like classic AMD under scan over HDMI.


You should be able to fix this in the catalyst control center or whatever the new one is..


instructions here




If you're still stuck after that, I've had success with the registry setting in the answer below, it should be your last resort.




Good luck.

7346 posts

Uber Geek
+1 received by user: 3446


  Reply # 1907808 26-Nov-2017 00:16
Send private message

The above would be excellent advice if the problem was actually what I initially thought it was. Instead, it seems I shot myself in the foot yet again. I have to say I have an extraordinary talent for doing this kind of thing. Anyway, the problem is now solved and I am glad of that, but I sure did put myself to a lot of unnecessary trouble getting there.



I reject your reality and substitute my own. - Adam Savage

Create new topic

Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:

Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:

Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:

News »

N4L helping TAKA Trust bridge the digital divide for Lower Hutt students
Posted 18-Jun-2018 13:08

Winners Announced for 2018 CIO Awards
Posted 18-Jun-2018 13:03

Logitech Rally sets new standard for USB-connected video conference cameras
Posted 18-Jun-2018 09:27

Russell Stanners steps down as Vodafone NZ CEO
Posted 12-Jun-2018 09:13

Intergen recognised as 2018 Microsoft Country Partner of the Year for New Zealand
Posted 12-Jun-2018 08:00

Finalists Announced For Microsoft NZ Partner Awards
Posted 6-Jun-2018 15:12

Vocus Group and Vodafone announce joint venture to accelerate fibre innovation
Posted 5-Jun-2018 10:52 to launch Kogan Mobile in New Zealand
Posted 4-Jun-2018 14:34

Enable doubles fibre broadband speeds for its most popular wholesale service in Christchurch
Posted 2-Jun-2018 20:07

All or Nothing: New Zealand All Blacks arrives on Amazon Prime Video
Posted 2-Jun-2018 16:21

Innovation Grant, High Tech Awards and new USA office for Kiwi tech company SwipedOn
Posted 1-Jun-2018 20:54

Commerce Commission warns Apple for misleading consumers about their rights
Posted 30-May-2018 13:15

IBM leads Call for Code to use cloud, data, AI, blockchain for natural disaster relief
Posted 25-May-2018 14:12

New FUJIFILM X-T100 aims to do better job than smartphones
Posted 24-May-2018 20:17

Stuff takes 100% ownership of Stuff Fibre
Posted 24-May-2018 19:41

Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.

Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.