Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




22 posts

Geek


Topic # 25523 24-Aug-2008 14:08
Send private message

I'm new to HTPC, my build is an AMD/4GB/500GB/Vista Home Premium with SP1/ASUS M3A78-EMH HDMI/additional nVidia 8400GS (using the SVideo output)/HVR2200 dual DVB-T Hybrid/MediaPortal RC2/PowerDVD7 Ultra/all the Microsoft updates/driver updates for motherboard & cards/DivX/no other codecs. The current TV is an older 4:3 using SVideo.

I've followed cranznz guide to installing Freeview and MediaPortal, and I've nosed around other forums here and there, but I've got a couple of problems and if anyone could help me that would be appreciated.

1. DirectShow Filter Control isn't listed in the left hand pane (between Remote and Weather) when Configuring MediaPortal, so I can't see the VMR9 or EMR option. I suspect Hardware acceleration isn't running because the CPU is 70-80% and it feels sluggish and displays blocky pixels when changing channels. I've been into the settings of Power DVD7 and this box is ticked Enable Hardware Acceleration (nVidia PureVideo). The nVidia Control Centre doesn't say anything more about PureVideo. In the Television section of Configuring MediaPortal I've selected the same options as crannz. Why can't I see the DirectShow Filter, where do I turn on Hardware Acceleration?

2. I tuned the Digital channels on both of the HVR2200 tuners, as cranznz said, and then manually added 2 Analogue channels for Prime (775.25) and our Sky Decoder (607.25) which the aerial signal goes through before entering the HVR2200. I didn't scan for Analogue channels because I don't want the other UHF channels. I've mapped Prime & Sky to both Analogue tuners on the HVR2200. Preview any channels works fine. However, when I start MediaPortal and choose a channel from the AllChannels group, if I choose an Analogue channel first and then change to a Digital channel I get the error "Unable to start timeshifting - unknown error occurred" but I can watch either Analogue channel. And if I choose a Digital channel first and then change to an Analogue channel I get the same error "Unable to start timeshifting - unknown error occurred" but I can watch any of the Digital channels. Am I doing something wrong in the channel mappings? Is there some trick when changing between the HVR2200 tuners or between hybrid modes?

View this topic in a long page with up to 500 replies per page Create new topic
 1 | 2
4025 posts

Uber Geek
+1 received by user: 1076

Trusted

  Reply # 159331 24-Aug-2008 15:00
Send private message

Are you running the latest Mediaportal SVN (ie released on friday)?
This fixed this can't start timeshifting issue i had with my HVR-2200. (identical to yours)

2720 posts

Uber Geek
+1 received by user: 95


  Reply # 159339 24-Aug-2008 15:31
Send private message

(1) Open mediaportal configuration, enable advanced options, you will then have access to the directshow filter settings and the PDVD settings.

(2) Try enabling hybrid mode, the instructions are in mediaportal tvserver configuration wiki, the link is via the main mediaportal homepage.




HTPC: Intel i3-2100 / 12GB RAM / AMD HD7750 / 480 GB SSD / 58TB Storage / MediaPortal / MadVR / Win10
AVR: Pioneer Elite SC-LX87 220W 9.2 Ch AVR
Speakers: Wharfedale Jade 7 Fronts / Jade 2c Center / Jade 5 Rears
Subs: iNuke 3000dsp 3000W proamp with 4x 15" JBL Sealed Subs
Display: Samsung 60" UA60H6400 LCD TV
Accessories: Gefen HDMI Detective with splitter


 
 
 
 


3571 posts

Uber Geek
+1 received by user: 679

Lifetime subscriber

  Reply # 159351 24-Aug-2008 16:50
Send private message

kiwijunglist: (1) Open mediaportal configuration, enable advanced options, you will then have access to the directshow filter settings and the PDVD setting.....


1.     Switch to expert mode in mediaportal configuration. It is at the top of the mediaportal configuration window (just below the minimise/maximise buttons) and all will be revealed.




Areas of Geek interest: Home Theatre, HTPC, Android Tablets & Phones, iProducts.



22 posts

Geek


Reply # 159410 24-Aug-2008 21:40
Send private message

Ok, thanks everyone. I got the latest SVN, setup Hybrid groups as per the wiki, found the expert mode, installed PowerDVD8, and tried both VMR and EVR. All of the issues I requested help with are resolved. It's still dropping frames on TV3 with CPU of 70-80% and slow to change channels. Is TV3 harder because of the 1080i? Are there preferred deinterlace options?

4025 posts

Uber Geek
+1 received by user: 1076

Trusted

  Reply # 159413 24-Aug-2008 21:51
Send private message

Hardware acceleration isn't working if you're getting 70% CPU usage on TV3, make sure you've enabled it and that you have no conflicting post processing filters, eg directvobsub.



22 posts

Geek


  Reply # 159527 25-Aug-2008 11:50
Send private message

Where do I enable the hardware acceleration on the 8400GS? It isn't an obvious option in the nVidia control panel, nor in PowerDVD or MediaPortal. Is there specific software to install nVidia PureVideo other than the latest drivers which I already have?

2720 posts

Uber Geek
+1 received by user: 95


  Reply # 159530 25-Aug-2008 12:00
Send private message

From Memory it is something like
Mediaportal Configuration -> Direct show Filter Settings -> PowerDVD8 Settings -> Hardware deinterlacing = On

If your in Vista you must use EVR render if your in XP you must use VRM renderer
(These options from memory are also under directshow filter settings)

NB - If you have other codecs or filters installed they may be getting in the way of PDVD8 using hardware acceleration.  Also you should have PDVD8 set as the H264 codec under the television settings in mediaportal configuration




HTPC: Intel i3-2100 / 12GB RAM / AMD HD7750 / 480 GB SSD / 58TB Storage / MediaPortal / MadVR / Win10
AVR: Pioneer Elite SC-LX87 220W 9.2 Ch AVR
Speakers: Wharfedale Jade 7 Fronts / Jade 2c Center / Jade 5 Rears
Subs: iNuke 3000dsp 3000W proamp with 4x 15" JBL Sealed Subs
Display: Samsung 60" UA60H6400 LCD TV
Accessories: Gefen HDMI Detective with splitter


4025 posts

Uber Geek
+1 received by user: 1076

Trusted

  Reply # 159644 25-Aug-2008 17:14
Send private message

Direct Show filter settings doesn't show up on my main computer when acting as a TV client, although many filters are installed including PDVD8 full. No idea what triggers it to show up.
Though hardware acceleration appears to be working.

1089 posts

Uber Geek
+1 received by user: 182


  Reply # 159753 26-Aug-2008 00:34
Send private message

At the top right of mp config switch to expert mode :)




78 posts

Master Geek


  Reply # 160005 26-Aug-2008 22:47
Send private message

gyrogearloose: I
I've followed cranznz guide to installing Freeview and MediaPortal, and I've nosed around other forums here and there, but I've got a couple of problems and if anyone could help me that would be appreciated.


Any chance of pointing me to this guide for MediaPortal ??

Cheers



22 posts

Geek


  Reply # 160077 27-Aug-2008 10:18
Send private message

The cranznz guide is linked a few rows down in this thread: http://www.geekzone.co.nz/forums.asp?ForumId=83&TopicId=19328

In my opinion, it omits several things that are quite relevant:
- if using an HVR2200, create 2 groups each containing an Analogue & Digital tuner (tuners 1 & 3, 2 & 4)
- switch to expert mode, otherwise you don't see the Direct Show filter Control option
- in the Configure MediaPortal plugins section, double click the Cyberlink PDVD8 H264 codec and then tick the box to enable it
- Then go back to the Direct Show Filter Control

2720 posts

Uber Geek
+1 received by user: 95


  Reply # 160085 27-Aug-2008 10:52
Send private message

gyrogearloose: The cranznz guide is linked a few rows down in this thread: http://www.geekzone.co.nz/forums.asp?ForumId=83&TopicId=19328

In my opinion, it omits several things that are quite relevant:
- if using an HVR2200, create 2 groups each containing an Analogue & Digital tuner (tuners 1 & 3, 2 & 4)
- switch to expert mode, otherwise you don't see the Direct Show filter Control option
- in the Configure MediaPortal plugins section, double click the Cyberlink PDVD8 H264 codec and then tick the box to enable it
- Then go back to the Direct Show Filter Control


Good tips, cranz omitted the above steps because they didn't exist in mediaportal RC1




HTPC: Intel i3-2100 / 12GB RAM / AMD HD7750 / 480 GB SSD / 58TB Storage / MediaPortal / MadVR / Win10
AVR: Pioneer Elite SC-LX87 220W 9.2 Ch AVR
Speakers: Wharfedale Jade 7 Fronts / Jade 2c Center / Jade 5 Rears
Subs: iNuke 3000dsp 3000W proamp with 4x 15" JBL Sealed Subs
Display: Samsung 60" UA60H6400 LCD TV
Accessories: Gefen HDMI Detective with splitter


78 posts

Master Geek


  Reply # 160232 27-Aug-2008 17:55
Send private message

gyrogearloose: The cranznz guide is linked a few rows down in this thread: http://www.geekzone.co.nz/forums.asp?ForumId=83&TopicId=19328

In my opinion, it omits several things that are quite relevant:
- if using an HVR2200, create 2 groups each containing an Analogue & Digital tuner (tuners 1 & 3, 2 & 4)
- switch to expert mode, otherwise you don't see the Direct Show filter Control option
- in the Configure MediaPortal plugins section, double click the Cyberlink PDVD8 H264 codec and then tick the box to enable it
- Then go back to the Direct Show Filter Control


Hi ok can you explain how I do what your suggesting, also how do I get into Media Portal in expert mode ??

Cheers

4025 posts

Uber Geek
+1 received by user: 1076

Trusted

  Reply # 160238 27-Aug-2008 18:16
Send private message

expert mode button top right corner of config.

81 posts

Master Geek


  Reply # 163161 8-Sep-2008 20:43
Send private message

gyrogearloose: The cranznz guide is linked a few rows down in this thread: http://www.geekzone.co.nz/forums.asp?ForumId=83&TopicId=19328

In my opinion, it omits several things that are quite relevant:
- if using an HVR2200, create 2 groups each containing an Analogue & Digital tuner (tuners 1 & 3, 2 & 4)
- switch to expert mode, otherwise you don't see the Direct Show filter Control option
- in the Configure MediaPortal plugins section, double click the Cyberlink PDVD8 H264 codec and then tick the box to enable it
- Then go back to the Direct Show Filter Control


Gyro, I'm trying to get hardware acceleration going with my HVR2200 and have followed the cranznz guide.

Can you explain what you mean by:
"in the Configure MediaPortal plugins section, double click the Cyberlink PDVD8 H264 codec and then tick the box to enable it".

How do I get to the Configure MediaPortal plugins section?

Is this Configuration -> Plugins?
I see My Emulators, My TV, My Radio etc but I don't se any PDVD8 codec plugin listed in there. Should I?

-Matt

 1 | 2
View this topic in a long page with up to 500 replies per page Create new topic



Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.