Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.


20 posts

Geek


Topic # 26826 5-Oct-2008 09:51
Send private message


Hi,

I am having real issues trying to get Media Portal to schedule record from S3 sleep i.e. set a scheduled recording and have the computer wakeup from S3 sleep and start recording.

I have had Vista Media Centre doing this without ant trouble at all, but probably like a number of other people, I am now looking at Media Portal with the issues around Freeview not working on Vista Media Centre - very frustrating!!!

I have read other Forums and set all the power options within TVServer, but it still does not work. I would have also thought the settings within Windows would have taken care of this - but I guess Media Portal is not interfaced with Windows like Media Centre?

My machine details are as follows:

Intel Quad Core Q6600 2.4G *MB
Coolermaster CPU Cooler
ASUS P5K-E WiFi Motherboard
4GB Memory
Gigabyte RX3855 Radeon HD video card
Hauppauge WinTV PVR500MCE Dual Tuner Card
Hauppauge Nove 500-T DVB-T Dual Tuner Card

Oh, I'm also running Media Centre at the same time as Media Portal.

Any help would be appreciated.

Thanks

Graham

View this topic in a long page with up to 500 replies per page Create new topic
 1 | 2
722 posts

Ultimate Geek


  Reply # 174723 30-Oct-2008 20:03
Send private message

Missed this one first time around. Have got it sorted???

You could try the MST Standby Tool It has an option TAB for MP. It might work.




Silverstone LC14 HTPC Case/Intel E4600 CPU/GA-EP35-DS3 MOBO/Asus EN9500GT graphics/2GB RAM/total 2TB HDD space/HVR-2200 & 2X 150MCE tuner cards/LG GGC-H20L BD Drive/MCE2005/Mediaportal/TVServer 1.1.0Final/LG 55"3D LED-TV/Denon AVR-1803 receiver/X1 projector

98 posts

Master Geek


  Reply # 174780 31-Oct-2008 08:13
Send private message

can you be more specific. What doesn't work exactly? the recording feature of mediaportal or your computer doesn't wake from sleep?



20 posts

Geek


  Reply # 174849 31-Oct-2008 12:33
Send private message

I'm unable to get the machine to go to sleep in the first place with the MP PowerScheduler and if I force it into sleep, it will not wake up and record.

I notice on a few forums that people have got this working in MP i.e. putting the machine to S3 sleep after no activity for a set period and then waking the machine up to record and then later putting it back to S3 sleep again after finishing the recording session. Unfortunately nobody seems to put details about HOW they got it working!!!!

I would be happier to have the Power Options setting activated in Microsoft because we use the machine for other things outside of MP e.g. the internet. This worked fine with Media Centre. Does it not recognise whether all activities are running on the PC including MP?

It would be fantastic to get a simple step by step instruction on getting S3 sleep to work with MP, including how to wake the machine up using the power option on the remote control - I understand from reading forums that this is only possible with an IR plugged into a USB port which is powered in sleep mode?

Regards

Graham


424 posts

Ultimate Geek
+1 received by user: 66


  Reply # 174871 31-Oct-2008 14:06
Send private message

I have this working in RC2 (yet to update to RC3) and afraid Im at work so cant remember EXACT settings...but....

One of the traps I remember falling into was that by default (and actually how I leave it) is that the plugin is set to only allow the PC to sleep when the client is at the "home" page.  This is obviously to stop it going to sleep when you're watching TV, listing to music etc etc.

When I get home, I'll run through all the options and settings I have set up for you.  So watch this space ;-)

424 posts

Ultimate Geek
+1 received by user: 66


  Reply # 175026 1-Nov-2008 09:22
Send private message

As promised, here's how I have the Power Scheduler plugins setup in Media Portal RC2.

TV Server

Plugins:
Power Scheduler: Enabled

Under the Power Scheduler plugin configuration:
General Tab:
Shutdown server after being idle 5 minutes - enabled and configured for 5 mins obviously
Wakeup server for various wakeup events - enabled
Shutdown mode - Suspend
Allow only standby between - 0 and 24

Advanced Tab
Forced shutdown - disabled
Enable Extensive logging - disabled
Pre-wake up time in seconds - 120
Pre-no shutdown time in seconds - 300
Check interval in seconds - 60
Re-initialize service on wakeup - disabled
Run command before standby/after wakeup - nothing/empty

EPG tab
Everything is disabled as I use XmlTV and mentalinc's programme to download the EPG data

Processes tab
Processes which can prevent standby - Setup TV, Configuration

MediaPortal Client config
Under Plugins -> Process Plugins
Ensure "PowerScheduler client plugin" is enabled
Config settings for plugin
General Tab
Shutdown client after being idle 5 minutes - disabled*
Only allow standby when on home window - enabled
Shutdown mode - Suspend

Advanced Tab
Forced shutdown - disabled
Enable extensive logging - disabled


Hope that helps get your Power Scheduler plugin working as expected.  If you find the HTPC is not going to sleep it might be that something else is keeping it awake.  I had a problem with my wireless mouse keeping my other PC alive so if you have something like that on your HTPC it could be worth checking out. 

On my HTPC I do not have Windows set to start a screen saver or to go to sleep after a period of time.  I let Media Portal (and specifically the Power Scheduler plugin) control all that for me.  The PC wakes up when it's expected to, does its recording and then goes back to sleep.  And if you're using Mentalinc's EPG downloader with a scheduled job make sure you set that job to wake the PC up too.  I have mine running at 2:00amish and the PC wakes up for that, does it's thing and goes back to sleep a few minutes later.


* For the "Shutdown client after being idle for 5 minutes" option I thought this was enabled.  I'm sure I had it enabled in an earlier release of Media Portal.  Perhaps not.  Even though this is disabled in my config the HTPC still goes to sleep when expected.  That is when nothing is being watched or played and the TV Server is not recording anything.



20 posts

Geek


  Reply # 175104 1-Nov-2008 16:30
Send private message

Hi NZKC,

First of all, thanks so much for the reply and all the detail you have included - much appreciated.

I got this all working OK, BUT, the machine goes to sleep when I'm using it for other purposes e.g. surfing the internet. I'm guessing therefore that it's specifically for Media Portal.

I tried disabling the shutdown in the Powerscheduler but enabling the Windows Power options along with the wakeup option in Media Portal and managed to get the machine to sleep, but it didn't wakeup to a scheduled TV program.

Any other thoughts?

Regards

Graham

98 posts

Master Geek


  Reply # 175172 1-Nov-2008 22:11
Send private message

gperkinson: Hi NZKC,

First of all, thanks so much for the reply and all the detail you have included - much appreciated.

I got this all working OK, BUT, the machine goes to sleep when I'm using it for other purposes e.g. surfing the internet. I'm guessing therefore that it's specifically for Media Portal.

I tried disabling the shutdown in the Powerscheduler but enabling the Windows Power options along with the wakeup option in Media Portal and managed to get the machine to sleep, but it didn't wakeup to a scheduled TV program.

Any other thoughts?

Regards

Graham


In the proceses tab you can specify which processes prevent the computer from going to sleep. so for example you can add iexplore.exe to the list if you don't want the computer to sleep while  Internet Explorer was running.

424 posts

Ultimate Geek
+1 received by user: 66


  Reply # 175192 2-Nov-2008 01:36
Send private message

I've no idea if the following will work.  But it has to be worth a go....

Change the configuration of the TV Server Power Scheduler plugin to the following:

General Tab
Shutdown mode - Stay On

Leave all other options as I described above.

What I'm hoping will happen is that the plugin will be active, but effectively do nothing in terms of putting the PC to sleep.  Windows can initiate the S3 sleep (through the screensaver presumably) but then the Power Scheduler plugin will wake the PC when a recording is scheduled.

P.S. I updated to RC3 today too.  Still using Power Scheduler as I described in the post earlier.



20 posts

Geek


  Reply # 175351 2-Nov-2008 22:38
Send private message

Hi,

That didn't seem to make any difference unfortunately. From all the testing I have done tonight with different settings, my conclusion is that they work completely independantly i.e. Windows Power Options don't seem to see Media Portal scheduler and the Media Portal Powerscheduler appears to only see just Media Portal e.g. it doesn't recognise I'm on the internet.

Because the machine is being used for other things, I'm left with the conclusion that I need to find some way of Windows Power Manager recognising Media Portal like it does Media Centre - the S3 process was perfect with Windows Media Centre.

Any help from anybody would be appreciated as this is the only thing now stopping me from moving to Media Portal.

PS: What do you think of Release 3? I also found it was heaps more stable as well!!

Cheers

Graham 




20 posts

Geek


  Reply # 176022 5-Nov-2008 09:55
Send private message

Hi,

I have noticed in the Powerscheduler sleep Processes tab there is an option to prevent standby when certain processes are running. I'm thinking this should solve my problem of wanting to use other software e.g. internet explorer and the computer going to sleep.

I'm now having issues however with Powerscheduler not doing anything at all i.e. going to sleep and waking the machine up from sleep to record. I cannot even send the machine to sleep from the Main Menu! Also, by forcing the machine to sleep and leaving it on the main screen, it does not wakeup to record.

I have seen posts about setting S3 sleep in the bios - could this be my problem? (have not tried it yet as I felt like throwing my machine out the window!!)

What am I missing here?
 
Also, do I need to deactivate the Windows Power Option for sleeping? I have done this and it has made no difference, but it would be good to understand what I need to do in this setting in relation to affecting Powerscheduler.

I have also activated Powerscheduler in the TV Server and Client and set the settings exactly the same.

I would really appreciate any help with this as it's getting very frustrating!!

On the plus side, we are loving the HD quality and stability since going to Version 3!!

Regards

Graham



20 posts

Geek


  Reply # 176251 6-Nov-2008 08:49
Send private message

Hi Everybody,

Well, after another 2 hours of fluffing around trying different options, I finally got up off the couch, made a cup of tea, sat back down on the couch and thought to myself what would be stopping the Powerscheduler from working i.e. sleeping at all. While just at the point of throwing my computer out of the window, my eyes were drawn to the toolbar and my anti-virus icon spinning around.

If you think about it, how many issues have you come across where the anti-virus was the problem - I should have thought about this before!!

Anyway, I disabled the anti-virus, walked away from the machine and it eventually went to sleep. So did I at that point and I decided to schedule a recording during the night to see if it would wake, record and then sleep again. The machine was asleep when I woke up this morning and the the recording worked!!

I also tested adding Explorer to the processes tab and when I used explorer the machine did not sleep, so that certainly works - thanks for the comment that someone added to my forum - appreciated :-)

I need to play with the Powerscheduler a bit more to fully test it, but can anybody drop in my forum some bullet points on any behaviour or settings I should be aware of please.

I also do not want to shutdown my anti-virus totally, but instead just resolve the sleeping problem. I'm running Avast. Does anybody know the correct setting to allow sleep through MediaPortal? I notice an exclusions option where you can select software Avast will not scan, but I'm not sure this will solve my issue.

Any help would be appreciated.

Regards

Graham



20 posts

Geek


  Reply # 176538 7-Nov-2008 09:33
Send private message

Hello All,

After some more stuffing around, I tried leaving the anti-virus on and just opening up MP i.e. shutting it down and opening it up again. It went to sleep!!

What I have discovered is that when I have finished using MP and go back to the Home Page, the TV is still running minimised (in the bottom left hand corner) This must mean that the MP is still active and therefore Powerscheduler is unable to go into sleep.

By the way, I'm still having issues forcing the machine to sleep using the MP main menu. Anybody else having these issues?

Regards

Graham

424 posts

Ultimate Geek
+1 received by user: 66


  Reply # 176553 7-Nov-2008 10:20
Send private message

gperkinson: After some more stuffing around, I tried leaving the anti-virus on and just opening up MP i.e. shutting it down and opening it up again. It went to sleep!!

I dont fully understand what you mean.  And did you want it to go to sleep or not?  Was that good or bad?

gperkinson: What I have discovered is that when I have finished using MP and go back to the Home Page, the TV is still running minimised (in the bottom left hand corner) This must mean that the MP is still active and therefore Powerscheduler is unable to go into sleep.

That is my understanding too.  I use the option in MyTV to turn the TV off and then drop back to the "Home" page.  Within 5 minutes the PC (and TV) will go to sleep.

gperkinson:
By the way, I'm still having issues forcing the machine to sleep using the MP main menu. Anybody else having these issues?

As I said above I let MP send the PC to sleep.  I don't bother with the menus to send the PC to sleep - I do sometimes use them to close MP or restart the machine but this is fairly rare these days.  You may find that it is Power Scheduler preventing the use of this sleep option.  I am guessing here though.

If you have quite a short "timeout" before the Power Scheduler plugin (e.g. 5 minutes like we talked about way above) is this such a problem?  I appreciate it may not be ideal or perfect for your ideal set up but then if it's good enough do you need more than that?



20 posts

Geek


  Reply # 176946 9-Nov-2008 17:41
Send private message

Thanks for the reply NZKC.

I'm happy to use MP as you have described with the 5 minute timeout and not being able to put the machine straight to sleep from the Main Menu - no worries. You might be right about the Powerscheduler keeping the machine from doing this - good point.

Thanks for the pointer on turning the TV off before exiting - that makes sense. I thought there might have been a setting to automatically shut the TV down when exiting My TV - much safer when the wife uses it!!

I have just checked a recording from yesterday and it has not worked, but will retest again now by not rebooting the machine.

Regards

Graham


81 posts

Master Geek


  Reply # 179618 23-Nov-2008 13:14
Send private message

Can someone point me to where I can download the Power Scheduler plugin?? The Media Portal plugins page doesn't seem to have anything, I've tried searching and browsing.

FYI, GBPVR automatically wakes the computer to record. I'm surprised MediaPortal doesn't do it out of the box.

Edit: never mind, I found it on the Plugins tab of the MediaPortal configuration. It's bundled with Media Portal.

-Matt


 1 | 2
View this topic in a long page with up to 500 replies per page Create new topic

Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

N4L helping TAKA Trust bridge the digital divide for Lower Hutt students
Posted 18-Jun-2018 13:08


Winners Announced for 2018 CIO Awards
Posted 18-Jun-2018 13:03


Logitech Rally sets new standard for USB-connected video conference cameras
Posted 18-Jun-2018 09:27


Russell Stanners steps down as Vodafone NZ CEO
Posted 12-Jun-2018 09:13


Intergen recognised as 2018 Microsoft Country Partner of the Year for New Zealand
Posted 12-Jun-2018 08:00


Finalists Announced For Microsoft NZ Partner Awards
Posted 6-Jun-2018 15:12


Vocus Group and Vodafone announce joint venture to accelerate fibre innovation
Posted 5-Jun-2018 10:52


Kogan.com to launch Kogan Mobile in New Zealand
Posted 4-Jun-2018 14:34


Enable doubles fibre broadband speeds for its most popular wholesale service in Christchurch
Posted 2-Jun-2018 20:07


All or Nothing: New Zealand All Blacks arrives on Amazon Prime Video
Posted 2-Jun-2018 16:21


Innovation Grant, High Tech Awards and new USA office for Kiwi tech company SwipedOn
Posted 1-Jun-2018 20:54


Commerce Commission warns Apple for misleading consumers about their rights
Posted 30-May-2018 13:15


IBM leads Call for Code to use cloud, data, AI, blockchain for natural disaster relief
Posted 25-May-2018 14:12


New FUJIFILM X-T100 aims to do better job than smartphones
Posted 24-May-2018 20:17


Stuff takes 100% ownership of Stuff Fibre
Posted 24-May-2018 19:41



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.