Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




360 posts

Ultimate Geek
+1 received by user: 3


Topic # 55457 4-Jan-2010 22:17
Send private message

Hi all!

There is a well known principle, that says that if it is working, don.t try to fix it. In other words, if you have MediaPortal 1.0.1.0 and it is working, I would not advise anyone to upgrade to 1.0.2.0. I tried it and it ruined everything.

Since then I completely removed 1.0.2 and reinstalled 1.0.1 but the error which started to appear under 1.0.2 still shows up now with 1.0.1.

The error consists of a windows showing up on top of Media Poprtal screen (fullscreen or not) and you cannot close that window at all, you cannot click anything on it, with the remote or the keyboard, you have to close MP to get rid of it. MediaPortal contines as usual behind that window, like it does not exist at all.

It says something like this:
"The number of returned rows 0 did not match the expected count of 1
If concurrency control is enabled this may indicate that ............"

It I start with Basic skin then the error window is named "MediaPortal - Basic skin".
If I start without "basic skin" ticked, then the error window is named "MediaPortal - fullscreen" but the content and the window behaviour is the same.

Where is this "concurrency control" feature and how can it be deactivated, as it appears it causes all this mess? I could not find any info about it.

I already have nearly 12 hours working on it, which means it pretty much ruined a full day and I will really appreciate any reply regarding this situation. I even installed some SQL editor to alter some values in a data base, which apprently fixed it for someone else back in 2009, but it did not work for me. I re-installed everything and the error still shows up.


Many thanks.






mobo Intel DH55PJ, RAM: 4GB RAM, Nova-T 500 HD + Avermedia Trinity tuner card, Geforce 520 video, 120GB SSD Sandisk + 640 WD + 1000SG, Win7 Home Prem 64-bit, Media Portal 1.15.0; BTC 9019URF Cordless Keyboard, Panasonic 55" (HDMI cable), HTPC Case Silverstone Grandia GD05B.


Create new topic
8019 posts

Uber Geek
+1 received by user: 385

Trusted
Subscriber

  Reply # 287038 4-Jan-2010 22:55
Send private message

Something to remember for next time: Before updating do a backup or disk image or take a system restore snapshot so you can roll back to the exact state of how things were before you ran the update.

2785 posts

Uber Geek
+1 received by user: 226


  Reply # 287046 4-Jan-2010 23:12
Send private message

Not sure why you had problems with 1.0.2 as I've been running it since it was released with no problems at all.
And that's also on Windows Home Server which is isn't even supported by MediaPortal.

Have you tried a System Restore to the last point before you did the upgrade?




 
 
 
 


1072 posts

Uber Geek
+1 received by user: 170


  Reply # 287114 5-Jan-2010 10:40
Send private message

Have you started with a new sql database?




2548 posts

Uber Geek
+1 received by user: 88


  Reply # 287177 5-Jan-2010 15:41
Send private message

reformat time maybe?

you should burn this cd and use acronus true image to do backups.
http://www.hiren.info/pages/bootcd




HTPC: Intel i3-2100 / 12GB RAM / AMD HD7750 / 480 GB SSD / 58TB Storage / MediaPortal / MadVR / Win10
AVR: Pioneer Elite SC-LX87 220W 9.2 Ch AVR
Speakers: Wharfedale Jade 7 Fronts / Jade 2c Center / Jade 5 Rears
Subs: iNuke 3000dsp 3000W proamp with 4x 15" JBL Sealed Subs
Display: Samsung 60" UA60H6400 LCD TV
Accessories: Gefen HDMI Detective with splitter


163 posts

Master Geek
+1 received by user: 5


  Reply # 287185 5-Jan-2010 16:07
Send private message

As mcraenz suggests, start a new database as it is definitely a database issue. I had this issue a while ago and hacked the database to fix it, but I can't remember quite what I needed to do at the time.

If you have schedules and things that you wish to keep, use the export function to save them to an XML file that you can then import into the new database.



360 posts

Ultimate Geek
+1 received by user: 3


  Reply # 288002 8-Jan-2010 07:20
Send private message

Thank you all for the replies.

A complete uninstall of the TV server and MP followed by fresh install fixed the problems, now working OK.

I still could not get the old recorded tv shows recognized by the new installation, I imported the database but only few shows were imported, I would say less than 10%. I had to declare the folder with the tv recordings under "My Videos" as well and go through there and play it as a "video" when I want. I really want to get them through "Mt TV -> Recorded". Mainly due to playback quality issues (all my "videos" are fairly low quality and the player is tuned to do the best job with this kind of file).

It has been mentioned to "start a new database". Do I just delete a certain file and MP will recreate it automatically at the next start up? Do I lose the skin installed?

Many thanks.





mobo Intel DH55PJ, RAM: 4GB RAM, Nova-T 500 HD + Avermedia Trinity tuner card, Geforce 520 video, 120GB SSD Sandisk + 640 WD + 1000SG, Win7 Home Prem 64-bit, Media Portal 1.15.0; BTC 9019URF Cordless Keyboard, Panasonic 55" (HDMI cable), HTPC Case Silverstone Grandia GD05B.


2548 posts

Uber Geek
+1 received by user: 88


  Reply # 288032 8-Jan-2010 09:09
Send private message

a complete uninstall + install would start a new database.

you don't need to import a database, just add the folder in tvserver config, and it will grab the details based on the .xml files, just point it to the old recording directory and select import.




HTPC: Intel i3-2100 / 12GB RAM / AMD HD7750 / 480 GB SSD / 58TB Storage / MediaPortal / MadVR / Win10
AVR: Pioneer Elite SC-LX87 220W 9.2 Ch AVR
Speakers: Wharfedale Jade 7 Fronts / Jade 2c Center / Jade 5 Rears
Subs: iNuke 3000dsp 3000W proamp with 4x 15" JBL Sealed Subs
Display: Samsung 60" UA60H6400 LCD TV
Accessories: Gefen HDMI Detective with splitter


Create new topic



Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

Vodafone TV — television in the cloud
Posted 17-Oct-2017 19:29


Nokia 8 review: Classy midrange pure Android phone
Posted 16-Oct-2017 07:27


Why carriers might want to embrace Commerce Commission study, MVNOs
Posted 13-Oct-2017 09:42


Fitbit launches Ionic, its health and fitness smartwatch
Posted 12-Oct-2017 15:52


Xero launches machine learning automation to improve coding accuracy for small businesses
Posted 12-Oct-2017 15:45


Bank of New Zealand uses Intel AI to detect financial crime
Posted 12-Oct-2017 15:39


Sony launches Xperia XZ1, a smartphone with real-time 3D capture
Posted 11-Oct-2017 10:26


Notes on Nokia’s phone comeback
Posted 10-Oct-2017 10:06


Air New Zealand begins Inflight Wi-Fi rollout
Posted 9-Oct-2017 20:16


The latest mobile phones in perspective
Posted 9-Oct-2017 18:34


Review: Acronis True Image 2018 — serious backup
Posted 8-Oct-2017 11:22


Lenovo launches ThinkPad Anniversary Edition 25
Posted 7-Oct-2017 23:16


Less fone, more tech as Vodafone gets brand make-over
Posted 6-Oct-2017 08:16


API Talent Achieves AWS MSP Partner Status
Posted 5-Oct-2017 21:20


Stellar Consulting Group now a Domo Partner
Posted 5-Oct-2017 21:03



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.