Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




21012 posts

Uber Geek
+1 received by user: 4154

Trusted
Subscriber

Topic # 56899 27-Jan-2010 22:32
Send private message

My machine is doing it on all HDD's occasionally, - basically the HDD light locks on solidly, the LED on one of my drives in the SATA bay comes on, and all disc access stalls for 20-60 seconds - then it comes right.

All drives are doing it, but it seems that the WD green ones are being affected more than the old seagate 500gig.

Have tried jumering drives to 150 meg mode incase its my cheap 90cm UV reactive SATA cables doing something dodgey between the mobo and the otehr case with all the drives in it.

Tried a new PSU for the drives, and also tried it on the computer. No change either way.

Am running AHCI mode if it matters. Anyone seen anything similar? Im going to get a PCI card and try that soon and see if it helps.




Richard rich.ms

Create new topic
217 posts

Master Geek
+1 received by user: 2


  Reply # 293726 28-Jan-2010 05:13
Send private message

So, the drives are in an external enclosure? Are they presented via some form of RAID controller in the external enclosure or are they just presented as the actual disks?

It doesn't sound like a cable problem - if there were problems with the cable you'd be getting read/write errors. It sounds more like power settings; have you checked the Power profile in Windows? See whether the disks are set to spin down after a certain amount of inactivity; it could be that it's just taking time to spin the disk up.



21012 posts

Uber Geek
+1 received by user: 4154

Trusted
Subscriber

  Reply # 293731 28-Jan-2010 06:33
Send private message

The are in another case, with 90cm cables thru a hole in the case.

First thing I do on any install is set everything to always on, so they shouldnt be spinning down, but being "green" they may be ignoring me.




Richard rich.ms

 
 
 
 


Try Wrike: fast, easy, and efficient project collaboration software
431 posts

Ultimate Geek
+1 received by user: 7

Trusted

  Reply # 293795 28-Jan-2010 10:11
Send private message

richms, I presume you're running Win7? There is an issue with the ACHI driver (msahci.sys) that causes it to lock for 60secs. The good news is that there is a hotfix available.

http://support.microsoft.com/k...

Hopefully that helps








21012 posts

Uber Geek
+1 received by user: 4154

Trusted
Subscriber

  Reply # 293806 28-Jan-2010 10:35
Send private message

Hmm, doesnt seem to want to install on 7100 which is what I am still using predominanlty since it has all my apps installed in it. When I reboot into RTM later I will give it a shot and see if it fixes it there. If it does will just have to get around to installing apps in the other install I guess...




Richard rich.ms

431 posts

Ultimate Geek
+1 received by user: 7

Trusted

  Reply # 293827 28-Jan-2010 11:19
Send private message

Yeah, you'll need to install it on the RTM (7600).






291 posts

Ultimate Geek


  Reply # 293867 28-Jan-2010 12:32
Send private message

richms: My machine is doing it on all HDD's occasionally, - basically the HDD light locks on solidly, the LED on one of my drives in the SATA bay comes on, and all disc access stalls for 20-60 seconds - then it comes right.


You don't happen to have atapi event 11 hardware controller error in the event log do you?

I saw similar symptoms on my 780g, with WD green. I have just replaced the drive to try and fix the issue, which seemed to be still there, but less deadly in IDE mode.




HTPC: Antec Fusion 430, Gigabyte GA-MA78GPM-UD2H F7, AMD X2 4850e, Sapphire 4670 1GB, Corsair 4x1Gb,  Adata 128Gb SSD, WD10EARS Green, LG GGC-H20L Blu-ray, Hauppauge NOVA TD-500, Logitech z-5500, Logitech Harmony 525, Samsung LA40B530 1080p, Vista Premium-32 SP2, Catalyst 10.12(Facelift preview), Mediaportal 1.2.3+OneButtonMusic, AC3Filter, Cyberlink Powercinema 6 codec, BLU-RAY: Samsung BD-F7500



21012 posts

Uber Geek
+1 received by user: 4154

Trusted
Subscriber

  Reply # 294052 28-Jan-2010 18:43
Send private message

I get lots of

The driver detected a controller error on \Device\RaidPort0.

The device, \Device\Harddisk2\DR2, is not ready for access yet.
The device, \Device\Harddisk4\DR43, is not ready for access yet.





Richard rich.ms

237 posts

Master Geek
+1 received by user: 2


  Reply # 294066 28-Jan-2010 19:01
Send private message

recently while searching for information in regard to network drives, I found lots of references to WD refusing to spin down and that was causing an error to be generated.... sorry I can't help with any URL's of sites I found at the time

Create new topic



Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

Lightbox updates platform with new streaming options
Posted 17-May-2018 13:09


Norton Core router launches with high-performance, IoT security in New Zealand
Posted 16-May-2018 02:00


D-Link ANZ launches new 4G LTE Dual SIM M2M VPN Router
Posted 15-May-2018 19:30


New Panasonic LUMIX FT7 ideal for outdoor: waterproof, dustproof
Posted 15-May-2018 19:17


Ryanair Goes All-In on AWS
Posted 15-May-2018 19:14


Te Papa and EQC Minecraft Mod shakes up earthquake education
Posted 15-May-2018 19:12


Framing Facebook: It’s not about technology
Posted 14-May-2018 16:02


Vocus works with NZ Police and telcos to stop scam calls
Posted 12-May-2018 11:12


Vista Group signs Aeon Entertainment, largest cinema chain in Japan
Posted 11-May-2018 21:41


New Privacy Trust Mark certifies privacy and customer control
Posted 10-May-2018 14:16


New app FIXR connects vehicle owners to top Mechanics at best prices
Posted 10-May-2018 14:13


Nutanix Beam gives enterprises control of the cloud
Posted 10-May-2018 14:09


D-Link ANZ launches Covr Seamless Wi-Fi System
Posted 10-May-2018 14:06


Telstra, Intel and Ericsson demonstrate a 5G future for esports
Posted 10-May-2018 13:59


Spark introduces Android One with Nokia 7 plus and Nokia 6.1
Posted 8-May-2018 05:00



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.