Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.


10 posts

Wannabe Geek

Trusted
Spark NZ

Topic # 58607 15-Mar-2010 22:36
Send private message

Guys, I need your help.

Having recently switched from Win7-64 RTM to the Retail version of Win7-64, I'm now having problems getting the Hauppauge HVR2200 to find the channels it was happily using a few weeks ago.

I've tried about every driver I can find for the 2200, and every combination of remove and reinstall the device I can think of. The same hardware was running fine under the release to manufacture version of Win7, the retail version is what is killing me here. I must have missed something obvious in my quest to get things working yet when performing a 'TV Channel Scan' I consistently get 'No channels were found. Make sure your TV equipment is properly connected to the computer' (it is, and it's the same setup as previously working)

WAF* is eroding fast so please, hit me with your ideas on how to make Media Center find my Freeview channels under Windows 7 Ultimate, 64-bit...

Cheers,


Rob

*WAF - Wife Approval Factor, the most important determining factor in current technology adoption and future financing in this house.

Create new topic
670 posts

Ultimate Geek
+1 received by user: 46

Trusted

  Reply # 307611 15-Mar-2010 22:49
Send private message

have the same card, and OS,
Not much help but i use driver: 7.6.27.27323 off the hauppauge.co.uk site i think.



10 posts

Wannabe Geek

Trusted
Spark NZ

  Reply # 307767 16-Mar-2010 12:08
Send private message

Great - thanks, I think I've tried that one, but no harm in running HWClear and trying again :)

--- Edit ---

Okay, it wasn't the driver - uninstalled via HCWClear, rebooted, reinstalled manually via Device manager, rebooted - setup the tuners - and still 'No Channels Found'

BUT - Then I found and tried this:
http://www.hack7mc.com/2009/09/clearing-guide-data-and-tuner-setup-from-windows-7-media-center.html

which *worked* ! :) - Essentially, it appears that the tuner / guide database was corrupted/sutffed/whatever and so, deleting it and re-running from scratch worked (YAY!)

In the interests of replication should the above link stop working, there are two ways to delete the database and start from scratch.

The Long Way
1) Quit Media Center
2) Start 'Task Manager', Click the 'Services' tab and click the 'Processes' button
3) Stop the 'Windows Media Center Receiver' and 'Windows Media Center Scheduler' services
4) Switch back to 'Task Manager' and open the 'Processes' tab.
4a) Stop the eh*.exe processes
4b) Stop the mcGlidHost.exe process
5) Open explorer, and navigate to "C:\ProgramData\Microsoft\ehome" (it's a sneaky hidden directory)
6) Delete the file mcepgX-X-X.db (where X-X-X is some kind of version)
7) Delete the directory mcepgX-X-X
8) Reboot
9) Cross everything that can be crossed, make sure the moon is in the right part of it's orbit, chant the right incantations and restart Media Center - you'll be starting your TV tuning from scratch now... good luck.

The Short Way
1) Quit Media Center
2) Open Task Scheduler -> Microsoft -> Windows -> Media Centre.
3) Manually run the MCERecoveryTask
Or
2) Open an elevated command prompt
3) run "mcupdate -MediaCenterRecoveryTask"

I can't confirm the short way, but it's far less painful so perhaps someone with a similar problem can try that first and post their findings...

Create new topic

Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

Intel introduces new NUC kits and NUC mini PCs
Posted 16-Aug-2018 11:03


The Warehouse leaps into the AI future with Google
Posted 15-Aug-2018 17:56


Targus set sights on enterprise and consumer growth in New Zealand
Posted 13-Aug-2018 13:47


Huawei to distribute nova 3i in New Zealand
Posted 9-Aug-2018 16:23


Home robot Vector to be available in New Zealand stores
Posted 9-Aug-2018 14:47


Panasonic announces new 2018 OLED TV line up
Posted 7-Aug-2018 16:38


Kordia completes first live 4K TV broadcast
Posted 1-Aug-2018 13:00


Schools get safer and smarter internet with Managed Network Upgrade
Posted 30-Jul-2018 20:01


DNC wants a safer .nz in the coming year
Posted 26-Jul-2018 16:08


Auldhouse becomes an AWS Authorised Training Delivery Partner in New Zealand
Posted 26-Jul-2018 15:55


Rakuten Kobo launches Kobo Clara HD entry level reader
Posted 26-Jul-2018 15:44


Kiwi team reaches semi-finals at the Microsoft Imagine Cup
Posted 26-Jul-2018 15:38


KidsCan App to Help Kiwi Children in Need
Posted 26-Jul-2018 15:32


FUJIFILM announces new high-performance lenses
Posted 24-Jul-2018 14:57


New FUJIFILM XF10 introduces square mode for Instagram sharing
Posted 24-Jul-2018 14:44



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.