Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.


33 posts

Geek


Topic # 58720 17-Mar-2010 20:24
Send private message

Hi all,

I've been using Mediaportal and mentalindustries EPG grabber utility for the last couple of years. Absolutely brilliant!

I noticed yesterday my guide was about to run out, and noticed that my tvguide.xml hasn't been updated since last Wednesday (I have a daily scheduled task).

I forced a run of the task, and this seems to be what comes back:

---------------------------------------------------------------------------------------------

C:\Documents and Settings\DVINE HTPC>"C:\Program Files\Team MediaPortal\MediaPor
tal TV Server\freeviewNZ-EPG.exe" -mediaportalTVServer
Finding install paths
System.NullReferenceException: Object reference not set to an instance of an obj
ect.
at freeviewNZ_EPG.Program.findInstallPaths()
EPG file to download: http://epg.pvr.geek.nz/epg/listings-freeview.xml.gz
EPG file location: tvguide.xml
Freeview Product Detection Complete. Now downloading XML file
epgXMLLocation tvguide.xml
Download location: C:\Documents and Settings\DVINE HTPC\listings-freeview.xml.gz


Folder to create: C:\Documents and Settings\DVINE HTPC
Error the EPG download folder does not exist!
Folder now created: C:\Documents and Settings\DVINE HTPC
Checking xmltv.dtd is in the correct folder
xmltv.dtd found.

System.Net.WebException: The remote name could not be resolved: 'epg.pvr.geek.nz
'
at System.Net.WebClient.DownloadFile(Uri address, String fileName)
at System.Net.WebClient.DownloadFile(String address, String fileName)
at freeviewNZ_EPG.Program.Main(String[] args)

-------------------------------------------------------------------------------------------------------

As I say, this has been working for months with no issues. I haven't changed any settings or installed any software in the last few weeks. It seems as if my PC isn't gettng a connection through to the pvr.geek.nz site.

I've tried disabling my firewall (Zonealarm) in case that was causing any issues, and also reset my router. I can't seem to get through to pvr.geek.nz (if I type that into firefox) on either my HTPC or laptop - should I be able to?

Does anyone have any ideas what I might need to do to sort ths out? Anyone else having similar problems??

Thanks in advance,
Danny

Create new topic
483 posts

Ultimate Geek

Trusted

  Reply # 308457 17-Mar-2010 20:26
Send private message


33 posts

Geek


  Reply # 308497 17-Mar-2010 21:56
Send private message

OK, now it makes more sense!!

My quick search never brought up that thread, thanks for pointing me in that direction.

I am now using rvangelders solution - and everything seems to be working fine!!

http://vangelder.orcon.net.nz/files/FreeviewToXMLTV.zip


Cheers,
Danny

Create new topic

Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.