Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




64 posts

Master Geek
+1 received by user: 5


Topic # 60761 2-May-2010 20:56
Send private message

Hi all, first off thank you to everyone involved for the wealth of info and special thanks to forum members who have taken time to compile all this info in one place.

I've been trying to get my jaycar reader working with NewCS and need some help on this. 

MySetup:
- Win7 x64 (X2 5000+ / Core 2 Duo)
- Jaycar reader with Diode Mod and Inverse Mod
- Jaycar reader without any mods
- Sunix Serial PCI card
- USB to Serial (FTDI chipset) 
- Sun VirtualBox with ClearOS

I have built 2 readers, one with the two mods described above and one without. Both the builds have been tested using a magnifying lens to ensure correct resistor values including tests with a multimeter before and after soldering.

Issue: 

Both the readers seem to work the first time (First test after the build). i can get the keys off NewCS (1.65 on Core2 and 1.67RC1 on X2 w/ ClearOS). Once I removed the card and inserted it again, NewCS doesn't seem to work. Also the yellow LED is not fully bright. At this point all I get is "rest failed" messages. If I disconnect power (tested with 12 V plug pack and internal PSU power), insert the card first and then apply power, the yellow LED is bright and now instead of "reset failed" messages, I get "Card 0900 on Com1 failed".

My card is recent myS*yHdi NZ45XX. I have tried pulling the card out by 1mm but no luck there. As stated above, the reader worked out of the box the first time. I'm out of ideas.

Questions:

- Has anyone experienced this before. Working the first time and not again?
- Does your yellow LED on the reader changes intensity when you pull out and re-insert the card?
- Any suggestions you might have which could help me resolve my issue. Thanks for reading.
 

Create new topic


64 posts

Master Geek
+1 received by user: 5


  Reply # 329941 13-May-2010 22:15
Send private message

bump..anyone?

483 posts

Ultimate Geek

Trusted

  Reply # 329961 13-May-2010 23:15
Send private message

NewCS likes to lock the serial port after being shutdown.

This prevents itself and any other app from getting access to the serial port.

You can fix it by either disabling/re-enabling the serial port after every restart or by rebooting every time you take the card out.

If you need to remove the card power down before you reinsert it. This will reset both the Jaycar reader and the serial port.


 
 
 
 


Try Wrike: fast, easy, and efficient project collaboration software


64 posts

Master Geek
+1 received by user: 5


Reply # 335947 28-May-2010 21:06
Send private message

Thanks Rusty.

I finally managed to get it to work. The issue was with the usb-> serial cable and the Sunix PCI serial card. I got hold of a DSE usb-> serial and I can confirm everything works on a Win7 x64 using NewCS 1.65 and 1.67 RC1 on a linux VM.

 



64 posts

Master Geek
+1 received by user: 5


  Reply # 338376 4-Jun-2010 20:47
Send private message

Hi all, a little embarrassed to admit this but the issue was with the serial cable. I had bought one off trademe for $4 and later when tried a "decent" cable, did not need the usb->serial adapter. In case any of you are having issues with your readers, make sure you test your cable first Embarassed

Create new topic



Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

Amazon launches the International Shopping Experience in the Amazon Shopping App
Posted 19-Apr-2018 08:38


Spark New Zealand and TVNZ to bring coverage of Rugby World Cup 2019
Posted 16-Apr-2018 06:55


How Google can seize Microsoft Office crown
Posted 14-Apr-2018 11:08


How back office transformation drives IRD efficiency
Posted 12-Apr-2018 21:15


iPod laws in a smartphone world: will we ever get copyright right?
Posted 12-Apr-2018 21:13


Lightbox service using big data and analytics to learn more about customers
Posted 9-Apr-2018 12:11


111 mobile caller location extended to iOS
Posted 6-Apr-2018 13:50


Huawei announces the HUAWEI P20 series
Posted 29-Mar-2018 11:41


Symantec Internet Security Threat Report shows increased endpoint technology risks
Posted 26-Mar-2018 18:29


Spark switches on long-range IoT network across New Zealand
Posted 26-Mar-2018 18:22


Stuff Pix enters streaming video market
Posted 21-Mar-2018 09:18


Windows no longer Microsoft’s main focus
Posted 13-Mar-2018 07:47


Why phone makers are obsessed with cameras
Posted 11-Mar-2018 12:25


New Zealand Adopts International Open Data Charter
Posted 3-Mar-2018 12:48


Shipments tumble as NZ phone upgrades slow
Posted 2-Mar-2018 11:48



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.