Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




9 posts

Wannabe Geek


# 110640 12-Oct-2012 21:26
Send private message

I'm having problems connecting to my newly-installed Snap! UFB.  Being a student I couldn't afford a Fritz!Box so chucked DD-WRT on my Linksys WRT320N instead.  Have gone through and configured it for PPPoE with VLAN tagging (VLAN 10) but can't even get a WAN address.  Has anyone had experience with Snap! and DD-WRT?

Create new topic
8035 posts

Uber Geek

Trusted

  # 700690 13-Oct-2012 16:56
Send private message

Best bet it to ring the helpdesk they will be able to check whether PPP authentication requests are being received etc, may just be wrong username/password for example.

2411 posts

Uber Geek

Trusted
Subscriber

  # 700715 13-Oct-2012 17:59
Send private message

I may be incorrect but I thought SNAP weren't using any authentication at present

 
 
 
 




9 posts

Wannabe Geek


  # 700732 13-Oct-2012 18:43
Send private message

Helpdesk just told me to set my router up with PPPoE and vlan tagging (vlan 10). I've done this but no luck so far, might ring them again and ask about the auth packet thing but in general they aren't too enthusiastic about anything other than a Fritz!Box - understandable but irritating

824 posts

Ultimate Geek

Trusted

  # 700749 13-Oct-2012 20:18
Send private message

If they aren't using PPPoE on VLAN 10, try it on DHCP? Or on DHCP VLAN 10?
You could try connecting your computer directly to the ONT, and configuring it to use PPPoE + VLAN tagging, and see if that works?



9 posts

Wannabe Geek


  # 700758 13-Oct-2012 21:10
Send private message

They're definately using PPPoE, called the helpdesk and theirs logs are showing no connection attempts from me at all (user/pw are definitely correct as I was logging onto the customer area of their site). I can't just use my PC to connect either because I can't get Windows 7 to do vlan tagging which is incredibly annoying. I'm just going to keep screwing with it and see if something happens

28571 posts

Uber Geek

Moderator
Trusted
Biddle Corp
Lifetime subscriber

  # 700780 13-Oct-2012 22:22
Send private message

Does the WRT320N support 802.1q / VLAN on the WAN interface? It's not a supported feature on all DD-WRT hardware.




9 posts

Wannabe Geek


  # 700791 13-Oct-2012 22:45
Send private message

Yep it does, Im posting this from my phone so can't link you the page but the DD-WRT wiki says it should be sweet. However after further investigation it looks like I might need to get my hands dirty and SSH into it as some extra stuff needs to be set behind the GUI. Will try this tomorrow as my flatmates are relying on the router for wifi access to our adsl box and I don't think they'll tolerate another outage tonight

 
 
 
 


1387 posts

Uber Geek


  # 700801 13-Oct-2012 23:13
Send private message

if you have a linux box i think you should be able to do something like

vconfig add eth0 10
pppoe -I eth0.10 -A

And see the access concentrator name.

With ddwrt I imagine it's similar, but you should already have a eth0.10

I've only done vlan10/pppoe with adsl though.

If that works fine, can start to get through pppoe debugging.

I'd generally start with the userspace straight pppoe suppor before shifting to the kernel level stuff. Kernel stuff is meant to be higher performance but the user space stuff has better debugging.




9 posts

Wannabe Geek


  # 875647 12-Aug-2013 10:10
Send private message

Sorry for the necro-post but I should really post a conclusion (of sorts). I ended up giving up on DD-WRT and bought the Fritz!Box as it was better than my router anyway. I've been pretty happy with it, however I did notice that torrenting could mess up DLNA streaming to my tablet (would get progressively slower) that was only fixed by a router reset. This seems to have been fixed by the latest firmware update (for me anyway).

3524 posts

Uber Geek

Trusted

  # 875654 12-Aug-2013 10:19
Send private message

I am pretty sure the VLAN tagging has nothing to do with your OS but rather your NIC. Have you gone into the advanced properties of it? And yea wouldn't surprise me if you need to do it via SSH.




Speedtest 2019-10-14


152 posts

Master Geek


  # 876636 13-Aug-2013 17:56
Send private message

only way i've ever seen VLAN tagging work in windows is using vendor software (this then creates a virtual LAN adapter so you can configure it seperately)

dan

1148 posts

Uber Geek

Lifetime subscriber

  # 878827 15-Aug-2013 14:16
Send private message

scalt: They're definately using PPPoE, called the helpdesk and theirs logs are showing no connection attempts from me at all (user/pw are definitely correct as I was logging onto the customer area of their site). I can't just use my PC to connect either because I can't get Windows 7 to do vlan tagging which is incredibly annoying. I'm just going to keep screwing with it and see if something happens



I got the windows 7 dialer pppoe working OK on Snap UFB today, all i had to do was set in advanced options of the network card properties, VLAN = 10 and then all the
default PPPoE dialer settings were fine, using the snap username and password

seems to be PAP connection, CHAP and CHAP v2 wouldn't connect.



15 posts

Geek


  # 884601 26-Aug-2013 12:16
Send private message

So just to help anyone else out there trying to get Snap or any other NZ UFB connection that uses 802.1q VLAN tags working with an off the shelf router..

I spent 5 hours solid the other night trying to get my new Asus RT-N66U (Dark Knight) working with Snap UFB.

I tried with the stock firmware, latest build (no UI to configure VLANs), Merlin's version of the Asus firmware (tells you what VLANs each port is on, but doesn't let you change in the UI) and finally ddwrt.

According to the information out there, the ddwrt VLAN UI pages don't work reliably so you need to go tweak nvram settings manually. It occurred to me that maybe I could have done this with the stock firmware or Merlin's version but whatever.

Resources I used are here:

http://www.dd-wrt.com/wiki/index.php/Switched_Ports
http://www.dd-wrt.com/wiki/index.php/Reconfigure_VLANs_for_802.1q_Compatibility

Unfortunately even though I followed everything to the letter - as far as I could tell - I still couldn't get it working!

Key settings are:

nvram set vlan10hwname=et0
nvram set vlan10ports="0t 8"
nvram set wan_ifname=vlan10

Then

nvram commit
reboot

These lines should set up VLAN10 on port 0 (the WAN port). The 't' means tag packets as per 802.1q. 

Unfortunately on my router the final line assigning the WAN interface to VLAN10 gets reset to the default VLAN on reboot. I added a line to the startup script to change it back, which I think helped, but then I got an error when I ran startservice wan to say that vlan10 couldn't be found.  There's more info about why I had to do this in the second link I posted above. 

A few people on the interwebs reported similar lines working fine on tomato, so I downloaded shibby's latest tomato build, configured VLAN10 tagging on the WAN port in the UI and it Just Worked... first time.

In summary, use tomato.


If anyone else has got ddwrt to work successfully with VLAN tagging of the WAN side then by all means tell me what I'm doing wrong!  FTTH is becoming more common worldwide and by the sounds of it plenty of ISPs are using VLAN tags in this way (Googling turned up other people trying to do this in the Netherlands, Sweden, Canada, the US), so surely it should be supported?!

824 posts

Ultimate Geek

Trusted

  # 884806 26-Aug-2013 16:03
Send private message

You can change the VLAN on the stock N66u (and N16) firmware. When you go through the connection wizard it'll ask you if there are any special requirements. You select VLAN 10 tagging in here.
It can also be set under the IPTV settings (Not sure why it's hidden in here. Presumably some overseas ISPS use VLAN tagging for IPTV services).

15 posts

Geek


# 884978 26-Aug-2013 21:17
Send private message

Hah, must have missed that .. thanks 

Create new topic



Switch your broadband provider now - compare prices


Twitter and LinkedIn »



Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

Vodafone integrates eSIM into device and wearable roadmap
Posted 17-Jan-2020 09:45


Do you need this camera app? Group investigates privacy implications
Posted 16-Jan-2020 03:30


JBL launches headphones range designed for gaming
Posted 13-Jan-2020 09:59


Withings introduces ScanWatch wearable combining ECG and sleep apnea detection
Posted 9-Jan-2020 18:34


NZ Police releases public app
Posted 8-Jan-2020 11:43


Suunto 7 combine sports and smart features on new smartwatch generation
Posted 7-Jan-2020 16:06


Intel brings innovation with technology spanning the cloud, network, edge and PC
Posted 7-Jan-2020 15:54


AMD announces high performance desktop and ultrathin laptop processors
Posted 7-Jan-2020 15:42


AMD unveils four new desktop and mobile GPUs including AMD Radeon RX 5600
Posted 7-Jan-2020 15:32


Consolidation in video streaming market with Spark selling Lightbox to Sky
Posted 19-Dec-2019 09:09


Intel introduces cryogenic control chip to enable quantum computers
Posted 10-Dec-2019 21:32


Vodafone 5G service live in four cities
Posted 10-Dec-2019 08:30


Samsung Galaxy Fold now available in New Zealand
Posted 6-Dec-2019 00:01


NZ company oDocs awarded US$ 100,000 Dubai World Expo grant
Posted 5-Dec-2019 16:00


New Zealand Rugby Selects AWS-Powered Analytics for Deeper Game Insights
Posted 5-Dec-2019 11:33



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.


Support Geekzone »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.