Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




26 posts

Geek


Topic # 122098 24-Jun-2013 19:44

I recently purchased a 2 degrees pre-pay sim for use in my son's iphone 3GS- for the 1st couple of weeks, all was good, but suddenly the phone says 'no service' and it does not receive any signal at all!
I have put the sim in an old blackberry and the sim works in that, but does not work in the iphone....

Similarly, I have put a Vodafone SIM into the Iphone 3GS, and that works fine in that as well, so the handset and the sim card seem to appear to fully work when swapped around......does anyone have any ideas as to why the Iphone 3GS does not work with the 2 degrees sim?

Create new topic
734 posts

Ultimate Geek
+1 received by user: 27

Trusted

  Reply # 843592 24-Jun-2013 19:57
Send private message

Could be the phone didn't have the 2degrees carrier pack properly installed by iTunes. 

http://www.iphonewzealand.co.nz/iphone-settings/manual-carrier-settings/

Simply enter all those details and it should work




Homebuilt High Performance Desktop: Windows 10 Professional (x64)
Toshiba Encore Write 2: Windows 10
Nokia 930: Windows Phone 10
Samsung Tab4 7": Android Lolipop
XBL: CruciasNZ
PSN: CruciasNZ
Steam: Lienhart2005




26 posts

Geek


  Reply # 843598 24-Jun-2013 20:09

I think that this refers to data settings only doesn't it?...it can't even pick up a 2g phone signal..- just 'no service' 

 
 
 
 


5108 posts

Uber Geek
+1 received by user: 1222

Moderator
Trusted
Lifetime subscriber

  Reply # 843636 24-Jun-2013 21:20
Send private message

Restore it in iTunes.

1235 posts

Uber Geek
+1 received by user: 154


  Reply # 843696 24-Jun-2013 22:28
Send private message

Strange, could be a number of things

if the 2degrees site you're connecting to is a 900mhz 3G only site then you'll get no coverage because the 3GS has no 900mhz 3G support.

The IMEI could have been blocked on 2degrees

Could be a radio/antenna fault inside the phone.

2515 posts

Uber Geek
+1 received by user: 541
Inactive user


  Reply # 843754 25-Jun-2013 06:56
Send private message

Is data roaming turned on?

Where I live there is no 2D towers, and it is pretty hit and miss if he sim card works.

I might have to change her over to Vodafone for ease of use, I will look at the carrier pack that is installed on her phone as well.

105 posts

Master Geek


  Reply # 843807 25-Jun-2013 09:23
Send private message

Try to reset the network settings first. Settings > General > Reset > Reset Network Settings. After the restart you need to connect to your home wireless modem/router again.



26 posts

Geek


  Reply # 845755 26-Jun-2013 20:42

it connects fine to the wifi.....the phone signal is the problem



26 posts

Geek


  Reply # 845756 26-Jun-2013 20:43

data roaming is switched on.....vodafone and Telecom sim work fine, no problem

2027 posts

Uber Geek
+1 received by user: 791

Trusted

  Reply # 845764 26-Jun-2013 21:06
Send private message

Verify with 2Degrees that the IMEI (you can find this by dialing *#06#) hasn't been blacklisted.

Create new topic



Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.


Geekzone Live »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.