Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.


489 posts

Ultimate Geek
+1 received by user: 68

Lifetime subscriber

Topic # 127227 3-Aug-2013 08:28
Send private message

I recently switched to Snap VDSL, and took advantage of getting a Fritz.Box at a good price. Overall it's working well other than the following issue I'm having trouble solving.

I have a Western Digital Mybook Live NAS plugged into one of the Fritz's Ethernet ports. In the Mybook Live, I've given the device a friendly name, and usually I can access its web UI from a browser, and map drives letters in Windows, using this friendly name.

This all works fine with the Fritz.Box for a while, but eventually, if I attempt to visit the UI for the drive in my browser, or access any of the drive letters I have mapped in Windows, they cannot be found. Rebooting the Fritz.Box restores everything to normal again for a little while, then the issue repeats.

When things get into this state, I can visit the web UI of the Mybook Live by entering its IP address, so I know the device hasn't lost contact with the router. It's also showing up fine in the Fritz.Box's UI. I've assigned it a static IP, not really knowing what else to try, but that's made no difference.

Is there some configuration issue I've overlooked here that would be causing this?

Obviously the Mybook is the hub of all our media, so having it not integrating with the router properly is a big issue, and if I can't resolve this I'll need to revert to the VDSL modem I was using before.

Would appreciate any suggestions, thanks.




Jonathan Mosen

 

Mosen Consulting, for advice on web and app accessibility

 

http://mosen.org

Create new topic
539 posts

Ultimate Geek
+1 received by user: 105


  Reply # 871113 3-Aug-2013 10:38
Send private message

Hi,

When you setup the static IP did you make the DNS server the fritz.box?


3588 posts

Uber Geek
+1 received by user: 1318

Subscriber

  Reply # 871573 4-Aug-2013 14:31
Send private message

Are your devices (laptops etc) getting assigned the Fritz's IP as the DNS server?
The Fritz will take a host name and make a DNS record from that device when it gives out the DHCP lease. So I would suggest make the NAS get an address by DHCP and then just use that host name to map all your dirves. You could then assign a static mapping to the NAS so it always gets the same IP but it wouldn't matter because you will have the devices mapped with the host name rather than the IP.
Just go in to the 'Home Network' section of the Fritz and then just hit the edit button next to the NAS's DHCP lease. From there you can edit the common name to be the one you want to use for mappings.

Create new topic

Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.